INFO: Dieses Forum nutzt Cookies...
Cookies sind für den Betrieb des Forums unverzichtbar. Mit der Nutzung des Forums erklärst Du dich damit einverstanden, dass wir Cookies verwenden.

Es wird in jedem Fall ein Cookie gesetzt um diesen Hinweis nicht mehr zu erhalten. Desweiteren setzen wir Google Adsense und Google Analytics ein.

Antwort schreiben 
 
Themabewertung:
  • 0 Bewertungen - 0 im Durchschnitt
  • 1
  • 2
  • 3
  • 4
  • 5
void Setup startet nicht
11.11.2014, 20:08
Beitrag #1
void Setup startet nicht
Hi Leute,
warum auch immer, aber die Setup scheint nicht zu starten. Eigentlich sollte der Code ja dazu führen, dass im Serial Monitor "BeginnSetup" ausgeworfen wird.. Statt dessen kommt die Meldung "Be(".... Was auch immer das heißen soll. Hier der Code (ein paar Routinen stehen noch auf anderen Registerkarten, aber das sollte hier ja keine Rolle spielen, oder?)(:
#include <Wire.h>
#define I2C1 0x20
#define I2C2 0x21
#define I2CMEMORY 0x50
#define GPIOA 0x12
#define GPIOB 0x13
#define IODIRA 0x00
#define IODIRB 0x01

#define GERADE 0
#define AUSSCHLAG 1

int GBM4[] = {17,0};
int Weiche3_0[] = {12,0};
int Weiche3_1[] = {13,0};
int ASF2[] = {3,0};
int I2CNum[17];
int I2CSide[17];
int I2CPin[17];

int WeichenStellung3[] = { 0,0};

void setup() {

Serial.begin(9600);

Serial.println("BeginnSetup");
Initialisieren();
Wire.begin();


Wire.beginTransmission(I2C1);
Wire.write(IODIRA);
Wire.write(0x00); // Alle als Ausgänge festlegen
Wire.endTransmission();

Wire.beginTransmission(I2C1);
Wire.write(IODIRB);
Wire.write(0x00);
Wire.endTransmission();

Serial.println("setup 1/2");

Wire.beginTransmission(I2C2);
Wire.write(IODIRA);
Wire.write(0B00000010);
Wire.endTransmission();

Wire.beginTransmission(I2C2);
Wire.write(IODIRB);
Wire.write(0x00);
Wire.endTransmission();
}


Hat jemand ne Idee, warum das nicht funktioniert?
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
11.11.2014, 20:42
Beitrag #2
RE: void Setup startet nicht
Hallo und herzlich willkommen.

Ist die Baudrate im Serial Monitor auch auf 9600 eingestellt?

Gruß
Arne

Gruß Arne
ExclamationMit zunehmender Anzahl qualifizierter Informationen bei einer Problemstellung, erhöht sich zwangsläufig die Gefahr auf eine zielführende Antwort.Exclamation
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
15.11.2014, 20:51
Beitrag #3
RE: void Setup startet nicht
Hallo
Mach mal Serial.Println("1 nächste erhöhen"); zwischen die Zeilen, damit du weißt, bei welcher Zeile er sich festnagt ;-)
Gruß Joe

Unser Projekt Rolleyes https://global-science-circle.net http://global-science-circle.info http://global-science-circle.de http://radio-gsc1.info und neuerdings https://gch.global https://entsalzung.gch.global
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
Antwort schreiben 


Möglicherweise verwandte Themen...
Thema: Verfasser Antworten: Ansichten: Letzter Beitrag
  TFT Display will nicht so wie ich Franzel007 10 318 12.05.2018 09:28
Letzter Beitrag: amithlon
  Neuling kommt nicht weiter, ws2812 If abfragen Tabata 8 670 19.04.2018 14:07
Letzter Beitrag: Tommy56
  millis() zählt nicht weiter sowerum 8 538 09.04.2018 17:55
Letzter Beitrag: Tommy56
  Windmesser auslesen will noch nicht so recht klappen.. Stargazer 12 648 05.04.2018 10:54
Letzter Beitrag: amithlon
  void value not ignored as it ought to be Tudorf 2 213 03.04.2018 04:51
Letzter Beitrag: Tudorf
  Bootlader Brennen funktioniert nicht Ardusil 6 466 18.03.2018 10:53
Letzter Beitrag: hotsystems
  Bool wird nicht umgesetzt Wampo 3 343 10.03.2018 23:04
Letzter Beitrag: Tommy56
  NTC für LCD-Anzeige.Weiter bekomme ich nicht hin malsehen 17 1.071 09.03.2018 20:28
Letzter Beitrag: malsehen
  328P geht nicht mehr [gelöst] Harry 37 2.696 04.03.2018 19:57
Letzter Beitrag: Harry
  UDP Paket über UART senden (nicht SPI) Wampo 9 669 04.03.2018 18:49
Letzter Beitrag: Tommy56

Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste