INFO: Dieses Forum nutzt Cookies...
Cookies sind für den Betrieb des Forums unverzichtbar. Mit der Nutzung des Forums erklärst Du dich damit einverstanden, dass wir Cookies verwenden.

Es wird in jedem Fall ein Cookie gesetzt um diesen Hinweis nicht mehr zu erhalten. Desweiteren setzen wir Google Adsense und Google Analytics ein.

Antwort schreiben 
 
Themabewertung:
  • 0 Bewertungen - 0 im Durchschnitt
  • 1
  • 2
  • 3
  • 4
  • 5
led geht nicht vollsändig aus
02.02.2014, 18:26
Beitrag #1
led geht nicht vollsändig aus
Hallo, vrwende diesen sketch, verstehe nicht warum die led nicht komplett ausgeht, sondert nur etwas heller oder dunkler wird. Wird der Pin nicht auf LOW gesetzt?[/code]
[const int buttonPin = 3;
const int ledPin = 13;
int buttonState = 0;

void setup() {
pinMode(ledPin, OUTPUT);
pinMode(buttonPin, INPUT);
}

void loop(){
buttonState = digitalRead(buttonPin);
if (buttonState == HIGH) {
digitalWrite(ledPin, HIGH);
}
else {
digitalWrite(ledPin, LOW);
}
}]
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
02.02.2014, 19:44
Beitrag #2
RE: led geht nicht vollsändig aus
nein, ich sehe dafür keinen Grund. Hast du einmal die Spannung am Eingang gemessen?

Dann, warum definierst du diese Variablen als Konstanten? Und verbrätst dafür ein ganzes Wort?


(02.02.2014 18:26)Coleby schrieb:  Hallo, vrwende diesen sketch, verstehe nicht warum die led nicht komplett ausgeht, sondert nur etwas heller oder dunkler wird. Wird der Pin nicht auf LOW gesetzt?[/code]
[const int buttonPin = 3;
const int ledPin = 13;
int buttonState = 0;

void setup() {
pinMode(ledPin, OUTPUT);
pinMode(buttonPin, INPUT);
}

void loop(){
buttonState = digitalRead(buttonPin);
if (buttonState == HIGH) {
digitalWrite(ledPin, HIGH);
}
else {
digitalWrite(ledPin, LOW);
}
}]

Gruß, Stefan . . . . . . //Wo mein Kölbchen dampft, da bin ich unverkrampft.
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
02.02.2014, 20:07
Beitrag #3
RE: led geht nicht vollsändig aus
(02.02.2014 19:44)Stefan schrieb:  nein, ich sehe dafür keinen Grund. Hast du einmal die Spannung am Eingang gemessen?

Dann, warum definierst du diese Variablen als Konstanten? Und verbrätst dafür ein ganzes Wort?


(02.02.2014 18:26)Coleby schrieb:  Hallo, vrwende diesen sketch, verstehe nicht warum die led nicht komplett ausgeht, sondert nur etwas heller oder dunkler wird. Wird der Pin nicht auf LOW gesetzt?[/code]
[const int buttonPin = 3;
const int ledPin = 13;
int buttonState = 0;

void setup() {
pinMode(ledPin, OUTPUT);
pinMode(buttonPin, INPUT);
}

void loop(){
buttonState = digitalRead(buttonPin);
if (buttonState == HIGH) {
digitalWrite(ledPin, HIGH);
}
else {
digitalWrite(ledPin, LOW);
}
}]

Habe auf
int buttonPin = 3;
int pwmpin = 5;
int motorpin=7;
int buttonState = 0;

geändert, aber daran liegt es nicht.
Habe grade keinen Messgerät parat, habe auch vermutet, dass die Spannung nicht auf 0 runter geht.
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
02.02.2014, 21:12
Beitrag #4
RE: led geht nicht vollsändig aus
das war auch nicht zu erwarten. Diese LED wird über einen OP-Amp angesteuert und kann deshalb auch beliebige Helligkeitswerte zeigen. Wenn definitiv 0V anliegen, dann sollte sie dunkel sein.

Gruß, Stefan . . . . . . //Wo mein Kölbchen dampft, da bin ich unverkrampft.
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
02.02.2014, 21:19
Beitrag #5
RE: led geht nicht vollsändig aus
(02.02.2014 21:12)Stefan schrieb:  das war auch nicht zu erwarten. Diese LED wird über einen OP-Amp angesteuert und kann deshalb auch beliebige Helligkeitswerte zeigen. Wenn definitiv 0V anliegen, dann sollte sie dunkel sein.

Wird aber nicht an der LED liegen, habe den Sketch zur einer Motorsteuerung umfunktioniert und der bleibt auch nicht stehen, sondern dreht sich ganz langsam.
Vielleicht ein Wackelkontakt irgendwo
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
Antwort schreiben 


Möglicherweise verwandte Themen...
Thema: Verfasser Antworten: Ansichten: Letzter Beitrag
  WEMOS Motorshield funzt nicht Rumpl-X 8 201 07.06.2017 21:10
Letzter Beitrag: Tommy56
  LCD geht nicht - keine Ahnung warum?? DL1AKP 12 449 15.05.2017 13:17
Letzter Beitrag: DL1AKP
  433mHz Funkmodule senden/empfangen nicht metzgefa 2 468 06.05.2017 13:30
Letzter Beitrag: metzgefa
  SD Karte wird nicht erkannt Maxi290997 6 278 31.03.2017 06:05
Letzter Beitrag: Bitklopfer
Sad Sketch funktioniert auf dem Mega 2560 nicht Frank1234 16 697 26.03.2017 14:15
Letzter Beitrag: oOSpikeOo
  Mein Skript macht nicht das was es soll ;( DerMatze79 4 324 16.03.2017 22:19
Letzter Beitrag: MicroBahner
  Programmablauf macht nicht das was ich möchte !! ESP + Blynk b3ta 3 259 01.03.2017 14:29
Letzter Beitrag: Tommy56
Rainbow File geht nicht zum compilieren!!!! Jocky 7 382 19.02.2017 20:01
Letzter Beitrag: Binatone
  IRremote bringe ich nicht zum laufen Franz54 5 314 19.02.2017 11:56
Letzter Beitrag: Tommy56
  Code aus 1.6.9 geht mit 1.8.1 nicht mehr zu kompilieren DL1AKP 7 541 02.02.2017 12:16
Letzter Beitrag: Tommy56

Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste