INFO: Dieses Forum nutzt Cookies...
Cookies sind für den Betrieb des Forums unverzichtbar. Mit der Nutzung des Forums erklärst Du dich damit einverstanden, dass wir Cookies verwenden.

Es wird in jedem Fall ein Cookie gesetzt um diesen Hinweis nicht mehr zu erhalten. Desweiteren setzen wir Google Adsense und Google Analytics ein.

Antwort schreiben 
 
Themabewertung:
  • 0 Bewertungen - 0 im Durchschnitt
  • 1
  • 2
  • 3
  • 4
  • 5
kleiner Roboter
27.07.2016, 14:02
Beitrag #25
RE: kleiner Roboter
(27.07.2016 13:48)blichi schrieb:  Hallo Thorsten
ich habe die Werte eingelesen ..........mir sagt das erstmal nicht so viel.....
Code:
Sensorwert R: 1021---  Sensorwert L: 1019
Sensorwert R: 840---  Sensorwert L: 666
Sensorwert R: 1019---  Sensorwert L: 749
Sensorwert R: 651---  Sensorwert L: 665

Das sind die Werte, die jeweils von deinen Sensoren kommen. Ich vermute jetzt mal, dass der Wert kleiner wird, sobald sich ein Hindernis nähert.
Also:
~1000 --> da ist nix
~500 --> da kommt was
~100 --> ganz nah dran.

Da du ja einen Wert <300 abfragst und die Werte in deinem Auszug ja kaum unter 300 gehen, sollte keine LED leuchten.
Also setze den Wert mal auf 500 und halte eine Hand davor. Wenn der Sensorwert also unter 500 fällt, sollte die jeweilige LED leuchten.

Versuch mal...
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
Antwort schreiben 


Möglicherweise verwandte Themen...
Thema: Verfasser Antworten: Ansichten: Letzter Beitrag
  Roboter-Bau Probleme blebbens 8 374 12.07.2016 07:35
Letzter Beitrag: Binatone
  Selbstfahrender Roboter Programm änderung hilfe ? arekklone 11 537 06.07.2016 14:59
Letzter Beitrag: Binatone
  Neo's Roboter Neoneo23 74 5.882 11.11.2015 21:18
Letzter Beitrag: Neoneo23
  SR-04 + UNO + 4WD Roboter, Abstandsfehler Marc2014 25 2.828 21.09.2014 21:42
Letzter Beitrag: Thorsten Pferdekämper
  Roboter J4Ng0 2 1.526 21.07.2013 15:49
Letzter Beitrag: Snake8811

Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste