INFO: Dieses Forum nutzt Cookies...
Cookies sind für den Betrieb des Forums unverzichtbar. Mit der Nutzung des Forums erklärst Du dich damit einverstanden, dass wir Cookies verwenden.

Es wird in jedem Fall ein Cookie gesetzt um diesen Hinweis nicht mehr zu erhalten. Desweiteren setzen wir Google Adsense und Google Analytics ein.

Antwort schreiben 
 
Themabewertung:
  • 0 Bewertungen - 0 im Durchschnitt
  • 1
  • 2
  • 3
  • 4
  • 5
[gelöst]Wo speichert die IDE (1.6.5) die Libs zu anderen Boards (ESP 8266)
23.01.2017, 18:16 (Dieser Beitrag wurde zuletzt bearbeitet: 23.01.2017 19:28 von Tommy56.)
Beitrag #1
[gelöst]Wo speichert die IDE (1.6.5) die Libs zu anderen Boards (ESP 8266)
Hallo zusammen,

ich suche mir gerade nen Wolf in den Verzeichnissen der IDE.
Ich habe über den Boardmanager den ESP8266 eingebunden und kann ihn auch auswählen.
Nun wollte ich mal in einige Libs rein schauen und finde keine.
Wo speichert er diese Files für die neue Hardware?

Gruß Tommy

"Wer den schnellen Erfolg sucht, sollte nicht programmieren, sondern Holz hacken." (Quelle unbekannt)
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
23.01.2017, 18:37
Beitrag #2
RE: Wo speichert die IDE (1.6.5) die Libs zu anderen Boards (ESP 8266)
(23.01.2017 18:16)Tommy56 schrieb:  Wo speichert er diese Files für die neue Hardware?

Für den ESP habe ich keinen Hinweis, aber für den ATtiny schreibt er das hier hin:
"...\Arduino\hardware\tiny"

Sollte beim ESP eigentlich ähnlich sein.

Gruß Dieter

I2C = weniger ist mehr: weniger Kabel, mehr Probleme. Cool
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
23.01.2017, 18:41
Beitrag #3
RE: Wo speichert die IDE (1.6.5) die Libs zu anderen Boards (ESP 8266)
(23.01.2017 18:16)Tommy56 schrieb:  Hallo zusammen,

ich suche mir gerade nen Wolf in den Verzeichnissen der IDE.
Ich habe über den Boardmanager den ESP8266 eingebunden und kann ihn auch auswählen.
Nun wollte ich mal in einige Libs rein schauen und finde keine.
Wo speichert er diese Files für die neue Hardware?

Gruß Tommy

im grenzfall einfach mal suchen :-)

unter windows oder linux ein terminalfenster aufmachen.
nach vorne ins verzeichnis gehen.

mit cd ..

unter windows mit dir *.* /s
und unter linux mit find

*.* durch namensfragment des libnamens ersetzen.
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
23.01.2017, 19:02 (Dieser Beitrag wurde zuletzt bearbeitet: 23.01.2017 19:14 von Tommy56.)
Beitrag #4
RE: Wo speichert die IDE (1.6.5) die Libs zu anderen Boards (ESP 8266)
(23.01.2017 18:41)Pit schrieb:  
(23.01.2017 18:16)Tommy56 schrieb:  Hallo zusammen,

ich suche mir gerade nen Wolf in den Verzeichnissen der IDE.
Ich habe über den Boardmanager den ESP8266 eingebunden und kann ihn auch auswählen.
Nun wollte ich mal in einige Libs rein schauen und finde keine.
Wo speichert er diese Files für die neue Hardware?

Gruß Tommy

im grenzfall einfach mal suchen :-)

unter windows oder linux ein terminalfenster aufmachen.
nach vorne ins verzeichnis gehen.

mit cd ..

unter windows mit dir *.* /s
und unter linux mit find

*.* durch namensfragment des libnamens ersetzen.
Stell Dir vor, das habe ich schon gemacht und er hat nichts gefunden. Auch ein WinGrep findet nichts. Und nun?

Gruß Tommy

(23.01.2017 18:37)hotsystems schrieb:  
(23.01.2017 18:16)Tommy56 schrieb:  Wo speichert er diese Files für die neue Hardware?

Für den ESP habe ich keinen Hinweis, aber für den ATtiny schreibt er das hier hin:
"...\Arduino\hardware\tiny"

Sollte beim ESP eigentlich ähnlich sein.
Die Tinys habe ich auch installiert, auch die finde ich nicht.

Gruß Tommy

"Wer den schnellen Erfolg sucht, sollte nicht programmieren, sondern Holz hacken." (Quelle unbekannt)
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
23.01.2017, 19:24
Beitrag #5
RE: Wo speichert die IDE (1.6.5) die Libs zu anderen Boards (ESP 8266)
Hallo,

(23.01.2017 18:16)Tommy56 schrieb:  ich suche mir gerade nen Wolf in den Verzeichnissen der IDE.
Ich habe über den Boardmanager den ESP8266 eingebunden und kann ihn auch auswählen.
Nun wollte ich mal in einige Libs rein schauen und finde keine.
Wo speichert er diese Files für die neue Hardware?

da sich in letzter Zeit nichts geändert haben sollte:

IDE starten, Voreinstellungen aufrufen und untern auf den Verweis zu preferences.txt klicken. In packages findest Du dann das Gesuchte.
Bei Win7 ist es in %appdata%\Local\Arduino15 oder so ähnlich.

Gruß aus Berlin
Michael
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
23.01.2017, 19:28
Beitrag #6
RE: Wo speichert die IDE (1.6.5) die Libs zu anderen Boards (ESP 8266)
(23.01.2017 19:24)amithlon schrieb:  Hallo,

(23.01.2017 18:16)Tommy56 schrieb:  ich suche mir gerade nen Wolf in den Verzeichnissen der IDE.
Ich habe über den Boardmanager den ESP8266 eingebunden und kann ihn auch auswählen.
Nun wollte ich mal in einige Libs rein schauen und finde keine.
Wo speichert er diese Files für die neue Hardware?

da sich in letzter Zeit nichts geändert haben sollte:

IDE starten, Voreinstellungen aufrufen und untern auf den Verweis zu preferences.txt klicken. In packages findest Du dann das Gesuchte.
Bei Win7 ist es in %appdata%\Local\Arduino15 oder so ähnlich.

Gruß aus Berlin
Michael
Danke, das wars.
Win 7 bei mir: %appdata%\Roaming\Arduino15\packages

Gruß Tommy

"Wer den schnellen Erfolg sucht, sollte nicht programmieren, sondern Holz hacken." (Quelle unbekannt)
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
Antwort schreiben 


Möglicherweise verwandte Themen...
Thema: Verfasser Antworten: Ansichten: Letzter Beitrag
  Gelöst beschroe 2 407 11.03.2019 22:56
Letzter Beitrag: Bitklopfer
  Gelöst ==> Arduino Nano, Kommunikation mit PC bringt nicht korrekten ASCII moehrle 4 595 02.03.2019 22:04
Letzter Beitrag: hotsystems
  '#' mit Leonardo/Micro [gelöst] Ardusil 10 973 25.11.2018 15:57
Letzter Beitrag: Ardusil
  [gelöst]String, char .... ich begreife es einfach nicht - char Array <> mit SDexist christian@schiltkamp.info 10 1.903 31.08.2018 23:05
Letzter Beitrag: Tommy56
  [selbst gelöst] Register von Inline-Assembler-Anweisung vorher nicht gesetzt => Bug? Addi 2 552 24.08.2018 08:11
Letzter Beitrag: Addi
  328P geht nicht mehr [gelöst] Harry 37 7.475 04.03.2018 19:57
Letzter Beitrag: Harry
  [gelöst] Micro SD-Card Shield an ISP? torsten_156 1 779 08.02.2018 22:24
Letzter Beitrag: Tommy56
  Arduino -> Controllino [Problem gelöst] Cyrilsneer 17 4.096 27.11.2017 18:49
Letzter Beitrag: Franz54
  Libs mit peristenten Variablen Gerri3d 2 1.074 04.11.2017 07:20
Letzter Beitrag: Gerri3d
  Vorangestellte Nullen | gelöst Jan74 3 1.513 17.08.2017 09:26
Letzter Beitrag: Jan74

Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste