INFO: Dieses Forum nutzt Cookies...
Cookies sind für den Betrieb des Forums unverzichtbar. Mit der Nutzung des Forums erklärst Du dich damit einverstanden, dass wir Cookies verwenden.

Es wird in jedem Fall ein Cookie gesetzt um diesen Hinweis nicht mehr zu erhalten. Desweiteren setzen wir Google Adsense und Google Analytics ein.

Antwort schreiben 
 
Themabewertung:
  • 0 Bewertungen - 0 im Durchschnitt
  • 1
  • 2
  • 3
  • 4
  • 5
[gelöst:] Hardware-Timer-Interrupts beim Mega
26.09.2014, 21:05 (Dieser Beitrag wurde zuletzt bearbeitet: 26.09.2014 22:11 von HaWe.)
Beitrag #1
[gelöst:] Hardware-Timer-Interrupts beim Mega
hallo,

wie kann ich beim Mega alle ca. 125-250µs einen Timer-Interrupt auslösen?
In diesen zeitabständen muss ich mehrere Pin-Zustände auslesen.

Beim Uno hatte ich diesen Code verwendet:
Code:
noInterrupts();

           TIMSK1 |= (1<<OCIE1A);  
           TCCR1A = 0;            
           // WGM12: CTC-Modus einschalten (Clear Timer on Compare match)
           // => Prescaler=8:
           TCCR1B = (1<<WGM12) | (1<<CS11);
           // Frequenz = 16,000,000 / 8 / 512 = rd. 4 kHz
           OCR1A =511;

       interrupts();
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
26.09.2014, 22:11 (Dieser Beitrag wurde zuletzt bearbeitet: 26.09.2014 22:11 von HaWe.)
Beitrag #2
RE: Hardware-Timer-Interrupts beim Mega
edit:
hat sich geklärt, war ein Fehler im Programm, kann alles bleiben wie es war...Blush
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
Antwort schreiben 


Möglicherweise verwandte Themen...
Thema: Verfasser Antworten: Ansichten: Letzter Beitrag
  Arduino Mega mit Shield und 7" Touch Tudorf 7 123 Heute 15:53
Letzter Beitrag: Tudorf
  [gelöst] Micro SD-Card Shield an ISP? torsten_156 1 134 08.02.2018 22:24
Letzter Beitrag: Tommy56
  COM Port bei Arduino Mega? LoroLoco 8 558 19.01.2018 12:49
Letzter Beitrag: hotsystems
  timer Mega 2560 4x tone Output see 6 347 11.01.2018 20:11
Letzter Beitrag: Tommy56
  [Frage] Unterschied zwischen &=~ und ^= beim Bit ändern auf dem Port? avoid 13 741 11.01.2018 00:53
Letzter Beitrag: avoid
  TFT 2.8" SPI bleibt weiß MEGA 2560 tillmg 15 840 06.01.2018 15:36
Letzter Beitrag: tillmg
  Arduino zu MySQL via Wifi Fehler beim compilieren Franzel007 21 857 05.01.2018 20:24
Letzter Beitrag: Tommy56
  Fehlermeldung beim Compilieren DonCamillo 1 327 16.12.2017 21:04
Letzter Beitrag: Chopp
  Timer 0 Mathias 8 594 02.12.2017 17:26
Letzter Beitrag: MicroBahner
  Arduino -> Controllino [Problem gelöst] Cyrilsneer 17 1.131 27.11.2017 18:49
Letzter Beitrag: Franz54

Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste