INFO: Dieses Forum nutzt Cookies...
Cookies sind für den Betrieb des Forums unverzichtbar. Mit der Nutzung des Forums erklärst Du dich damit einverstanden, dass wir Cookies verwenden.

Es wird in jedem Fall ein Cookie gesetzt um diesen Hinweis nicht mehr zu erhalten. Desweiteren setzen wir Google Adsense und Google Analytics ein.

Antwort schreiben 
 
Themabewertung:
  • 0 Bewertungen - 0 im Durchschnitt
  • 1
  • 2
  • 3
  • 4
  • 5
[gelöst:] Hardware-Timer-Interrupts beim Mega
26.09.2014, 21:05 (Dieser Beitrag wurde zuletzt bearbeitet: 26.09.2014 22:11 von HaWe.)
Beitrag #1
[gelöst:] Hardware-Timer-Interrupts beim Mega
hallo,

wie kann ich beim Mega alle ca. 125-250µs einen Timer-Interrupt auslösen?
In diesen zeitabständen muss ich mehrere Pin-Zustände auslesen.

Beim Uno hatte ich diesen Code verwendet:
Code:
noInterrupts();

           TIMSK1 |= (1<<OCIE1A);  
           TCCR1A = 0;            
           // WGM12: CTC-Modus einschalten (Clear Timer on Compare match)
           // => Prescaler=8:
           TCCR1B = (1<<WGM12) | (1<<CS11);
           // Frequenz = 16,000,000 / 8 / 512 = rd. 4 kHz
           OCR1A =511;

       interrupts();
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
26.09.2014, 22:11 (Dieser Beitrag wurde zuletzt bearbeitet: 26.09.2014 22:11 von HaWe.)
Beitrag #2
RE: Hardware-Timer-Interrupts beim Mega
edit:
hat sich geklärt, war ein Fehler im Programm, kann alles bleiben wie es war...Blush
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
Antwort schreiben 


Möglicherweise verwandte Themen...
Thema: Verfasser Antworten: Ansichten: Letzter Beitrag
  Arduino MEGA + EthernetShield W5100 und weiteres SPI Device ? Stargazer 12 264 11.10.2017 19:03
Letzter Beitrag: Tommy56
  Mega 2560 Visualisieren binderj1 11 330 01.10.2017 19:07
Letzter Beitrag: Tommy56
  Fortschritte beim 3-flammigen Gasgrill - nun wieder Pause MOE. 17 671 14.09.2017 11:24
Letzter Beitrag: Bitklopfer
  Logger am Mega 2560 Wolfgang50 3 239 13.09.2017 10:53
Letzter Beitrag: Tommy56
  Vorangestellte Nullen | gelöst Jan74 3 381 17.08.2017 09:26
Letzter Beitrag: Jan74
  [Gelöst]Automatische Lichtschaltung mit Tastern TerroraffE 5 465 09.08.2017 22:24
Letzter Beitrag: TerroraffE
Wink Arduino TFT Display MEGA 2560 Samsuino 47 3.180 24.07.2017 12:45
Letzter Beitrag: Harry Hirsch
  Treiberprobleme Arduino Mega 2560 DonAthello 19 1.464 14.07.2017 10:14
Letzter Beitrag: SkobyMobil
  Timer lernen AnjinSan 14 811 26.06.2017 13:25
Letzter Beitrag: Tommy56
Sad Fehlermeldung beim Hochladen meines Sketches kletterloewe 5 495 14.06.2017 16:08
Letzter Beitrag: hotsystems

Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste