INFO: Dieses Forum nutzt Cookies...
Cookies sind für den Betrieb des Forums unverzichtbar. Mit der Nutzung des Forums erklärst Du dich damit einverstanden, dass wir Cookies verwenden.

Es wird in jedem Fall ein Cookie gesetzt um diesen Hinweis nicht mehr zu erhalten. Desweiteren setzen wir Google Adsense und Google Analytics ein.

Antwort schreiben 
 
Themabewertung:
  • 0 Bewertungen - 0 im Durchschnitt
  • 1
  • 2
  • 3
  • 4
  • 5
erledigt: atan2 rechnet falsch?
30.11.2015, 17:29 (Dieser Beitrag wurde zuletzt bearbeitet: 30.11.2015 18:13 von HaWe.)
Beitrag #1
erledigt: atan2 rechnet falsch?
hallo,
ich habe das Gefühl. atan2 rechnet falsch für ungültige Werte:

normalerweise ist atan2(y,x) definiert als atan(y/x) für x!=0,
d.h. er ist undefiniert für x=0.

für x=0 müsste atan2 also NAN ausgeben.

Setze ich aber z.B ein
double val=atan2(-2.0 , 0)
erhalte ich -1.5707



edit, hat sich erledigt, wird als Sonderfall behandelt.
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
Antwort schreiben 


Möglicherweise verwandte Themen...
Thema: Verfasser Antworten: Ansichten: Letzter Beitrag
  OLED Display anzeige von Logo falsch ! b3ta 0 339 23.01.2016 15:12
Letzter Beitrag: b3ta
  [gelöst] was ist falsch bei Wire.onReceive()? HaWe 0 638 26.09.2015 16:58
Letzter Beitrag: HaWe
  String falsch verstanden? hougy 20 1.805 07.07.2015 14:53
Letzter Beitrag: HaWe
  [erledigt] Wie Mealy-Automat implementieren? gregors 6 1.164 26.05.2015 21:12
Letzter Beitrag: gregors
  sprintf formatiert völlig falsch ! HaWe 15 1.598 13.12.2014 10:04
Letzter Beitrag: HaWe
  Switch Case, LEDs bleiben an, Bedingung aber falsch luto92 4 1.449 16.11.2014 16:52
Letzter Beitrag: luto92
  Bluetooth Shield ließt Daten falsch ein mck7000 4 1.863 20.12.2013 19:54
Letzter Beitrag: mck7000
  arduino rechnet falsch neuling 3 10.596 28.04.2013 09:18
Letzter Beitrag: neuling

Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste