INFO: Dieses Forum nutzt Cookies...
Cookies sind für den Betrieb des Forums unverzichtbar. Mit der Nutzung des Forums erklärst Du dich damit einverstanden, dass wir Cookies verwenden.

Es wird in jedem Fall ein Cookie gesetzt um diesen Hinweis nicht mehr zu erhalten. Desweiteren setzen wir Google Adsense und Google Analytics ein.

Antwort schreiben 
 
Themabewertung:
  • 0 Bewertungen - 0 im Durchschnitt
  • 1
  • 2
  • 3
  • 4
  • 5
arduino uno r3 läd ersten sketch nicht
22.02.2015, 10:07
Beitrag #1
arduino uno r3 läd ersten sketch nicht
Ich habe eine LED (GND und 13) in meinen neuen Arduino Uno gesteckt und mit meinem Rechner(Linux OpenSuse verbunden). Obwohl ich noch keinen sketch geladen hatte, fing die LED sofort im Sekundenrhythmus an zu blinken.
Dann habe ich versucht diesen sketch zu laden:

const int LED = 13;
void setup()
{
pinMode(LED, OUTPUT);
}
void loop()
{
digitalWrite(LED, HIGH);
delay(3000);
digitalWrite(LED, LOW);
delay(2000);
}

Anschließend bekam ich diese Fehlermeldung:

This report would have more information with
"Show verbose output during compilation"
enabled in File > Preferences.
Arduino: 1.0.6 (Linux), Board: "Arduino Uno"
/usr/bin/avr-ld: warning: -z relro ignored.
Binäre Sketchgröße: 1.058 Bytes (von einem Maximum von 32.256 Bytes)
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 1 of 10: not in sync: resp=0x00
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 2 of 10: not in sync: resp=0x00
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 3 of 10: not in sync: resp=0x00
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 4 of 10: not in sync: resp=0x00
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 5 of 10: not in sync: resp=0x00
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 6 of 10: not in sync: resp=0x00
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 7 of 10: not in sync: resp=0x00
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 8 of 10: not in sync: resp=0x00
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 9 of 10: not in sync: resp=0x00
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 10 of 10: not in sync: resp=0x00

Kann mir jemand sagen, was da schief gelaufen ist?
(Ich habe diese Frage auch im intern. Forum gestellt, weil ich noch nicht auf das deutsche Forum gestoßen war.)
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
22.02.2015, 10:32
Beitrag #2
RE: arduino uno r3 läd ersten sketch nicht
(22.02.2015 10:07)luxikon schrieb:  Ich habe eine LED (GND und 13) in meinen neuen Arduino Uno gesteckt
Hoffentlich mit Vorwiderstand, sonst kann es sein, dass jetzt schon was kaputt ist. Wenn Du "Vorwiderstand" nicht verstehst, dann lass einfach die LED komplett weg. Der Uno sollte eine kleine SMD-LED haben, die sowieso an Port 13 hängt.

Zitat:Obwohl ich noch keinen sketch geladen hatte, fing die LED sofort im Sekundenrhythmus an zu blinken.
Ja, der Blink-Sketch ist sozusagen vorinstalliert.

Zitat:Arduino: 1.0.6 (Linux), Board: "Arduino Uno"
Gibt es für Linux nichts neueres? Aktuell ist 1.6.0.

Zitat:Binäre Sketchgröße: 1.058 Bytes (von einem Maximum von 32.256 Bytes)
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 1 of 10: not in sync: resp=0x00
Ist der richtige Port ausgewählt und auch der USB-Treiber installiert? Ich habe ein paar Jahre nichts mehr mit Linux gemacht, aber unter Windows muss der richtige Treiber installiert sein.
Gruß,
Thorsten

Falls ich mit einer Antwort helfen konnte, wuerde ich mich freuen, ein paar Fotos oder auch ein kleines Filmchen des zugehoerigen Projekts zu sehen.
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
22.02.2015, 12:09 (Dieser Beitrag wurde zuletzt bearbeitet: 22.02.2015 15:47 von luxikon.)
Beitrag #3
RE: arduino uno r3 läd ersten sketch nicht
> Hoffentlich mit Vorwiderstand, sonst kann es sein, dass jetzt schon was kaputt ist. Wenn Du "Vorwiderstand" nicht verstehst, dann lass einfach die LED komplett weg. Der Uno sollte eine kleine SMD-LED haben, die sowieso an Port 13 hängt.

Ich habe keine LED mit Vorwiderstand genommen. Die LED ist in dem Buch "Getting started with Arduino", nach dem ich vorgehe, auf Seite 27 (Blinking an LED) auch ohne den Widerstand abgebildet.

> Ist der richtige Port ausgewählt und auch der USB-Treiber installiert? Ich habe ein paar Jahre nichts mehr mit Linux gemacht, aber unter Windows muss der richtige Treiber installiert sein.

Habe den Port gewechselt. Jetzt geht's.
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
22.02.2015, 22:50
Beitrag #4
RE: arduino uno r3 läd ersten sketch nicht
(22.02.2015 12:09)luxikon schrieb:  Ich habe keine LED mit Vorwiderstand genommen. Die LED ist in dem Buch "Getting started with Arduino", nach dem ich vorgehe, auf Seite 27 (Blinking an LED) auch ohne den Widerstand abgebildet.
Dadurch wird's nicht besser. Wundere Dich nicht, wenn die LED oder der Pin oder beides abraucht.
Gruß,
Thorsten

Falls ich mit einer Antwort helfen konnte, wuerde ich mich freuen, ein paar Fotos oder auch ein kleines Filmchen des zugehoerigen Projekts zu sehen.
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
23.02.2015, 08:25
Beitrag #5
RE: arduino uno r3 läd ersten sketch nicht
Hallo Thorsten,
ich habe Deinen Rat befolgt und die LED entfernt. Noch ist kein Schaden entstanden. Ich werde mir ein breadboard besorgen und einen Widerstand vor die LED schalten.
Danke.

(22.02.2015 22:50)Thorsten Pferdekämper schrieb:  
(22.02.2015 12:09)luxikon schrieb:  Ich habe keine LED mit Vorwiderstand genommen. Die LED ist in dem Buch "Getting started with Arduino", nach dem ich vorgehe, auf Seite 27 (Blinking an LED) auch ohne den Widerstand abgebildet.
Dadurch wird's nicht besser. Wundere Dich nicht, wenn die LED oder der Pin oder beides abraucht.
Gruß,
Thorsten

Beste Grüße
luxikon
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
Antwort schreiben 


Möglicherweise verwandte Themen...
Thema: Verfasser Antworten: Ansichten: Letzter Beitrag
  Arduino lässt sich nicht installieren bergfrei 4 134 20.11.2016 18:34
Letzter Beitrag: bergfrei
  Arduino Mega 2560 läuft nicht Wolfgang50 6 169 13.11.2016 10:50
Letzter Beitrag: Wolfgang50
  Ardublock übertragt nicht an IDE oder UNO R3 tobi83 5 320 16.10.2016 14:07
Letzter Beitrag: Pit
  Upload funktioniert nicht Levi 5 236 22.09.2016 20:19
Letzter Beitrag: hotsystems
  ESP8266 tuts nicht sowerum 7 384 19.09.2016 21:01
Letzter Beitrag: sowerum
  If-Bedingung funktioniert nicht bei Serial1.write Datatom 6 222 16.09.2016 20:36
Letzter Beitrag: Datatom
  SD Karte wird nicht erkannt... Maxi290997 2 201 16.08.2016 14:36
Letzter Beitrag: Maxi290997
  Arduino lässt sich nicht mehr beschreiben Maxi290997 15 962 07.08.2016 11:40
Letzter Beitrag: Maxi290997
  Sketch vom Arduino Board Herunterladen Sarius 2 341 27.07.2016 15:26
Letzter Beitrag: Sarius
  Arduino Uno+Motor Shield+Velleman Mustercode funktionieren nicht Dubidu 8 478 20.07.2016 19:05
Letzter Beitrag: Scheams

Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 2 Gast/Gäste