INFO: Dieses Forum nutzt Cookies...
Cookies sind für den Betrieb des Forums unverzichtbar. Mit der Nutzung des Forums erklärst Du dich damit einverstanden, dass wir Cookies verwenden.

Es wird in jedem Fall ein Cookie gesetzt um diesen Hinweis nicht mehr zu erhalten. Desweiteren setzen wir Google Adsense und Google Analytics ein.

Antwort schreiben 
 
Themabewertung:
  • 0 Bewertungen - 0 im Durchschnitt
  • 1
  • 2
  • 3
  • 4
  • 5
analoge Eingänge funktionieren nicht als digital Input oder Outpt
16.09.2020, 19:24
Beitrag #1
analoge Eingänge funktionieren nicht als digital Input oder Outpt
Hallo,

will meine analogen Eingänge am UNO als digitalen INPUT oder OUTPUT nutzen.
im setup habe ich:

pinMode(A0,INPUT);
bzw.
pinMode(A0,OUTPUT);

zum testen im loop;
digitalWrite(A0,HIGH);

Da passiert nichts.

Zudem ist mir aufgefallen, wenn ich einen digitalen Pin, z.B. 8 mit
pinMode(8,INPUT_PULLUP); deklariere, die PULLUP Funktion nicht funktioniert.

Hat das Problem jemand schon gehabt?
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
16.09.2020, 20:07 (Dieser Beitrag wurde zuletzt bearbeitet: 16.09.2020 20:08 von Tommy56.)
Beitrag #2
RE: analoge Eingänge funktionieren nicht als digital Input oder Outpt
Da habe ich beide Probleme nicht gehabt. Womit prüfst Du, ob die Einstellung funktioniert hat?
Evtl. ist Deine IDE defekt.

Gruß Tommy

"Wer den schnellen Erfolg sucht, sollte nicht programmieren, sondern Holz hacken." (Quelle unbekannt)
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
16.09.2020, 21:47
Beitrag #3
RE: analoge Eingänge funktionieren nicht als digital Input oder Outpt
(16.09.2020 19:24)Jenser schrieb:  Hat das Problem jemand schon gehabt?

Auch ich habe dieses Problem bisher noch nicht gehabt.

Ich vermute aber bei deinem Aufbau einen Kontaktfehler oder Messfehler.

Gruß Dieter

I2C = weniger ist mehr: weniger Kabel, mehr Probleme. Cool
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
17.09.2020, 10:44
Beitrag #4
RE: analoge Eingänge funktionieren nicht als digital Input oder Outpt
...öfter mal was Neues... würde mal darauf tippen das die Ports Defekt sind.
lgbk


An alle Neuankömmlinge hier, wenn ihr Code(Sketch) hier posten wollte dann liest euch bitte diese Anleitung durch.

1+1 = 10 Angel ...und ich bin hier nicht der Suchmaschinen-Ersatz Dodgy...nur mal so als genereller Tipp..
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
17.09.2020, 15:02
Beitrag #5
RE: analoge Eingänge funktionieren nicht als digital Input oder Outpt
(16.09.2020 20:07)Tommy56 schrieb:  Womit prüfst Du, ob die Einstellung funktioniert hat?

An zwei digitalen Pins hängt je ein Taster und eine Led.
Funktioniert auch, dann ersetze ich im Setup den Ein- und Ausgang durch analoge Pins > funktioniert nicht.

Vermutlich ist dann wirklich was defekt.
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
17.09.2020, 15:10
Beitrag #6
RE: analoge Eingänge funktionieren nicht als digital Input oder Outpt
Klemmst Du Taster und LED auch um?

"Wer den schnellen Erfolg sucht, sollte nicht programmieren, sondern Holz hacken." (Quelle unbekannt)
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
17.09.2020, 15:16
Beitrag #7
RE: analoge Eingänge funktionieren nicht als digital Input oder Outpt
(17.09.2020 15:10)Tommy56 schrieb:  Klemmst Du Taster und LED auch um?

Big Grin natürlich
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
17.09.2020, 18:37
Beitrag #8
RE: analoge Eingänge funktionieren nicht als digital Input oder Outpt
Poste bitte mal in Codetags
Code:
den completten Code
vor und nach den Änderungen.

In der heutigen Zeit ist gesunder Menschenverstand so etwas Ähnliches wie eine Superkraft - aber keine nützliche.
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
Antwort schreiben 


Möglicherweise verwandte Themen...
Thema: Verfasser Antworten: Ansichten: Letzter Beitrag
  2 I2C-Devices nicht zusammen wonk 13 236 Heute 18:58
Letzter Beitrag: Tommy56
  Schieberegister funktioniert nicht richtig flint74 9 461 21.02.2021 13:35
Letzter Beitrag: flint74
  Warum sind mehrere Attiny´s nicht Synchron ? Chris_Arduino 6 2.059 02.02.2021 11:46
Letzter Beitrag: Harry
  Arduino Uno will nicht mehr wonk 35 5.594 21.01.2021 17:33
Letzter Beitrag: Tommy56
  RFID keine Daten / wird nicht erkannt Wochenendprogrammierer 79 7.103 27.12.2020 19:20
Letzter Beitrag: Wochenendprogrammierer
  Ausgabe LCD-Display funktioniert nicht wonk 6 1.075 23.12.2020 21:15
Letzter Beitrag: hotsystems
  Schrittmotor bewegt sich nicht DerMaschbaustudent 79 10.053 01.12.2020 22:08
Letzter Beitrag: MicroBahner
  Neopixel - LEDS leuchten obwohl sie es nicht sollten Mauser 72 7.099 01.12.2020 10:00
Letzter Beitrag: hotsystems
  Seltsames Zackenmuster, wenn Poti nicht bewegt wird. . Guekard 9 2.159 26.11.2020 08:40
Letzter Beitrag: hotsystems
  Spannungsversorgung Wemos 5V über Regler oder nicht?? DO3GE 23 4.457 21.10.2020 06:02
Letzter Beitrag: DO3GE

Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste