INFO: Dieses Forum nutzt Cookies...
Cookies sind für den Betrieb des Forums unverzichtbar. Mit der Nutzung des Forums erklärst Du dich damit einverstanden, dass wir Cookies verwenden.

Es wird in jedem Fall ein Cookie gesetzt um diesen Hinweis nicht mehr zu erhalten. Desweiteren setzen wir Google Adsense und Google Analytics ein.

Antwort schreiben 
 
Themabewertung:
  • 0 Bewertungen - 0 im Durchschnitt
  • 1
  • 2
  • 3
  • 4
  • 5
adruino mega 2560 reset
04.04.2015, 18:14
Beitrag #17
RE: adruino mega 2560 reset
(04.04.2015 17:18)rkuehle schrieb:  Hallo manne,
Zitat:Wenn ich das Programm von Minibloc aus überschreibe,hochlade,
blinkt led 13 so lange mit.
RX-TX auch,ist ja klar.
Ähm, ich gehe mal davon aus, dass du den Fehler bekommst, wenn du den Code in der Arduino IDE übersetzt ???
Wenn ja, würde ich die #include oben rausnehmen, die gehören schlicht nicht zur Arduino IDE.
Weiterhin wird per include der mbq.h auch die Minibloq.h included.
Diese wiederum ermöglicht erst so Sachen wie "DigitalWrite", was in der Arduino IDE definitiv Fehler produziert. Und nicht zuletzt steht in der Minibloq.h die Funktion
Code:
void initBoard()
{
Serial.begin(115200);
randomSeed(analogRead(0));
servo0.setPin(16);
servo1.setPin(17);
motor1.setClockwise(false);
}
Das randomSeed könnte die Ursache für das eigenartige Verhalten sein.
Sieht mir so aus, als wenn du mit dem gleichen Code auf zwei verschiedenen IDE arbeiten möchtest. Das wird so nicht funktionieren, da Minibloq eine Wrapper auf den Sprachvorrat der Arduino IDE ist.
Grüße Ricardo

Hallo Ricardo
Danke für den Tipp.
Wie gesagt,habe es jetzt mal im Arduino direkt geschrieben.
Erst mal nur für 2 LED
Aber das gleiche Ergebnis.
Sollte eigentlich nur ein mal durchlaufen.
Beim Hochladen blinkt LED 13
Nach etwa 30 sec. läuft es von vorn.
Und das regelmässig alle 30 sec.


void setup() {
// put your setup code here, to run once:
pinMode(22,OUTPUT);
pinMode(23, OUTPUT);
digitalWrite(22, HIGH);
delay(1000);
digitalWrite(22, LOW);
delay(1000);
digitalWrite(23, HIGH);
delay(1000);
digitalWrite(23, LOW);
delay(1000);
}
void loop() {

}
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
04.04.2015, 20:02
Beitrag #18
RE: adruino mega 2560 reset
..ach mir fällt dazu noch was siedendheiß ein... wird durch diese MiniBlock Libs etc. vielleicht ein Watchdog Timer aufgezogen der dann weil nicht im Programmlauf berücksichtigt dann immer wieder auf den Reset drückt....sowas gibt es...
lg
bk

1+1 = 10 Angel ...und ich bin hier nicht der Suchmaschinen-Ersatz Dodgy...nur mal so als genereller Tipp..
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
05.04.2015, 16:33 (Dieser Beitrag wurde zuletzt bearbeitet: 05.04.2015 16:34 von rkuehle.)
Beitrag #19
RE: adruino mega 2560 reset
Hallo manne,

hast du mal versucht einen völlig nackten/leeren Sketch ohne irgendwelche angeschlossene Peripherie auf den Arduino zu bringen? Solltest du mal tun. Wenn dann immer noch das Getue mit der LED auftritt ist es wohl eher ein Hardware-Problem Huh
Grüße Ricardo

Nüchtern betrachtet...ist besoffen besser Big Grin
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
06.04.2015, 10:47
Beitrag #20
RE: adruino mega 2560 reset
(05.04.2015 16:33)rkuehle schrieb:  Hallo manne,

hast du mal versucht einen völlig nackten/leeren Sketch ohne irgendwelche angeschlossene Peripherie auf den Arduino zu bringen? Solltest du mal tun. Wenn dann immer noch das Getue mit der LED auftritt ist es wohl eher ein Hardware-Problem Huh
Grüße Ricardo

Also ich habe mal nur setup nichts, und loop nichts
ohne Peripherie hochgeladen.
Das Resultat ist das gleiche.
Tippe auch auf Hardware

manne
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
06.04.2015, 14:31
Beitrag #21
RE: adruino mega 2560 reset
...und wieder frage ich mich, wie man bei einem leeren Sketch merkt, dass der Arduino sich zurücksetzt.

Falls ich mit einer Antwort helfen konnte, wuerde ich mich freuen, ein paar Fotos oder auch ein kleines Filmchen des zugehoerigen Projekts zu sehen.
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
Antwort schreiben 


Möglicherweise verwandte Themen...
Thema: Verfasser Antworten: Ansichten: Letzter Beitrag
  Fern Reset Arduino möglich? sepp01 51 1.433 12.05.2018 20:32
Letzter Beitrag: hotsystems
  Reset beim Arduino Franz54 6 415 03.03.2018 00:41
Letzter Beitrag: ardu_arne
  Arduino Mega mit Shield und 7" Touch Tudorf 10 608 25.02.2018 14:30
Letzter Beitrag: Tommy56
  Daten vom Arduino Mega an Nextion Diskusguppy 4 385 25.02.2018 13:29
Letzter Beitrag: hotsystems
  COM Port bei Arduino Mega? LoroLoco 8 821 19.01.2018 12:49
Letzter Beitrag: hotsystems
  timer Mega 2560 4x tone Output see 6 667 11.01.2018 20:11
Letzter Beitrag: Tommy56
  TFT 2.8" SPI bleibt weiß MEGA 2560 tillmg 15 1.510 06.01.2018 15:36
Letzter Beitrag: tillmg
  Arduino MEGA + EthernetShield W5100 und weiteres SPI Device ? Stargazer 12 1.288 11.10.2017 19:03
Letzter Beitrag: Tommy56
  Mega 2560 Visualisieren binderj1 11 1.063 01.10.2017 19:07
Letzter Beitrag: Tommy56
  Logger am Mega 2560 Wolfgang50 3 569 13.09.2017 10:53
Letzter Beitrag: Tommy56

Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste