INFO: Dieses Forum nutzt Cookies...
Cookies sind für den Betrieb des Forums unverzichtbar. Mit der Nutzung des Forums erklärst Du dich damit einverstanden, dass wir Cookies verwenden.

Es wird in jedem Fall ein Cookie gesetzt um diesen Hinweis nicht mehr zu erhalten. Desweiteren setzen wir Google Adsense und Google Analytics ein.

Antwort schreiben 
 
Themabewertung:
  • 0 Bewertungen - 0 im Durchschnitt
  • 1
  • 2
  • 3
  • 4
  • 5
Zeichen werden auf der LCD verfälscht
09.02.2020, 21:16
Beitrag #9
RE: Zeichen werden auf der LCD verfälscht
(09.02.2020 18:43)hotsystems schrieb:  Hast du in deinem Aufbau für I2C auch Pullup-Widerstände eingesetzt ?
Wie lang sind deine I2C-Kabel ?

Das sieht mir nach einem Problem mit I2C aus bei einem Projekt.

Pullup-Widerstände sind zwischen SDA /SCL nicht verbaut.
Das IC2 Kabel ist ca. 10 cm lang.
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
09.02.2020, 22:48
Beitrag #10
RE: Zeichen werden auf der LCD verfälscht
(09.02.2020 21:16)Tom2Bit schrieb:  Pullup-Widerstände sind zwischen SDA /SCL nicht verbaut.
Das IC2 Kabel ist ca. 10 cm lang.

Du brauchst keine Pullups zwischen SDA und SCL, sondern jeweils von SDA/SCL auf VCC. Das sollten 4,7kOhm sein. Aber vorher nachmessen, ob schon welche auf irgend einem Board verbaut sind. Das Messen ohne Betriebsspannung.
Die Länge des Kabels ist mit 10cm erstmal unkritisch, hier vermute ich eher einen Wackelkontakt.

Gruß Dieter

I2C = weniger ist mehr: weniger Kabel, mehr Probleme. Cool
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
11.02.2020, 17:32
Beitrag #11
RE: Zeichen werden auf der LCD verfälscht
(09.02.2020 22:48)hotsystems schrieb:  
(09.02.2020 21:16)Tom2Bit schrieb:  Pullup-Widerstände sind zwischen SDA /SCL nicht verbaut.
Das IC2 Kabel ist ca. 10 cm lang.

Du brauchst keine Pullups zwischen SDA und SCL, sondern jeweils von SDA/SCL auf VCC. Das sollten 4,7kOhm sein. Aber vorher nachmessen, ob schon welche auf irgend einem Board verbaut sind. Das Messen ohne Betriebsspannung.
Die Länge des Kabels ist mit 10cm erstmal unkritisch, hier vermute ich eher einen Wackelkontakt.

Sorry falsch ausgedrückt. Ich meinte das keine Pullups zwischen SCL bzw. SDA und Vcc verbaut sind. Ich finde auch nirgends Baupläne wo das gemacht wird. Zum anderen würde der beschriebene Fehler dann nicht immer nach 30-40 Tagen eintreten und sich, wie beschrieben, selbst beheben.
Damit schieße ich auch ein Wackelkontakt oder "kalte Lötstelle" aus. (Es ist alles 100% verlötet weil ich mit Steckverbindungen schlechte Erfahrungen gesammelt habe)

Zum anderen habe ich jetzt im Sketch alles was zur Anzeige des Datums oder der Zeit inkl. der Berechnung der Vornull auskommentiert.

Mal sehen was jetzt passiert.
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
11.02.2020, 17:40
Beitrag #12
RE: Zeichen werden auf der LCD verfälscht
(11.02.2020 17:32)Tom2Bit schrieb:  Sorry falsch ausgedrückt. Ich meinte das keine Pullups zwischen SCL bzw. SDA und Vcc verbaut sind. Ich finde auch nirgends Baupläne wo das gemacht wird. Zum anderen würde der beschriebene Fehler dann nicht immer nach 30-40 Tagen eintreten und sich, wie beschrieben, selbst beheben.
.....
Das ist ja die Krux.
Die meisten User, sind einfach zu Faul oder habe nicht das Wissen, dass dies Widerstände da ran gehören. Daher wird das in vielen Beschreibungen einfach weggelassen.
In richtigen Datenblättern zu I2C wird das aber so beschrieben. Ist einfach Fakt.
Und ein Fehler muss nicht immer sofort auftreten.
Wen es nicht dein Problem ist, umso besser.
Wollte nur einen Tipp geben.

Gruß Dieter

I2C = weniger ist mehr: weniger Kabel, mehr Probleme. Cool
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
Antwort schreiben 


Möglicherweise verwandte Themen...
Thema: Verfasser Antworten: Ansichten: Letzter Beitrag
  & Zeichen in Funktionen Franz54 4 600 08.03.2020 22:06
Letzter Beitrag: Franz54
  LCD 16*2 display zeigt sinnlose Zeichen Schneggl 15 2.221 04.10.2019 18:58
Letzter Beitrag: Tommy56
  Das Zeichen "°" (Grad) ausgeben Rockman 6 2.448 16.06.2019 16:39
Letzter Beitrag: Rockman
  Nur seltsam Zeichen Serial TeimeN 5 1.201 30.05.2019 10:32
Letzter Beitrag: Tommy56
  Analog Eingang _ Werte verfälscht Traktor 16 4.522 30.03.2018 08:36
Letzter Beitrag: Bitklopfer
  Code muss um 73Bytes reduziert werden! Wie? torsten_156 13 4.172 25.01.2018 21:56
Letzter Beitrag: torsten_156
  ASCII Zeichen Seriell ausgeben huber5093 3 3.963 07.10.2017 20:35
Letzter Beitrag: Tommy56
  Werden ungenutzte Funktionen weg optimiert? BennIY 1 1.385 03.10.2017 09:06
Letzter Beitrag: Tommy56
  Empfange nur "Geister"zeichen vom BT-Modul dabbamonkeyyy 2 1.618 23.10.2016 11:34
Letzter Beitrag: Harry Hirsch
  LCD Display plötzlich komische Zeichen Jessi97 2 3.254 28.07.2016 11:34
Letzter Beitrag: Bitklopfer

Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste