INFO: Dieses Forum nutzt Cookies...
Cookies sind für den Betrieb des Forums unverzichtbar. Mit der Nutzung des Forums erklärst Du dich damit einverstanden, dass wir Cookies verwenden.

Es wird in jedem Fall ein Cookie gesetzt um diesen Hinweis nicht mehr zu erhalten. Desweiteren setzen wir Google Adsense und Google Analytics ein.

Antwort schreiben 
 
Themabewertung:
  • 0 Bewertungen - 0 im Durchschnitt
  • 1
  • 2
  • 3
  • 4
  • 5
Wire.h und SD.h nicht kompatibel?
18.11.2015, 19:57 (Dieser Beitrag wurde zuletzt bearbeitet: 18.11.2015 20:01 von HaWe.)
Beitrag #9
RE: Wire.h und SD.h nicht kompatibel?
pin 6 ???
klar dürfen i2c und SPI nicht am selben Pin hängen, das ist doch logisch!

aber normalerweise ist bei Uno Boards i2c an analog 4+5 und SPI an digital 10-13,

und an Mega ist i2c an extra i2c Pins (20/21 oder so) und SPI an 50-52/53.

außerdem braucht jedes SPI Gerät (SD, TFT,...) einen eigenen, einzigartigen CS/SS-Pin (chip-select oder slave-select).

Was hast du denn für ein Board und was für ein seltsames Shield ???
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
18.11.2015, 20:45
Beitrag #10
RE: Wire.h und SD.h nicht kompatibel?
(18.11.2015 19:57)HaWe schrieb:  pin 6 ???
klar dürfen i2c und SPI nicht am selben Pin hängen, das ist doch logisch!

aber normalerweise ist bei Uno Boards i2c an analog 4+5 und SPI an digital 10-13,

und an Mega ist i2c an extra i2c Pins (20/21 oder so) und SPI an 50-52/53.

außerdem braucht jedes SPI Gerät (SD, TFT,...) einen eigenen, einzigartigen CS/SS-Pin (chip-select oder slave-select).

Was hast du denn für ein Board und was für ein seltsames Shield ???
Ja stimmt eigentlich mit i2c und spi... hab ich echt nicht nachgedacht
hab einen RFDuino
SD-Shield ist das: http://www.rfduino.com/product/rfd22130-...index.html
da ist der SCPin 6 und der Sl pin 5
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
22.11.2015, 13:16
Beitrag #11
RE: Wire.h und SD.h nicht kompatibel?
Also ich hab jetzt anstatt mit Wire.begin(); mit Wire.beginOnPins(0,1); meine I2c Übertragung auf 2 freien Pins gestartet und dementsprechend auch umgesteckt und jetzt funktionierts Smile

Danke für die Hilfe
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
23.11.2015, 12:51
Beitrag #12
RE: Wire.h und SD.h nicht kompatibel?
(22.11.2015 13:16)hulofu schrieb:  Also ich hab jetzt anstatt mit Wire.begin(); mit Wire.beginOnPins(0,1); meine I2c Übertragung auf 2 freien Pins gestartet und dementsprechend auch umgesteckt und jetzt funktionierts Smile

Danke für die Hilfe

Hallo,
du hast anfangs geschrieben, dass du die Standard-Lib Wire verwendest, ich habe jetzt aber 2 Funktionen gesehen, die ich von Wire nicht kenne:
Wire.speed = 400;
Wire.beginOnPins(0,1);
Welche Wire-Lib verwendest du und woher hast du sie?
Danke!!
Retian
Webseite des Benutzers besuchen Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
25.11.2015, 15:31
Beitrag #13
RE: Wire.h und SD.h nicht kompatibel?
(23.11.2015 12:51)Retian schrieb:  Welche Wire-Lib verwendest du und woher hast du sie?
Danke!!
Retian

Das ist die Wire Lib für RfDuino, also doch nicht die Standart Lib, hab aber keine Ahnung, wie universell die einsetzbar ist
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
25.11.2015, 20:50
Beitrag #14
RE: Wire.h und SD.h nicht kompatibel?
Hallo hulofu,
danke für die Klarstellung!
Gruß
Retian
Webseite des Benutzers besuchen Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
Antwort schreiben 


Möglicherweise verwandte Themen...
Thema: Verfasser Antworten: Ansichten: Letzter Beitrag
Rainbow File geht nicht zum compilieren!!!! Jocky 7 148 19.02.2017 20:01
Letzter Beitrag: Binatone
  IRremote bringe ich nicht zum laufen Franz54 5 98 19.02.2017 11:56
Letzter Beitrag: Tommy56
  Code aus 1.6.9 geht mit 1.8.1 nicht mehr zu kompilieren DL1AKP 7 260 02.02.2017 12:16
Letzter Beitrag: Tommy56
  Arduino Läst sich nicht Programmieren Micha06 4 188 29.01.2017 17:27
Letzter Beitrag: Micha06
  Nicht verzagen Forum fragen bergfrei 13 406 28.01.2017 06:09
Letzter Beitrag: dqb312
  Sloeber findet meinen Com Port nicht :-( Pfeilebastler 2 106 27.01.2017 11:11
Letzter Beitrag: hotsystems
  nRF24l01 empfängt Daten nicht techniclover 1 181 09.01.2017 19:20
Letzter Beitrag: celle
  [Gelöst] SD Card (Ethernet Shield) IO funktioniert nicht __jb__ 7 434 05.01.2017 09:51
Letzter Beitrag: rpt007
Wink Funktioniert, funktioniert nicht. clandestino 7 342 04.01.2017 22:54
Letzter Beitrag: renid55
  Drehencoder, ich verstehe es einfach nicht! Kitt 12 480 27.12.2016 21:39
Letzter Beitrag: Tommy56

Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste