INFO: Dieses Forum nutzt Cookies...
Cookies sind für den Betrieb des Forums unverzichtbar. Mit der Nutzung des Forums erklärst Du dich damit einverstanden, dass wir Cookies verwenden.

Es wird in jedem Fall ein Cookie gesetzt um diesen Hinweis nicht mehr zu erhalten. Desweiteren setzen wir Google Adsense und Google Analytics ein.

Antwort schreiben 
 
Themabewertung:
  • 0 Bewertungen - 0 im Durchschnitt
  • 1
  • 2
  • 3
  • 4
  • 5
Wemos TTGO XI 8F328P-I Nano V3.0
20.12.2018, 20:33
Beitrag #9
RE: Wemos TTGO XI 8F328P-U Nano V3.0
(04.11.2018 10:54)hotsystems schrieb:  
(04.11.2018 10:34)AnFi schrieb:  Ja, du hast recht! Der Prozessor arbeitet statt mit 16MHz (oder sogar maximal 32MHz) nur mit 4MHz.
Könnte sich eine reduzierte Frequenz auf Bauelemente (z.B. Funkmodule 433MHz > plötzlich in einem verbotenen Frequenbereich..) oder Software (z.B. I2C, Interrupt.. etc) auswirken? Kann man diese Frequenz auf dem Microcontroller beeinflussen (= erhöhen)?

Da müsste dann der Bootloader neu gebrannt werden. Den wirst du nur vom Hersteller bekommen. Einen direkten Einfluss auf andere Module hat es nicht, allerdings weiß ich, dass einige Libraries nur mit min. 8 MHz laufen.
Da heißt es dann Dokumentation lesen.

Erfolgserlebnis!
Der oben beschriebene Wemos lief mit 4MHz und sogar der Serial Monitor musste heruntergetunt werden, damit er funktioniert.
Auf der Webseite https://learn.adafruit.com/introducing-t...8mhz-clock fand ich interessante Hinweise, wie die Frequenz erhöht werden kann:
#include <avr/power.h>
und im Setup:
if (F_CPU == 16000000) clock_prescale_set(clock_div_2); > auf der Webseite steht allerdings ..(clock_div_1). Das ergab in meinem Fall 32MHz aber das machte die LCD nicht mit und ergab nur mismatch. Mit ..div_2 funktioniert der Wemos nun mit 16MHz!
Andreas
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
Antwort schreiben 


Möglicherweise verwandte Themen...
Thema: Verfasser Antworten: Ansichten: Letzter Beitrag
  Nano CH340 - Software Reset Lite 16 316 17.03.2019 20:07
Letzter Beitrag: Tommy56
  Kann ein Arduino Nano mittels delayMicroseconds(13) ein 38kHz-Signal erzeugen SchwuppSchwupp 3 343 13.03.2019 09:41
Letzter Beitrag: SchwuppSchwupp
  Nano - gelöste USB-Buchse wieder anlöten? Arduinero 7 1.534 27.01.2019 17:05
Letzter Beitrag: Chopp
  Nano spielt verrückt! AnFi 6 937 16.01.2019 02:54
Letzter Beitrag: Chopp
  PWM-Signal reduzieren auf 5V und per Nano auswerten (PulseIn) dionys 13 1.864 21.12.2018 21:38
Letzter Beitrag: georg01
  Fehlfunktion bei Nano + Servomotor im Batteriebetrieb Backtobasics 11 1.636 10.12.2018 11:11
Letzter Beitrag: Backtobasics
  Uno geht Nano nicht ... wieso? dani 14 2.422 29.09.2018 14:40
Letzter Beitrag: Bitklopfer
  Nano, nur oben Bauteile Mathias 5 1.296 01.09.2018 20:50
Letzter Beitrag: hotsystems
  China Nano mit CH340C + Win 10 läuft nicht mirco432 6 1.316 22.08.2018 12:18
Letzter Beitrag: hotsystems
  I2C bus ( Nano + PCA9685 ) wie verbinden ? uweq 11 2.052 31.07.2018 21:27
Letzter Beitrag: uweq

Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste