INFO: Dieses Forum nutzt Cookies...
Cookies sind für den Betrieb des Forums unverzichtbar. Mit der Nutzung des Forums erklärst Du dich damit einverstanden, dass wir Cookies verwenden.

Es wird in jedem Fall ein Cookie gesetzt um diesen Hinweis nicht mehr zu erhalten. Desweiteren setzen wir Google Adsense und Google Analytics ein.

Antwort schreiben 
 
Themabewertung:
  • 0 Bewertungen - 0 im Durchschnitt
  • 1
  • 2
  • 3
  • 4
  • 5
Welches Modul fehlt hier bitte noch aus dem Bordverwalter für das Wemos d1 ??
15.01.2019, 19:44
Beitrag #1
Welches Modul fehlt hier bitte noch aus dem Bordverwalter für das Wemos d1 ??
Hallo, guten Tag.
Ich habe dieses aus dem Bordverwalter für das Wemos d1 installiert bei der ArduinoIDE 1.6.8 :
esp8266bby esp8266 community version 2.5.0-beta2

Beim abspielen einiger original-Demos kommt immer diese Meldung:
---------------------------------------------------
Arduino: 1.6.8 (Windows 10), Board: "WeMos D1 R1, 80 MHz, Flash, Enabled, 4M (no SPIFFS), v2 Lower Memory, Disabled, None, Only Sketch, 921600"

In file included from C:\Users\pebi\AppData\Local\Arduino15\packages\esp8266\hardware\esp8266\2.5.0-beta2/tools/sdk/lwip2/include/lwip/opt.h:51:0,

from C:\Users\pebi\AppData\Local\Arduino15\packages\esp8266\hardware\esp8266\2.5.0-beta2/tools/sdk/lwip2/include/lwip/init.h:40,

from C:\Users\pebi\AppData\Local\Arduino15\packages\esp8266\hardware\esp8266\2.5.0-beta2\cores\esp8266/IPAddress.h:27,

from C:\Users\pebi\AppData\Local\Arduino15\packages\esp8266\hardware\esp8266\2.5.0-beta2\libraries\ESP8266WiFi\src/ESP8266WiFi.h:31,

from C:\Users\pebi\AppData\Local\Arduino15\packages\esp8266\hardware\esp8266\2.5.0-beta2\libraries\ESP8266HTTPClient\examples\Authorization\Authorization.ino:10:

C:\Users\pebi\AppData\Local\Arduino15\packages\esp8266\hardware\esp8266\2.5.0-beta2/tools/sdk/lwip2/include/lwipopts.h:1301:2: error: #error TCP_MSS must be defined

#error TCP_MSS must be defined

^

C:\Users\pebi\AppData\Local\Arduino15\packages\esp8266\hardware\esp8266\2.5.0-beta2/tools/sdk/lwip2/include/lwipopts.h:2381:2: error: #error LWIP_IPV6 must be defined

#error LWIP_IPV6 must be defined

^

C:\Users\pebi\AppData\Local\Arduino15\packages\esp8266\hardware\esp8266\2.5.0-beta2/tools/sdk/lwip2/include/lwipopts.h:3534:2: error: #error LWIP_FEATURES must be defined

#error LWIP_FEATURES must be defined

^

In file included from C:\Users\pebi\AppData\Local\Arduino15\packages\esp8266\hardware\esp8266\2.5.0-beta2\libraries\ESP8266WiFi\src/ESP8266WiFiSTA.h:29:0,

from C:\Users\pebi\AppData\Local\Arduino15\packages\esp8266\hardware\esp8266\2.5.0-beta2\libraries\ESP8266WiFi\src/ESP8266WiFi.h:34,

from C:\Users\pebi\AppData\Local\Arduino15\packages\esp8266\hardware\esp8266\2.5.0-beta2\libraries\ESP8266HTTPClient\examples\Authorization\Authorization.ino:10:

C:\Users\pebi\AppData\Local\Arduino15\packages\esp8266\hardware\esp8266\2.5.0-beta2/tools/sdk/include/user_interface.h:34:2: error: #error LWIP_OPEN_SRC must be defined

#error LWIP_OPEN_SRC must be defined

^

exit status 1
Fehler beim Kompilieren für das Board WeMos D1 R1.

--------------------------------------------------------

Ich weiss nicht , welches Programm ich noch aus dem Bordvwerwalter installieren muss?
Vielleicht kann einer von euch bitte auf Anhieb sagen welches Modul da noch fehlt.

Danke.
Gruss
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
15.01.2019, 20:16
Beitrag #2
RE: Welches Modul fehlt hier bitte noch aus dem Bordverwalter für das Wemos d1 ??
Du verwendest eine Beta-Version. Diese sind eigentlich zum Testen durch erfahrene Entwickler gedacht und noch nicht stabil.

Vorschlag: Deinstalliere die Version 2.5.0 Dann IDE neu starten, dann die Version 2.4.2 installieren.

Gruß Tommy

"Wer den schnellen Erfolg sucht, sollte nicht programmieren, sondern Holz hacken." (Quelle unbekannt)
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
16.01.2019, 19:14
Beitrag #3
RE: Welches Modul fehlt hier bitte noch aus dem Bordverwalter für das Wemos d1 ??
Danke für die Info.
Mit der Version 2.4.2 funktioniert es.

Gruss
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
16.01.2019, 19:23
Beitrag #4
RE: Welches Modul fehlt hier bitte noch aus dem Bordverwalter für das Wemos d1 ??
Prima und danke für die Rückmeldung.

Gruß Tommy

"Wer den schnellen Erfolg sucht, sollte nicht programmieren, sondern Holz hacken." (Quelle unbekannt)
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
Antwort schreiben 


Möglicherweise verwandte Themen...
Thema: Verfasser Antworten: Ansichten: Letzter Beitrag
  Wemos D1 R2, Kein Reset wenn 5V Ausgang belegt ist LutzS 14 476 24.05.2020 21:07
Letzter Beitrag: LutzS
  Wemos D1 mini (ESP8266) wechselt nicht mehr in auto-sleep Zipfel1 5 691 27.04.2020 14:07
Letzter Beitrag: rev.antun
  ESP32 mit Ethernet W5500 Modul als Wlan-Adapter RainerR 3 542 03.04.2020 11:28
Letzter Beitrag: Tommy56
  Wemos D1 mini mit Switch input ButtaMartin 3 662 06.03.2020 14:17
Letzter Beitrag: ButtaMartin
  Wemos D1 Mini Deepsleep Wlan Zeit plastikjoe 11 2.381 29.02.2020 11:29
Letzter Beitrag: Tommy56
  Wemos LOLIN32 OLED "WetterUhr" 4711engel 24 3.126 12.02.2020 16:43
Letzter Beitrag: Tommy56
  Mit Wemos D1 eine Webseite aufrufen DO3GE 18 2.508 02.02.2020 14:58
Letzter Beitrag: Gorathan
  MQTT / RSL problem am Wemos D1 Mini myreal84 7 1.035 19.01.2020 13:42
Letzter Beitrag: Fips
  Wemos D1 R1 PS2 Tastatur Wolli501 3 803 30.11.2019 00:30
Letzter Beitrag: Bitklopfer
  Esp8266-->Wemos D1: Nicht funktionsfähige WiFi Chips KarlMarv 14 5.188 29.10.2019 13:48
Letzter Beitrag: uweausbaden

Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste