INFO: Dieses Forum nutzt Cookies...
Cookies sind für den Betrieb des Forums unverzichtbar. Mit der Nutzung des Forums erklärst Du dich damit einverstanden, dass wir Cookies verwenden.

Es wird in jedem Fall ein Cookie gesetzt um diesen Hinweis nicht mehr zu erhalten. Desweiteren setzen wir Google Adsense und Google Analytics ein.

Antwort schreiben 
 
Themabewertung:
  • 0 Bewertungen - 0 im Durchschnitt
  • 1
  • 2
  • 3
  • 4
  • 5
Von mehreren Libarys wird eine nicht erkannt
20.08.2014, 22:10
Beitrag #1
Von mehreren Libarys wird eine nicht erkannt
Hallo,

ich habe folgendes Problem:

Habe die Library http://playground.arduino.cc/Code/dateTime heruntergeladen, ausgepackt und die beiden dort enthaltenen Librarys in den passenden Ordner kopiert.

Eine von den beiden wird erkannt (DateTimeStrings.h), die andere nicht (DateTime.h).

Beim Befehl #include DateTimeStrings.h wird diese Library auch in orange angezeigt, die DateTime.h nicht obwohl DateTime.h in der keywords.txt drinsteht.

Dasselbe verhalten habe ich auch mit einer weiteren Time.h Library die anscheinend die "verbesserte" Version der DateTime.h sein soll.

Hat mir vielleicht jemand einen Tipp?

Anbei ein screenshot vom Anfang des Programms und des Ordners mit den Librarys.


Angehängte Datei(en) Thumbnail(s)
   
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
21.08.2014, 21:30
Beitrag #2
RE: Von mehreren Libarys wird eine nicht erkannt
Hi Foto-Ralf,
helfen kann ich dir nicht direkt, aber wie macht es sich bemerkbar, dass sie nicht erkannt wird? kommt beim Überprüfen eine Fehlermeldung?
Falls ja solltest du diese mal posten, ggf. kann dir dann jemand helfen.
Hast du mal die Ordner der Lib. geöffnet? In meiner Time Lib sind examples, keywords und readme, sollte alless unwichtig sein, aber die datastrings.ccp die time.ccp und die time (H Datei) sollten da sein, nicht das beim entpacken oder kopieren was verloren ging.

Mfg Sascha
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
22.08.2014, 08:53
Beitrag #3
RE: Von mehreren Libarys wird eine nicht erkannt
Hallo,
Die Farbe sagt nichts darüber aus. Hatte ich auch, schau dir mal das an:
http://www.arduinoforum.de/arduino-Threa...ht-erkannt

Wenn du die Libary über das Menu einfügen kannst ist alles ok.

Gruss Leto73
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
22.08.2014, 15:24
Beitrag #4
RE: Von mehreren Libarys wird eine nicht erkannt
Die Dateien sind alle in den entsprechenden Unterordnern. Mit dem Texteditor geöffnet und Programmiersprache "c" ausgewählt sieht auch alles plausibel aus.

Beim kompilieren kommt folgende Fehlermeldung:

C:\PAF\arduino-1.0.5\libraries\DateTime\DateTime.cpp: In member function 'void DateTimeClass::setTime(time_t)':
C:\PAF\arduino-1.0.5\libraries\DateTime\DateTime.cpp:28: error: 'millis' was not declared in this scope
C:\PAF\arduino-1.0.5\libraries\DateTime\DateTime.cpp: In member function 'time_t DateTimeClass::now()':
C:\PAF\arduino-1.0.5\libraries\DateTime\DateTime.cpp:43: error: 'millis' was not declared in this scope

Wenn ich die Library über die Arduino-Oberfläche versuche zu integrieren passiert dasselbe: Die Library ist vorhanden, lässt sich einbinden aber es kommt dieselbe Fehlermeldung.
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
22.08.2014, 16:03
Beitrag #5
RE: Von mehreren Libarys wird eine nicht erkannt
Hi,
in einem englischen Forum gefunden:
Zitat:Add this #include <Arduino.h> to your DateTime.cpp
Das ist allerdings etwas komisch. Kann es sein, dass die DateTime Lib etwas veraltet ist? Versuche mal lieber die Time Libary zu verwenden. Siehe auch hier: http://playground.arduino.cc/Code/dateTime. Da steht deutlich, dass das Ding veraltet ist.
Gruß,
Thorten

Falls ich mit einer Antwort helfen konnte, wuerde ich mich freuen, ein paar Fotos oder auch ein kleines Filmchen des zugehoerigen Projekts zu sehen.
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
Antwort schreiben 


Möglicherweise verwandte Themen...
Thema: Verfasser Antworten: Ansichten: Letzter Beitrag
  328P geht nicht mehr Harry 23 572 Heute 19:33
Letzter Beitrag: Harry
  Rotaryencoder funktioniert nicht richtig 123clever 18 299 17.02.2018 21:38
Letzter Beitrag: georg01
  Echtzeituhrmodul läuft nicht scritch 64 2.736 28.01.2018 14:16
Letzter Beitrag: Tommy56
  Schon wieder eine Zeitschaltung Eckardt 7 280 28.01.2018 10:26
Letzter Beitrag: Tommy56
Bug I2C Displays wollen nicht mehr Der Ausserirdische 12 560 30.12.2017 17:11
Letzter Beitrag: hotsystems
  Uhr funktioniert nicht Jakob 8 540 30.12.2017 00:15
Letzter Beitrag: hotsystems
Sad Loop Schleife wird unterbrochen? M3tzl3r 4 343 21.12.2017 23:44
Letzter Beitrag: hotsystems
  Eine Funktion verlassen Jan5663 8 538 18.12.2017 13:49
Letzter Beitrag: Chopp
  BME280 wird nicht erkannt sowerum 14 670 10.12.2017 22:14
Letzter Beitrag: Tommy56
  Eine void starten mit eine Android app Atwist 8 614 04.12.2017 19:18
Letzter Beitrag: MicroBahner

Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste