INFO: Dieses Forum nutzt Cookies...
Cookies sind für den Betrieb des Forums unverzichtbar. Mit der Nutzung des Forums erklärst Du dich damit einverstanden, dass wir Cookies verwenden.

Es wird in jedem Fall ein Cookie gesetzt um diesen Hinweis nicht mehr zu erhalten. Desweiteren setzen wir Google Adsense und Google Analytics ein.

Antwort schreiben 
 
Themabewertung:
  • 0 Bewertungen - 0 im Durchschnitt
  • 1
  • 2
  • 3
  • 4
  • 5
Verständnis Problem
23.11.2015, 20:05
Beitrag #1
Verständnis Problem
Hallo, ich habe in kleines Verständnis Problem mit der Programmierung meines Arduinos.
Ich möchte damit eine Wählscheibe auslesen, so dass es mir auf dem Seriellen Monitor anzeigt, welche Zahl ich gewählt habe.

Das Problem ist jetzt, dass im Seriellen Monitor die Werten immer mit der Baud-rate abgefragt werden.
Wie bekomme ist das denn Weg?
Es soll mir also nur einmal Anzeigen:
Bsp: "es wählt" und nicht die ganze Zeit "es wählt" hintereinnander.
Ich habe schon länger mit if und whlie Schleifen probiert, aber damit komme ich nicht weiter.

Ich hoffe ihr könnt mir helfen Blush
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
23.11.2015, 20:50
Beitrag #2
RE: Verständnis Problem
Das klingt so, als wenn in jedem Loop ein Serial.print ausgeführt wird.

Du musst aber die Pulse erst zählen, bis keiner mehr kommt und dann den gezählten Wert schicken.

Binatone
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
23.11.2015, 21:16
Beitrag #3
RE: Verständnis Problem
So ähnlich wollte ich das umsetzen. Das steht in meiner loop:
Code:
if(analogRead(0)>400){
             if (analogRead(1) < 400) {
             zahl++;
             digitalWrite (13, HIGH);    
           } else if (analogRead(1) >= 400)
           {
              digitalWrite (13, LOW);
           }
}

Beim Eingang 0 liegt so lange keine Spannung an, solange es wählt.
Beim Eingang 1 kommen die Pulse und Ausgang 13 ist eine LED zur Pulsanzeige.
Wenn ich dann nach der Schleife eine Serielle Ausgabe mache, laufen die Zahlen ständig durch.
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
23.11.2015, 21:55
Beitrag #4
RE: Verständnis Problem
Warum machst du das mit einem analogen Eingang.
Ich würde es mit einem digitalen Port machen und den dann auf High oder Low abfragen.
Wichtig hierbei ist das entprellen des Kontaktes und den Pullup oder Pulldown nicht vergessen.
Anders bekommst du immer falsche Werte.

I2C = weniger ist mehr: weniger Kabel, mehr Probleme. Cool
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
24.11.2015, 18:04
Beitrag #5
RE: Verständnis Problem
(23.11.2015 21:55)hotsystems schrieb:  Warum machst du das mit einem analogen Eingang.
Ich würde es mit einem digitalen Port machen und den dann auf High oder Low abfragen.
Wichtig hierbei ist das entprellen des Kontaktes und den Pullup oder Pulldown nicht vergessen.
Anders bekommst du immer falsche Werte.

das wäre auch eine Alternative, aber das ändert doch nichts an dem Problem oder?
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
24.11.2015, 18:09 (Dieser Beitrag wurde zuletzt bearbeitet: 24.11.2015 18:13 von hotsystems.)
Beitrag #6
RE: Verständnis Problem
Hast du schon mal nach eine Library dafür gesucht?

Hier findest du evtl. etwas, was dir weiter hilft.

https://github.com/markfickett/Rotary-Dial

I2C = weniger ist mehr: weniger Kabel, mehr Probleme. Cool
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
Antwort schreiben 


Möglicherweise verwandte Themen...
Thema: Verfasser Antworten: Ansichten: Letzter Beitrag
Question Problem beim Hochladen auf AtTiny45. Hilfe -.- Jonas Lindenblatt 5 117 24.03.2017 22:58
Letzter Beitrag: Tommy56
  ESP8622 - 01 sendet UDP - Problem WLan Kriskind 37 2.592 14.03.2017 19:49
Letzter Beitrag: Tommy56
  Smart Home Webserver Basic Authentication Problem Osotastic 21 558 20.02.2017 18:00
Letzter Beitrag: Tommy56
  Problem mit Sketch senden an Uno feuerwehr 5 455 31.01.2017 20:41
Letzter Beitrag: Tommy56
  Beim Hochladen USB Problem Nils 10 659 29.12.2016 21:05
Letzter Beitrag: renid55
  Problem mit SD Card Library BennIY 4 402 06.10.2016 18:38
Letzter Beitrag: Bitklopfer
  Problem mit SD.remove Eichner 6 325 22.08.2016 19:42
Letzter Beitrag: Eichner
  4x16 Tastermatrix Problem Michel 16 1.148 14.07.2016 10:02
Letzter Beitrag: StephanBuerger
  Problem mit Delay und Millis funnyzocker 1 673 26.06.2016 09:54
Letzter Beitrag: hotsystems
  Problem mit ESP8266 und EMail senden torsten_156 1 967 13.06.2016 21:14
Letzter Beitrag: torsten_156

Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste