INFO: Dieses Forum nutzt Cookies...
Cookies sind für den Betrieb des Forums unverzichtbar. Mit der Nutzung des Forums erklärst Du dich damit einverstanden, dass wir Cookies verwenden.

Es wird in jedem Fall ein Cookie gesetzt um diesen Hinweis nicht mehr zu erhalten. Desweiteren setzen wir Google Adsense und Google Analytics ein.

Antwort schreiben 
 
Themabewertung:
  • 0 Bewertungen - 0 im Durchschnitt
  • 1
  • 2
  • 3
  • 4
  • 5
Verbindung zwischen BLE Shield und Feather32u4
08.05.2019, 12:14
Beitrag #9
RE: Verbindung zwischen BLE Shield und Feather32u4
Bei dem BLE-Shield habe ich die Brücken verändert: RX auf Pin0 und TX auf Pin1. (Davor war RX auf PIN 3 und TX auf Pin 2) Damit komme ich bei einem leeren Sketch in den AT-Modus. Im seriellen Monitor habe ich "AT+ROLE?" eingegeben und mir wurde "OK+Get:0" zurückgegeben.

Bei dem Feather habe ich das Beispiel atcommand hochgeladen. Einige AT-Commands funktionieren, andere nicht.
Ich habe nur die AT-Commands verwendet, die auf der Homepage von Adafruit gezeigt sind:
https://learn.adafruit.com/adafruit-feat...t-commands
Auf dieser Seite und auf den folgenden. Aber ich konnte nicht herausfinden, ob dieser jetzt ein Master oder ein Slave ist. Es scheint keinen passenden At-Command zu geben.

Gruß WinTiger
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
11.05.2019, 13:38
Beitrag #10
RE: Verbindung zwischen BLE Shield und Feather32u4
Gibt es wirklich niemanden der sich damit auskennt? Oder ist meine Idee eine so seltene?
Ich freue mich über Hilfestellungen.
Oder stimmt etwas mit meinen Geräten nicht, dass keine Verbindung hergestellt werden kann? Eigentlich, sollte die Verbindung ohne großem Programmieraufwand hergestellt werden können.

Gruß WinTiger
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
21.05.2019, 11:07
Beitrag #11
RE: Verbindung zwischen BLE Shield und Feather32u4
Also, die Verbindung konnte bisher niemand lösen. Das nicht ohne Grund. So weit wie ich es herausfinden konnte, kann die Feather nicht als Master fungieren. Theoretisch könnte aber die Verbindung über den UNO (als Master) hergestellt werden. Dies funktioniert auch nicht.
Meine Lösung ist, dass die Anordnung einfach nicht miteinander funktionieren kann. Die beiden Module können nicht in Verbindung gesetzt werden.
In meinem Fall weiche ich auf andere Komponenten aus. Falls ich falsch liege oder es jemand hinbekommt, würde ich gerne dazu lernen.
Ich hoffe es hilft jemandem und derjenige weicht vorher auf alternative Komponenten aus.
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
Antwort schreiben 


Möglicherweise verwandte Themen...
Thema: Verfasser Antworten: Ansichten: Letzter Beitrag
Lightbulb HC05 Bluetooth auf Verbindung / Empfang überprüfen Beatzler 6 268 Gestern 15:09
Letzter Beitrag: hotsystems
  Bluetooth shield HC06 RCudino 16 438 04.02.2020 22:07
Letzter Beitrag: Tommy56
  Berechnen der Entfernung zwischen 2 GPS Koordinaten louard 3 275 02.02.2020 18:29
Letzter Beitrag: louard
  Zeitmessen zwischen 2 Impulse Lothileinchen 10 344 02.02.2020 16:48
Letzter Beitrag: Lothileinchen
  Mit einen Taster zwischen zwei Ausgängen Toggeln luft-post 6 299 13.01.2020 17:41
Letzter Beitrag: hotsystems
  SD shield / Kein Zugriff auf Karte Ernie70 33 1.242 10.01.2020 18:06
Letzter Beitrag: Tommy56
  Arduino Mega mit Lan Shield und Googlemail Franzel007 8 600 20.12.2019 17:20
Letzter Beitrag: Franzel007
Lightbulb Internet Verbindung Mirkan 1 335 11.11.2019 09:39
Letzter Beitrag: hotsystems
  CAN BUS Shield / Lesen von Nachrichten Gary 0 384 13.10.2019 20:07
Letzter Beitrag: Gary
  Arduino Mega mit CAN-Shield Gary 5 588 09.10.2019 23:38
Letzter Beitrag: Bitklopfer

Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste