INFO: Dieses Forum nutzt Cookies...
Cookies sind für den Betrieb des Forums unverzichtbar. Mit der Nutzung des Forums erklärst Du dich damit einverstanden, dass wir Cookies verwenden.

Es wird in jedem Fall ein Cookie gesetzt um diesen Hinweis nicht mehr zu erhalten. Desweiteren setzen wir Google Adsense und Google Analytics ein.

Antwort schreiben 
 
Themabewertung:
  • 0 Bewertungen - 0 im Durchschnitt
  • 1
  • 2
  • 3
  • 4
  • 5
Variableninhalt (Schleife) geht verloren
15.04.2015, 08:15
Beitrag #33
RE: Variableninhalt (Schleife) geht verloren
(15.04.2015 06:26)scritch schrieb:  So, habe das ganze mal auf das nötigste gekürzt. Der Fehler bleibt nach wie vor, vielleicht hilft das ja.
So wie ich Deine vorherigen Beiträge verstanden habe ist das aber gerade das funktionierende Coding, oder?

Falls ich mit einer Antwort helfen konnte, wuerde ich mich freuen, ein paar Fotos oder auch ein kleines Filmchen des zugehoerigen Projekts zu sehen.
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
15.04.2015, 08:46
Beitrag #34
RE: Variableninhalt (Schleife) geht verloren
neuer Fehler:

sketch_apr15a.ino:2:20: fatal error: EEPROM.h: No such file or directory
compilation terminated.
Fehler beim Übersetzen


dann hat man beim Due allerdings geloost, denn der hat gar keine EEPROM... Wink
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
15.04.2015, 08:56
Beitrag #35
RE: Variableninhalt (Schleife) geht verloren
Der Sketch benutzt doch gar kein EEPROM...

Falls ich mit einer Antwort helfen konnte, wuerde ich mich freuen, ein paar Fotos oder auch ein kleines Filmchen des zugehoerigen Projekts zu sehen.
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
15.04.2015, 09:10
Beitrag #36
RE: Variableninhalt (Schleife) geht verloren
kA, vllt aber die lib?
muss dann leider erstmal jemand anders testen... Undecided
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
15.04.2015, 09:28 (Dieser Beitrag wurde zuletzt bearbeitet: 15.04.2015 09:30 von scritch.)
Beitrag #37
RE: Variableninhalt (Schleife) geht verloren
(15.04.2015 08:15)Thorsten Pferdekämper schrieb:  
(15.04.2015 06:26)scritch schrieb:  So, habe das ganze mal auf das nötigste gekürzt. Der Fehler bleibt nach wie vor, vielleicht hilft das ja.
So wie ich Deine vorherigen Beiträge verstanden habe ist das aber gerade das funktionierende Coding, oder?

Ne, das ist der Code der zwar fehlerfrei kompiliert werden kann, allerdings nicht so läuft wie er soll. So wie er jetzt da steht, wird das i vom serial.print richtig ausgegeben (steht in der 2. for-Schleife). Sobald du das serial.print in die while-Schleife packst, wird i nicht mehr korrekt ausgegeben, sondern nur noch 0.

@tito-t: Lösche einfach das include vom eeprom. In dem Beispielcode wird der eeprom nicht gebraucht. Hatte das nur vergessen raus zu löschen, im richtigen Code verwende ich den eeprom.
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
16.04.2015, 17:03
Beitrag #38
RE: Variableninhalt (Schleife) geht verloren
Betretenes Schweigen Big Grin Ist das evt. ein Bug in irgendeiner Libary? Wenn wir das Problem nicht lösen können, können wir es irgendwie umgehen?
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
16.04.2015, 17:53
Beitrag #39
RE: Variableninhalt (Schleife) geht verloren
Vielleicht glaubt Dir einfach keiner...

Falls ich mit einer Antwort helfen konnte, wuerde ich mich freuen, ein paar Fotos oder auch ein kleines Filmchen des zugehoerigen Projekts zu sehen.
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
16.04.2015, 18:00
Beitrag #40
RE: Variableninhalt (Schleife) geht verloren
Dafür habe ich den Code gepostet damit ihr euch davon überzeugen könnt. Wieso sollte ich lügen?
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
Antwort schreiben 


Möglicherweise verwandte Themen...
Thema: Verfasser Antworten: Ansichten: Letzter Beitrag
  mit if aus do-while oder while Schleife aussteigen Nafetz 6 116 05.12.2016 21:41
Letzter Beitrag: Pit
  while Schleife nach sleep mode interrupt tklaus 13 262 23.11.2016 17:40
Letzter Beitrag: Tommy56
  Do-While-Schleife Abbruchbedinung Majera 14 261 22.11.2016 18:07
Letzter Beitrag: Pit
  Schleife Hannes 3 196 16.11.2016 00:54
Letzter Beitrag: Hannes
  SoftwareSerial Baudrate automatisch korrekt erkennen - geht das? Gelegenheitsbastler 5 533 21.04.2016 12:32
Letzter Beitrag: SkobyMobil
  Problem: SDFat - Das Ende einer Datei finden und Schleife beenden MartinK 4 490 01.04.2016 05:49
Letzter Beitrag: MartinK
  for - Schleife #elextro19 6 713 27.03.2016 13:21
Letzter Beitrag: #elextro19
  Aus While-Schleife durch Interrupt aussteigen Zill3 10 1.191 08.02.2016 16:28
Letzter Beitrag: ardu_arne
  Den 1. nRF24L01 auf "T" setzen und den 2. auf "R" setzen, wie geht das bitte ? arduinofan 3 438 01.02.2016 20:10
Letzter Beitrag: arduinofan
  Stringvariable senden beim ESP8266 geht nicht , warum ? arduinofan 9 1.136 12.01.2016 11:05
Letzter Beitrag: arduinofan

Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste