INFO: Dieses Forum nutzt Cookies...
Cookies sind für den Betrieb des Forums unverzichtbar. Mit der Nutzung des Forums erklärst Du dich damit einverstanden, dass wir Cookies verwenden.

Es wird in jedem Fall ein Cookie gesetzt um diesen Hinweis nicht mehr zu erhalten. Desweiteren setzen wir Google Adsense und Google Analytics ein.

Antwort schreiben 
 
Themabewertung:
  • 0 Bewertungen - 0 im Durchschnitt
  • 1
  • 2
  • 3
  • 4
  • 5
Variableninhalt (Schleife) geht verloren
14.04.2015, 12:33
Beitrag #17
RE: Variableninhalt (Schleife) geht verloren
Hi,
trotzdem solltest Du mal das Coding zeigen. D.h. die zwei Varianten mit dem print einmal innerhalb und einmal außerhalb der while-Schleife.
Gruß,
Thorsten

Falls ich mit einer Antwort helfen konnte, wuerde ich mich freuen, ein paar Fotos oder auch ein kleines Filmchen des zugehoerigen Projekts zu sehen.
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
14.04.2015, 13:06 (Dieser Beitrag wurde zuletzt bearbeitet: 14.04.2015 13:16 von scritch.)
Beitrag #18
RE: Variableninhalt (Schleife) geht verloren
So gibt er immer nur 0 aus (auf das serial.print achten):

Code:
random_rot = random(0, 255); // Beinhaltet den Wert einer Randomfarbe, in diesem Fall rot
for( int i=0 ; i < num_stripes ; i++){
for(int j=0; j < NUMPIXELS; j++){
delay(180);
while(random_rot > temp_rot || random_rot < temp_rot){
  Serial.print(i);
  Serial.print("\t");
  delay(10);
  if(random_rot > temp_rot){
   temp_rot++;
   stripes[i].setPixelColor(j, stripes[i].Color(temp_rot, temp_gruen, temp_blau));
   stripes[i].show();
   f_interval(delay_random_led_on);
}
  f(random_rot < temp_rot){
   temp_rot --;
   stripes[i].setPixelColor(j, stripes[i].Color(temp_rot, temp_gruen, temp_blau));
   stripes[i].show();
   f_interval(delay_random_led_on);
  }
}//provisorisch  
}
}
temp_rot = random_rot;

So hingegen zählt er wie er soll:

Code:
random_rot = random(0, 255); // Beinhaltet den Wert einer Randomfarbe, in diesem Fall rot
for( int i=0 ; i < num_stripes ; i++){
for(int j=0; j < NUMPIXELS; j++){
  Serial.print(i);
  Serial.print("\t");
  delay(10);
delay(180);
while(random_rot > temp_rot || random_rot < temp_rot){
  if(random_rot > temp_rot){
   temp_rot++;
   stripes[i].setPixelColor(j, stripes[i].Color(temp_rot, temp_gruen, temp_blau));
   stripes[i].show();
   f_interval(delay_random_led_on);
}
  f(random_rot < temp_rot){
   temp_rot --;
   stripes[i].setPixelColor(j, stripes[i].Color(temp_rot, temp_gruen, temp_blau));
   stripes[i].show();
   f_interval(delay_random_led_on);
  }
}//provisorisch  
}
}
temp_rot = random_rot;
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
14.04.2015, 13:14
Beitrag #19
RE: Variableninhalt (Schleife) geht verloren
Das ist wirklich sehr seltsam. Kann es sein, dass Du ein Speicherplatz-Problem hast?

Falls ich mit einer Antwort helfen konnte, wuerde ich mich freuen, ein paar Fotos oder auch ein kleines Filmchen des zugehoerigen Projekts zu sehen.
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
14.04.2015, 13:21
Beitrag #20
RE: Variableninhalt (Schleife) geht verloren
Weiss ich nicht, wie würde ich das merken?
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
14.04.2015, 14:42 (Dieser Beitrag wurde zuletzt bearbeitet: 14.04.2015 14:45 von tito-t.)
Beitrag #21
RE: Variableninhalt (Schleife) geht verloren
hallo, das hier kann nicht dein wirklich benutzer Code sein, der angeblich funktioniert, denn er führt mit Sicherheit zu Compilerfehlern:
Zitat:So hingegen zählt er wie er soll:

Code:
random_rot = random(0, 255); // Beinhaltet den Wert einer Randomfarbe, in diesem Fall rot
for( int i=0 ; i < num_stripes ; i++){
for(int j=0; j < NUMPIXELS; j++){
  Serial.print(i);
  Serial.print("\t");
  delay(10);
delay(180);
while(random_rot > temp_rot || random_rot < temp_rot){
  if(random_rot > temp_rot){
   temp_rot++;
   stripes[i].setPixelColor(j, stripes[i].Color(temp_rot, temp_gruen, temp_blau));
   stripes[i].show();
   f_interval(delay_random_led_on);
}
  f(random_rot < temp_rot){
   temp_rot --;
   stripes[i].setPixelColor(j, stripes[i].Color(temp_rot, temp_gruen, temp_blau));
   stripes[i].show();
   f_interval(delay_random_led_on);
  }
}//provisorisch  
}
}
temp_rot = random_rot;

guck doch mal bitte, ob du nicht den wirklich verwendeten, funktionierenden Code posten kannst!
Außerdem sind die Einrückungen nicht korrekt, das wäre aber hilfreich fürs Debuggen!
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
14.04.2015, 14:46
Beitrag #22
RE: Variableninhalt (Schleife) geht verloren
(14.04.2015 13:21)scritch schrieb:  Weiss ich nicht, wie würde ich das merken?
Da gibt's eine Funktion, die man verwenden kann, um den verbleibenden Speicherplatz zu ermitteln. Ich glaube, die habe ich auch schon irgendwo gepostet.
Versuch's mal selbst mit google und sowas wie "arduino remaining memory" oder so.

Falls ich mit einer Antwort helfen konnte, wuerde ich mich freuen, ein paar Fotos oder auch ein kleines Filmchen des zugehoerigen Projekts zu sehen.
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
14.04.2015, 14:49
Beitrag #23
RE: Variableninhalt (Schleife) geht verloren
Oder einfach mal schauen was der Compiler ausspuckt.
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
14.04.2015, 15:14
Beitrag #24
RE: Variableninhalt (Schleife) geht verloren
(14.04.2015 14:42)tito-t schrieb:  guck doch mal bitte, ob du nicht den wirklich verwendeten, funktionierenden Code posten kannst!
Außerdem sind die Einrückungen nicht korrekt, das wäre aber hilfreich fürs Debuggen!
Klar, kann ich. Das wäre aber nicht hilfreich, da es 1300 Zeilen Code sind Angel

Der Teil an sich funktioniert, bis auf das ausgeben von i und j in der while-Schleife.
@memerqi: Der Compiler sagt dass alles Roger ist und kompiliert ohne Fehler. Die Übertagung zum µController ist fehlerfrei.
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
Antwort schreiben 


Möglicherweise verwandte Themen...
Thema: Verfasser Antworten: Ansichten: Letzter Beitrag
  328P geht nicht mehr [gelöst] Harry 37 2.926 04.03.2018 19:57
Letzter Beitrag: Harry
  Unverständnis bei FOR-Schleife Telefonmann 3 327 22.02.2018 14:29
Letzter Beitrag: Telefonmann
  Variablenname über Schleife deklarieren golden_eagle 9 570 12.02.2018 22:36
Letzter Beitrag: golden_eagle
  Schleife nach else beenden Chef_2 24 1.278 08.02.2018 23:28
Letzter Beitrag: Franz54
  Bei Power ein geht der Servo auf 90 Grad ? Franz54 12 1.388 09.01.2018 20:55
Letzter Beitrag: Franz54
  While Schleife in einer If abfrage Thorsten_S 4 580 30.12.2017 16:37
Letzter Beitrag: Thorsten_S
Sad Loop Schleife wird unterbrochen? M3tzl3r 4 609 21.12.2017 23:44
Letzter Beitrag: hotsystems
  I2C Slave Empfang geht aber Senden? Franz54 9 1.148 09.11.2017 22:05
Letzter Beitrag: Tommy56
  ATtiny13 mit der Arduino IDE 1.0.6 programmieren - geht das? Gelegenheitsbastler 5 3.660 11.09.2017 15:24
Letzter Beitrag: Mathias
  LCD geht nicht - keine Ahnung warum?? DL1AKP 12 1.576 15.05.2017 13:17
Letzter Beitrag: DL1AKP

Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste