INFO: Dieses Forum nutzt Cookies...
Cookies sind für den Betrieb des Forums unverzichtbar. Mit der Nutzung des Forums erklärst Du dich damit einverstanden, dass wir Cookies verwenden.

Es wird in jedem Fall ein Cookie gesetzt um diesen Hinweis nicht mehr zu erhalten. Desweiteren setzen wir Google Adsense und Google Analytics ein.

Antwort schreiben 
 
Themabewertung:
  • 0 Bewertungen - 0 im Durchschnitt
  • 1
  • 2
  • 3
  • 4
  • 5
Variablen Fehler bei TFT Display
08.05.2015, 11:53
Beitrag #1
Variablen Fehler bei TFT Display
Hallo, ich versuche gerade auf einem 3,2 " TFT Display (UTFT Library) mit Arduino Mega 2560 und TFT Zwischenshield Variablen von einem DCF77 darzustellen.
Wenn ich Positionen ( nach hour, minute, second) angebe kommen nur Fehlermeldungen.

Zitat: {
delay(200);
time_t DCFtime = DCF.getTime(); // Check if new DCF77 time is available
if (DCFtime!=0)
{
setTime(DCFtime);
}

//_________Ausgabe______________


myGLCD.setColor(255, 0, 255);
if(hour() < 10)
myGLCD.print("0");
myGLCD.print(hour()); // Eingabe : my GLCD.print(hour() ; LEFT ; 180)
myGLCD.print(":");
if(minute() < 10)
myGLCD.print("0");
myGLCD.print(minute());
myGLCD.print(":");
if(second() < 10)
myGLCD.print("0");
myGLCD.print(second());
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
08.05.2015, 13:10
Beitrag #2
RE: Variablen Fehler bei TFT Display
Na dann zeig doch mal die Fehlermeldungen...
Ich vermute mal, dass das myGLCD.print nur Strings (char-Arrays) ausgeben kann. In dem fall: sprintf
Gruß,
Thorsten

Falls ich mit einer Antwort helfen konnte, wuerde ich mich freuen, ein paar Fotos oder auch ein kleines Filmchen des zugehoerigen Projekts zu sehen.
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
Antwort schreiben 


Möglicherweise verwandte Themen...
Thema: Verfasser Antworten: Ansichten: Letzter Beitrag
  Fehler bei Zeitmessung Fox 15 154 24.05.2017 09:19
Letzter Beitrag: SkobyMobil
  Waveform auf Nextion Display GuaAck 6 280 12.04.2017 19:08
Letzter Beitrag: SkobyMobil
  neues OLED Display nötig an vorhandenem uC Systemswerlich Ersatz hd311 7 230 26.03.2017 11:16
Letzter Beitrag: hd311
  Pinbelegung TFT-Display ILI9341 mingo 19 672 23.03.2017 17:49
Letzter Beitrag: oOSpikeOo
  Display über I2-Bus betreiben mfri 22 935 23.01.2017 11:06
Letzter Beitrag: renid55
  Seltsamer Fehler bei Vergleichsoperation ardu_arne 14 475 22.01.2017 20:35
Letzter Beitrag: Binatone
  Fehler beim Hochladen steyr 24 1.182 16.12.2016 07:52
Letzter Beitrag: hotsystems
  Fehler in meinem Programm Franz54 7 380 01.12.2016 23:58
Letzter Beitrag: hotsystems
  matrix display elegoo uno R3 starter set lecker16 7 745 23.11.2016 21:14
Letzter Beitrag: Bitklopfer
  Fehler im Programmablauf binderj1 14 619 10.10.2016 10:29
Letzter Beitrag: StephanBuerger

Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste