INFO: Dieses Forum nutzt Cookies...
Cookies sind für den Betrieb des Forums unverzichtbar. Mit der Nutzung des Forums erklärst Du dich damit einverstanden, dass wir Cookies verwenden.

Es wird in jedem Fall ein Cookie gesetzt um diesen Hinweis nicht mehr zu erhalten. Desweiteren setzen wir Google Adsense und Google Analytics ein.

Antwort schreiben 
 
Themabewertung:
  • 0 Bewertungen - 0 im Durchschnitt
  • 1
  • 2
  • 3
  • 4
  • 5
Uno - hochladen scheitert
17.05.2015, 11:12
Beitrag #1
Uno - hochladen scheitert
Hallo liebe Arduino Gemeinde

Ich besitze einen Uno R2 und habe damit ein Problem.

Ich habe die Entwicklungsumgebung und den Treiber in der Version 1.6.4 auf einem Notebook unter Windows 7 so runtergeladen und installaiert, wie es auf der Arduino Homepage beschrieben war. Das hat auch alles funktioniert und auf dem Uno leuchtet die "on" LED, wenn er ans Notebook angeschlossen ist. Der Uno wird im Gerätemangager von Windows angezeigt, er ist im Boards Manager der Entwicklungsumgebung korrekt ausgewählt, ebenso wird dort die Schnittstelle Com3 angezeigt.

Das Problem ist nun, daß das Hochladen der Sketche nicht klappt. Ich habe es als erstes mit dem Blink Sketch aus den Beispielen unter "Basisc" versucht (mit einer LED zwischen PIN13 und GND). Das Kompilieren scheint noch zu klappen, dann aber bleibt beim Hochladen der Fortschrittsbalken ziemlich am Ende stehen und es geht nicht weiter. Dabei blinkt die T LED auf dem Uno. Auch nach einer halben Stunde passiert nichts - der Hochladevorgang wird weder abgeschlossen noch abgebrochen.

Ich habe alle Versuche unternommen, die mir einfielen:

- anderen USB Anschluß (mein Notebook hat zwei)
- anderes USB Kabel
- Neuinstallation des Treibers
- drücken der Reset Taste auf dem Uno sowie auch gedrückt halten für einige Sekunden
- anderen Sketch aus Beispiele - Basics
- Neustart des Notebooks

Alle diese Versuche haben zu keinem Ergebnis geführt - das Hochladen klappt nicht und der Fortschrittsbalken bleibt stehen. Der Uno weist augenscheinlich keine Beschädigungen auf.
Weiß jemand von euch, was das Problem ist und wie man es lösen kann? Der Umgang mit Mikrocontrollern ist für mich noch Neuland.
Vielen Dank für eure Hilfe.
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
17.05.2015, 13:52 (Dieser Beitrag wurde zuletzt bearbeitet: 17.05.2015 13:53 von rkuehle.)
Beitrag #2
RE: Uno - hochladen scheitert
Hallo wub,

ein paar Fragen:
Die IDE bringt bei Problemen auch immer Fehlermeldungen im unteren Fensterbereich.
Kannst du die mal bitte reinstellen?
Konntest du schon mal was auf den Arduino raufladen oder soll das der 1. Upload sein?
Ist das ein Original Arduino / wo hast du ihn her, Link ?
Grüße RK
PS: ISt auf deinem Notebook noch irgendeine Java-lastige Software installiert, die selbst auch eine JVM / JRE benutzt?

Nüchtern betrachtet...ist besoffen besser Big Grin
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
17.05.2015, 15:24 (Dieser Beitrag wurde zuletzt bearbeitet: 17.05.2015 18:22 von wub71.)
Beitrag #3
RE: Uno - hochladen scheitert
Hallo rkuehle,

ich habe es eben nochmal versucht. Es kommen beim Hochladen keine Fehlermeldungen, sondern nur einige Angaben bezüglich genutztem und verfügbarem Speicherplatz auf dem Controller. Der Fortschrittsbalken bleibt wie gehabt fast am Ende stehen.
Klicke ich dann erneut auf Hochladen, kommt die Fehlermeldung
avrdude: ser_open(): can't open device "\\.\COM3": Zugriff verweigert
Probleme beim Hochladen auf die Platinee.


Drücke ich dann die Reset Taste am Uno, kommt die Fehlermeldung:
avrdude: stk500_getsync() attempt 1 of 10: not in sync: resp=0x00
Diese Fehlermeldung kommt 10 mal hintereinander, von "1 of 10" bis "10 of 10".

Bisher konnte ich noch nichts auf meinen Uno hochladen, es soll das erste mal sein.
Es ist ein original Arduino, kein Nachbau. Ich habe ihn bei Ebay gekauft.
Hast du eine Idee, woran es liegt?

P.S. Java ist auf dem Notebook drauf. Ich weiß jetzt allerdings nicht mehr, im Rahmen welcher Software ich das installiert habe. XAMPP oder Open Office vielleicht.
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
17.05.2015, 15:49
Beitrag #4
RE: Uno - hochladen scheitert
Hallo:
Ich hatte mal das gleiche Problem.
Wenn irgend wo im Code ein "!" vorkam blieb der fortschritt Balken am Ende stehen
und es tat sich nichts mehr.
Den Code daraufhin überprüfen. Sonst fällt mir dazu nichts ein.
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
17.05.2015, 15:51
Beitrag #5
RE: Uno - hochladen scheitert
Unter dem Reiter Tools findet man den Button Ports. Dort sind angegeben, welche Ports zur Verfügung stehen. Schließt man nun den Uno an, kommt ein weiterer Port dazu. Dieses muss man dann auswählen. Bei mir war es "Com7". Danach hat es bei mir funktioniert.
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
17.05.2015, 21:21
Beitrag #6
RE: Uno - hochladen scheitert
Zitat:avrdude: ser_open(): can't open device "\\.\COM3": Zugriff verweigert
Probleme beim Hochladen auf die Platinee.
Das ist typisch für Windows wenn du zB. den Treiber für einen Mega bereits drin hast, dann aber einen Uno betanken möchtest.
Der Uno bekommt erstens einen anderen Port zugewiesen und zweitens fehlt halt noch der Treiber.
Am besten du steckst jeden Arduino-Typ einmal ran und machst über den Gerätemanager eine Treiberaktualisierung / - installation.
Danach musst du je nach angestecktem Arduino-Typ natürlich den richtigen Port zum betanken auswählen.
Ist halt lästig. Daher nutze ich lieber Linux.
Grüße Ricardo

Nüchtern betrachtet...ist besoffen besser Big Grin
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
24.05.2015, 16:25
Beitrag #7
RE: Uno - hochladen scheitert
(17.05.2015 21:21)rkuehle schrieb:  Daher nutze ich lieber Linux.
Grüße Ricardo

Hast du Erfahrung mit dem Arduino an einem Raspberry unter Raspbian? Falls ja, kommen die problemlos miteinander klar, bzw. auf was sollte man da achten?
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
24.05.2015, 17:05
Beitrag #8
RE: Uno - hochladen scheitert
(24.05.2015 16:25)wub71 schrieb:  ...
Hast du Erfahrung mit dem Arduino an einem Raspberry unter Raspbian? Falls ja, kommen die problemlos miteinander klar, bzw. auf was sollte man da achten?

Das habe ich erst neulich aus Spaß mal gemacht RasPi Modell 2, der mit 1GB RAM
Arduino IDE installiert mit
sudo apt-get install arduino
In der Arduino IDE erscheint dann unter den Tools unter Seriellem Port eben eine Linux typische Bezeichnung (müßte ich nachkucken wie die...*michausdemsofaschäleunddenRPistarte*)...siehe Screenshot
Das Ganze lief nach der Installation auf anhieb. Allerdings hatte ich keinen klassischen UNO dran sondern einen USB/Seriell Wandler mit einem FTDI Chip drin mit dem man dann typischerweise den Arduino Ethernet oder die Pro Minis bespassen tut.
lg
bk

   

1+1 = 10 Angel ...und ich bin hier nicht der Suchmaschinen-Ersatz Dodgy...nur mal so als genereller Tipp..
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
Antwort schreiben 


Möglicherweise verwandte Themen...
Thema: Verfasser Antworten: Ansichten: Letzter Beitrag
  Fehlermeldung beim hochladen opa michi 12 1.500 02.03.2016 17:32
Letzter Beitrag: hotsystems
  Sketch läßt sich nicht hochladen - not in sync Stephan_56 20 1.768 17.01.2016 23:00
Letzter Beitrag: Bitklopfer
  Fehlermeldung beim hochladen in den ESP8266 arduinofan 7 1.047 25.12.2015 17:32
Letzter Beitrag: amithlon
  Daten auf eigene Website hochladen Max32 3 771 08.03.2015 20:00
Letzter Beitrag: rkuehle
Bug UNO Serial.println("Hello World"); scheitert unter Ubuntu Uno-Fan 4 948 21.02.2015 13:17
Letzter Beitrag: Uno-Fan
  2.4"TFT LCD * Arduino MEGA 2560 problem beim Hochladen Rene S. 2 5.191 03.05.2014 15:55
Letzter Beitrag: Rene S.

Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste