INFO: Dieses Forum nutzt Cookies...
Cookies sind für den Betrieb des Forums unverzichtbar. Mit der Nutzung des Forums erklärst Du dich damit einverstanden, dass wir Cookies verwenden.

Es wird in jedem Fall ein Cookie gesetzt um diesen Hinweis nicht mehr zu erhalten. Desweiteren setzen wir Google Adsense und Google Analytics ein.

Antwort schreiben 
 
Themabewertung:
  • 0 Bewertungen - 0 im Durchschnitt
  • 1
  • 2
  • 3
  • 4
  • 5
USB-Gerät wird nicht erkannt
04.02.2015, 02:39
Beitrag #1
USB-Gerät wird nicht erkannt
Hallo,
ich bekomme keine Verbindung zu dem Arduino duemilanove! Ich betreibe ihn mit externer Spannungsversorgung, aber mit oder ohne aktiven USB-Hub bekomme ich partout keine Verbindung zu dem Gerät. Ich habe immer mal wieder den in der IDE enthaltenen Treiber nachinstalliert, aber es ist einfach nichts zu machen.
Stecke ich dagegen einen Arduino Uno an, gibt es keine Probleme, der wird erkannt und man kann ihn programmieren.
Ich benutze einen PC mit i3-Prozessor und Windows 7- pro.

Hat vielleicht jemand eine Idee, wie man den Arduino duemilanove wieder reaktivieren kann? Es läuft darauf ein Loggerprogramm und ich würde gern die Daten auslesen.

Vielen Dank schon mal!

Gruß
kpc
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
04.02.2015, 05:18
Beitrag #2
RE: USB-Gerät wird nicht erkannt
Hallo,

bei Win7 und Ärger mit USB-Geräten hilt oft, den Treiber mit USBDeview zu deinstallieren und anschließend den Treiber neu einzuspielen.

Gruß Rainer
Webseite des Benutzers besuchen Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
05.02.2015, 00:37
Beitrag #3
RE: USB-Gerät wird nicht erkannt
(04.02.2015 05:18)dqb312 schrieb:  Hallo,

bei Win7 und Ärger mit USB-Geräten hilt oft, den Treiber mit USBDeview zu deinstallieren und anschließend den Treiber neu einzuspielen.

Gruß Rainer

Funktioniert bestens mit Arduino Uno, den kann man mit USBDeview deinstallieren und, wenn man ihn wieder ansteckt, erscheint er als Communikationsport bzw. USB-serial-Gerät. Mit dem duemilanove geht überhaupt nichts, der wird nicht aufgelistet, erscheint nicht bei Installation mittels dpinst-x86.exe oder nach dem Anstecken, nichts geschieht.

Ich habe mir überlegt, mir einen neuen Arduino duemilanove zu beschaffen und wohl oder übel zu versuchen, die Anschlüsse an EEPROM, LCD und an alle Sensoren nachzubauen, damit ich das EEPROM auslesen und die Datenaufnahme fortsetzen kann.
Oder sollte ich einen Leonardo nehmen, dessen USB-Anschluß in dem Atmega integriert ist, vielleicht ist der nicht so kitzelig?

Gruß
kpc
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
05.02.2015, 00:56
Beitrag #4
RE: USB-Gerät wird nicht erkannt
Er hat!
Allerdings erinnere ich mich nicht an irgendwelches Update, das muß doch mit der IDE-Software geschehen? Also müßte ich ich mit einer älteren IDE-Version vielleicht wieder auf das Gerät zugreifen können?

Gruß
kpc
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
05.02.2015, 01:41
Beitrag #5
RE: USB-Gerät wird nicht erkannt
(05.02.2015 01:02)Zorg schrieb:  das Update ist über Windows gekommen - siehe Link zu Heise-Beitrag in dem von mir genannten Fred

falls doch kein FTDI-Problem (testweise): würde es nicht ausreichen den Prozessor auf ein neues Board zu setzen

Ich meinte nicht einen neuen Prozessor, sondern ein neues Board. Aber nach Lektüre der Beiträge frage ich mich, wie an ein Board ohne gefälschten FTDI-Chip kommen?

Zitat:erste Maßnahme:
1) Mit dem Programm "usbview" kann man sich die Eigenschaften des fehlerhaften FTDI-Chips anzeigen lassen. In meinem Fall war die PID auf 0000 zurückgestzt worden.

Original PID sollte 6001 sein

Das Problem mit USBDeview bei mir ist, daß das Duemilanove gar nicht auftaucht. Ich habe 51 Positionen, darunter ein Arduino uno mit PID 0043, aber ein duemilanove taucht nicht auf.

Gruß
kpc
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
05.02.2015, 14:17
Beitrag #6
RE: USB-Gerät wird nicht erkannt
Mißverständnis! Die Daten sind auf einem externen EEPROM, das per I2C angeschlossen ist. Der Austausch des kompletten Board wäre kein Problem (sofern ich die Anschlüsse fehlerfrei am neuen Board wiederherstelle).

Deshalb nochmals meine Frage: Soll ich ein Leonardo nehmen, wo der USB-Anschluß in den Atmega integriert ist und wo es daher keine Probleme mit gefälschten Chips geben sollte?


Ich bin dann erst mal weg!
Viele Grüße
kpc
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
07.02.2015, 14:52
Beitrag #7
RE: USB-Gerät wird nicht erkannt
Leider ist da noch ein Mißverständnis bzw. Fehler: bei dem fraglichen Gerät handelt es sich nicht um einen Arduino duemilanove, sondern um einen Iteaduino 2.2. Hatte ich leider verwechselt, scheint aber wohl auch mit dem gefälschten Chip aus China ausgerüstet zu sein, sofern es überhaupt daran liegt. Übrigens kommt wahrscheinlich der gesamte Iteaduino aus China.

Hat noch jemand eine Idee, wie man das Ding wieder ansprechbar machen kann - oder soll ich ihn doch durch Leonardo ersetzen?

VG
kpc
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
Antwort schreiben 


Möglicherweise verwandte Themen...
Thema: Verfasser Antworten: Ansichten: Letzter Beitrag
  "Arduino on Breadboard" startet neu wenn USB-Gerät am PC gesteckt wird da_user 11 259 08.04.2017 15:38
Letzter Beitrag: ardu_arne
  Arduino Uno R3, servos reagieren nicht auf die Befehle Crossedsticks 5 327 22.02.2017 22:42
Letzter Beitrag: Binatone
  4-fach Relaiskarte HL-54 zieht nicht richtig an. Kriskind 13 551 12.02.2017 23:51
Letzter Beitrag: Tommy56
  Arduino UNO Board wird heiß ardun 6 463 02.01.2017 10:44
Letzter Beitrag: ardun
  ws2812b + nodemcu Ich finde den Fehler nicht. Tha_Coralis 16 1.038 15.12.2016 18:37
Letzter Beitrag: Harry Hirsch
  USB-Gerät wird nicht erkannt kpc 4 560 13.12.2016 15:48
Letzter Beitrag: René Hitz
  Bluetooth-Steuerung mit elegoo uno funktioniert nicht Matthias_Arduino 0 460 01.11.2016 19:47
Letzter Beitrag: Matthias_Arduino
  Pin 5 an Pro Micro funktioniert nicht scritch 1 251 07.09.2016 13:54
Letzter Beitrag: ardu_arne
  Arduino UNO IC wird heiß fagus 1 389 31.08.2016 11:20
Letzter Beitrag: ardu_arne
  ESP8266-01 wird heiß ? cuteemo 5 638 20.08.2016 10:16
Letzter Beitrag: HDT

Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste