INFO: Dieses Forum nutzt Cookies...
Cookies sind für den Betrieb des Forums unverzichtbar. Mit der Nutzung des Forums erklärst Du dich damit einverstanden, dass wir Cookies verwenden.

Es wird in jedem Fall ein Cookie gesetzt um diesen Hinweis nicht mehr zu erhalten. Desweiteren setzen wir Google Adsense und Google Analytics ein.

Antwort schreiben 
 
Themabewertung:
  • 0 Bewertungen - 0 im Durchschnitt
  • 1
  • 2
  • 3
  • 4
  • 5
Treiber für Nano unter Win10
03.02.2020, 14:09
Beitrag #9
RE: Treiber für Nano unter Win10
(03.02.2020 13:38)hotsystems schrieb:  
(03.02.2020 13:18)ben schrieb:  Hallo Dieter,
die Anleitung zur Installation von Franzis hatte ich gelesen und befolgt: erfolglos. Darin steht auch, dass man den CH341SER.EXE installieren soll. Das habe ich durch Doppelklick versucht. Dann erscheint ein Fenster, in dem man auf "INSTALL" klicken kann. Erfolg: Fehlermeldung "Driver install failure!". Ich habe auch den USB 2.0 Anschluss benutzt, und ich habe die erforderlichen Administrator-Rechte.

Dann sieht es nach einem Problem deines Rechners aus.
Mein Tipp, evtl. vorhandenen Treiber deinstallieren und diesen dann neu installieren.
Hallo Dieter,
da das Hochladen mit einem Uno und einem Nano von Fa. Joy-it mit dem CH341SER.EXE klappt, verstehe ich nicht, wie mein PC das Problem sein kann und was es bringen sollte, einen mit Original-Uno und einem Nano von Joy-it (s.o.) funktionierenden Treiber zu deinstallieren und dann wieder zu installieren. Kann das wirklich etwas bringen?
Viele Grüße
ben
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
03.02.2020, 14:19
Beitrag #10
RE: Treiber für Nano unter Win10
Ein originaler UNO hat keinen CH340.

Gruß Tommy

"Wer den schnellen Erfolg sucht, sollte nicht programmieren, sondern Holz hacken." (Quelle unbekannt)
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
03.02.2020, 14:38 (Dieser Beitrag wurde zuletzt bearbeitet: 03.02.2020 14:40 von MicroBahner.)
Beitrag #11
RE: Treiber für Nano unter Win10
(03.02.2020 14:09)ben schrieb:  da das Hochladen mit einem Uno und einem Nano von Fa. Joy-it mit dem CH341SER.EXE klappt, verstehe ich nicht, wie mein PC das Problem sein kann
Warum schreibst Du dann, dass das Installieren des CH340 nicht geklappt hätte? Hast Du im Gerätemanager nachgeschaut, ob da was angezeigt wird, wenn Du deinen Nano ansteckst? Und wird ein CH340 COM-Device angezeigt, wenn Du deinen Joy-It ansteckst?

Gruß, Franz-Peter
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
04.02.2020, 19:17
Beitrag #12
RE: Treiber für Nano unter Win10
(03.02.2020 14:38)MicroBahner schrieb:  
(03.02.2020 14:09)ben schrieb:  da das Hochladen mit einem Uno und einem Nano von Fa. Joy-it mit dem CH341SER.EXE klappt, verstehe ich nicht, wie mein PC das Problem sein kann
Warum schreibst Du dann, dass das Installieren des CH340 nicht geklappt hätte? Hast Du im Gerätemanager nachgeschaut, ob da was angezeigt wird, wenn Du deinen Nano ansteckst? Und wird ein CH340 COM-Device angezeigt, wenn Du deinen Joy-It ansteckst?
Hallo Tommy, Dieter und Franz-Peter,
zunächst bedanke ich mich für Eure Hinweise und Tipps. Leider haben sie mich nicht weiter gebracht. Ich habe meine Versuche und Ergebnisse zusammengefasst:
Am 2.2.2020 getestet:
Stets kommt die Meldung: avrdude: stk500_recv(): programmer is not responding und avrdude: stk500_getsync() attempt 10 of 10: not in sync: resp=…
Die hex-Zahl in „resp=…“ ist zufällig (0x0a, 0x42, …), hängt NICHT ab vom Programmer-Typ.
Programmer = „AVR ISP“
Prozessor = „ATmega328P (Old Bootloader)“

Wenn ein COMn ungleich COM1 in der Arduino-DIE angezeigt wird, wird dieser COMn auch im Windows-Gerätemanager angezeigt und umgekehrt.

CH34x_Install_Windows_v3_4.EXE konnte NICHT installiert werden: Fenster mit Button „INSTALL“ erschien.
Select INF: „CH341SER.INF“, aber nach Button „INSTALL“ angeklickt Fehlermeldung „Driver install failure!“.

Auf einem Original-Nano-Board (gekauft bei Franzis) gibt es einen Chip mit ca. 26 Pins „FT232RL“.
Diverse Boards getestet:
joy-it NanoV3 (mit CH340G): COM4, Hochladen ok
Original Uno R3 SMD (mit ICSP): COM7, Hochladen ok
Original Uno (mit Plastik-Bodenplatte, mit ICSP): COM8, Hochladen ok
Original Uno R3 von Franzis (mit Plastik-Bodenplatte, mit ICSP): COM3, Hochladen ok
Original Nano (mit FT232RL) von Franzis: COM3, Hochladen ok

Original M-Zero Pro von Franzis: COM1, Fehler
Franzis-Micro 5V (mit CH340G, 16 Pins, ohne ISP): COM1, Fehler (Programmer Type: butterfly)
Franzis-Micro 5V (mit CH340G, 16 Pins, ohne ISP): COM1, Fehler (Programmer Type: butterfly)
Franzis-Micro 5V (mit CH340G, 16 Pins, ohne ISP): COM1, Fehler (Programmer Type: butterfly)
Original Micro von Franzis (mit ISP): COM1, Fehler (Programmer Type: butterfly)
Original Micro von Franzis (mit ISP): COM1, Fehler (Programmer Type: butterfly); Fehlermeldung:
Der ausgewählte serielle Port ist nicht vorhanden oder das Board ist nicht angeschlossen.
Original Due von Franzis: COM1; nicht im Boardverwalter der Arduino-IDE

Am 4.2.2020 getestet:
CH34x_Install_Windows_v3_4.EXE konnte installiert werden: Fenster mit Button „INSTALL“ erschien.
Select INF: „CH341SER.INF“ Nach Anklicken Meldung „installiert“.
Danach: Original Nano (mit FT232RL) von Franzis: COM3, aber Fehler „programmer is not responding etc.“ (vergl. oben: Hochladen hatte geklappt!).
Doppelklick auf CP210xVCPInstaller_x64.exe klappt: wurde installiert.

Zusammenfassend denke ich: Das Dreigestirn (Windows 10, Arduino Nano, USB-Treiber für Arduino Nano) kann nicht zusammenarbeiten, evtl. auch nur zwei von den dreien.
Folgerung für mich: Ich vergesse Arduino Nano, arbeite vorerst mit dem Uno und kaufe mir demnächst noch einige joy-it NanoV3.
Falls noch jemand eine neue Idee hat, werde ich die selbstverständlich gerne verfolgen. Ansonsten bedanke ich mich nochmal bei Tommy, Dieter und Franz-Peter und verabschiede mich enttäuscht von meinem Thema "Treiber für Nano unter Windows 10".
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
04.02.2020, 19:25 (Dieser Beitrag wurde zuletzt bearbeitet: 04.02.2020 19:26 von Tommy56.)
Beitrag #13
RE: Treiber für Nano unter Win10
Wenn der joy-it NanoV3 (mit CH340G): COM4 läuft, dann ist der CH340-Treiber ja ordnungsgemäß installiert.

In dem Fall (da Du beide Bootlader probiert hast) würde ich den Nano als defekt einstufen.
Schicke/bringe ihn als defekt zurück.

Gruß Tommy

"Wer den schnellen Erfolg sucht, sollte nicht programmieren, sondern Holz hacken." (Quelle unbekannt)
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
05.02.2020, 09:50
Beitrag #14
RE: Treiber für Nano unter Win10
(04.02.2020 19:17)ben schrieb:  .....
Original M-Zero Pro von Franzis: COM1, Fehler
.....

Das mit COM1 sehe ich mal als Fehler.
COM1 ist normalerweise die "echte" serielle Schnittstelle, die auf die RS232 des PC geht. Da kannst du über USB nicht flashen.
Der M-Zero Pro müsste dir da eigentlich eine andere COM zeigen.

Gruß Dieter

I2C = weniger ist mehr: weniger Kabel, mehr Probleme. Cool
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
05.02.2020, 12:47
Beitrag #15
RE: Treiber für Nano unter Win10
Da der Nano von joi-it mit CH340G läuft, ist auch der Treiber ordentlich installiert.
Alles von Franzis geht nicht - zurückschicken und diesen Hersteller in Zukunft meiden. Wenn deren Hardware genau so schlecht ist, wie die Software und die Bücher, wundert es mich nicht.

Gruß Tommy

"Wer den schnellen Erfolg sucht, sollte nicht programmieren, sondern Holz hacken." (Quelle unbekannt)
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
Antwort schreiben 


Möglicherweise verwandte Themen...
Thema: Verfasser Antworten: Ansichten: Letzter Beitrag
  S-BUS und Arduino Nano plu 2 97 25.03.2020 14:51
Letzter Beitrag: ingo46
  Bitte um Hilfe für ein Arduino Nano Andi-1090 14 509 08.03.2020 14:55
Letzter Beitrag: Andi-1090
  Probleme mit GPS-Modul an Nano DO3GE 3 232 26.02.2020 16:13
Letzter Beitrag: amithlon
  mp3 auf Arduino Nano speichern und abspielen Thor Wallhall 9 613 15.01.2020 22:04
Letzter Beitrag: Tommy56
  Schreiben von Arduino Nano auf SD Karte mit 80 Hertz Joshua_Gunjah 8 793 27.11.2019 18:43
Letzter Beitrag: Tommy56
Question Mega2560 / Nano mit nRF24L01 verbinden R_M 1 425 08.10.2019 18:47
Letzter Beitrag: Tommy56
Sad Sonderbares Verhalten von Relais Arduino Nano Sarkermann 7 653 20.09.2019 12:26
Letzter Beitrag: Bitklopfer
  IDE unter Linux xfce LM18 TKK-Arduino 15 1.445 14.07.2019 16:16
Letzter Beitrag: TKK-Arduino
  Gelöst ==> Arduino Nano, Kommunikation mit PC bringt nicht korrekten ASCII moehrle 4 1.193 02.03.2019 22:04
Letzter Beitrag: hotsystems
Tongue Türgriff unter Strom setzen :angel: invalidfake 1 738 25.02.2019 19:08
Letzter Beitrag: Tommy56

Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste