INFO: Dieses Forum nutzt Cookies...
Cookies sind für den Betrieb des Forums unverzichtbar. Mit der Nutzung des Forums erklärst Du dich damit einverstanden, dass wir Cookies verwenden.

Es wird in jedem Fall ein Cookie gesetzt um diesen Hinweis nicht mehr zu erhalten. Desweiteren setzen wir Google Adsense und Google Analytics ein.

Antwort schreiben 
 
Themabewertung:
  • 0 Bewertungen - 0 im Durchschnitt
  • 1
  • 2
  • 3
  • 4
  • 5
Softserial Probleme
22.02.2014, 19:41
Beitrag #1
Softserial Probleme
Hallo Leute,

ich bräuchte mal wieder eure Hilfe. Ich möchte von einem Arduino Pro mini via Softserial Daten auf ein anderes Gerät übersenden. Momentan ist es noch mit einem Kabel verbunden, später soll es über BT funktionieren. Ich habe den Sketch soweit, dass ich die Daten an das externe Gerät übersenden kann solange meine USB Programmieradapter gesteckt ist. Stecke ich aber meinen USB Programmieradapter ab, werden keine Daten mehr an das externe gerät gesendet. Das externe gerät habe ich an PIn 10 und Pin 11
Hat von euch einer eine Ahnung woran das liegen kann??

Gruß
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
22.02.2014, 20:26 (Dieser Beitrag wurde zuletzt bearbeitet: 22.02.2014 20:27 von rkuehle.)
Beitrag #2
RE: Softserial Probleme
Hallo Xtremefly,

der Thread erfordert (wieder mal) die Kristallkugel Confused
Der Code wäre schon hilfreichExclamation

Grüße RK

Nüchtern betrachtet...ist besoffen besser Big Grin
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
22.02.2014, 20:42
Beitrag #3
RE: Softserial Probleme
(22.02.2014 20:26)rkuehle schrieb:  Hallo Xtremefly,

der Thread erfordert (wieder mal) die Kristallkugel Confused
Der Code wäre schon hilfreichExclamation

Grüße RK

Ricardo, Du hast wahrscheinlich Recht, folgendes sollte jeder irgendwie vor dem Posten auf dem Schirm haben:
Kristallkugeln sind teuer - Wahrsagerei auch..daher...

Smile
Sloompie

Dimidium facti, qui coepit, habet: SAPERE AUDE, incipe!©Horaz

Vor allem sapere aude! oder wie Immanuel Kant sagt:
"Habe Mut, dich deines eigenen Verstandes zu bedienen!"

Es tut auch nicht weh! Daher: incipe! oder Tu es! wie Yoda sagen würde.
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
22.02.2014, 21:02 (Dieser Beitrag wurde zuletzt bearbeitet: 22.02.2014 21:53 von Xtremefly.)
Beitrag #4
RE: Softserial Probleme
Hallo,

ja klar hier mal der code, hätte ja sein können das einer von euch schonmal das gleiche Probleme hatte und es zufällig so weiß Wink


#include "config.h"
#include <SoftwareSerial.h>


int rxPin = 10;
int txPin = 11;
SoftwareSerial Bluetooth = SoftwareSerial(rxPin, txPin); // RX, TX
String Str_SendOut;

void setup() {

pinMode(rxPin, INPUT);
pinMode(txPin, OUTPUT);

Serial.begin(9600);
Bluetooth.begin(9600);

}




void loop() {


Str_SendOut=( "$C,720,150,28,,21,0,345");

Bluetooth.println(Str_SendOut);

if (Bluetooth.available())
Bluetooth.write(Bluetooth.read());



}

Ich habe das ganze gerade mit einem arduino uno getestet. dort funktioniert es, auch wenn der uno nicht am pc hängt. Kann es damit zusammen hängen, weil der arduino pro mini keine onboard umwandler von usb auf ttl umsetzet hat?? muss man hardwaretechnisch noch was am pro mini machen?? so sieht es momentan für mich aus.

Hab gerade das ganze mal so umprogrammiert, dass es über die normale Schnittstelle geht. Also dort wo ich den USB Adapter anschließe. Über diese Schnittstelle geht es nun. Warum es über die Softserial nicht geht, bleibt mir gerade noch ein Rätsel.
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
Antwort schreiben 


Möglicherweise verwandte Themen...
Thema: Verfasser Antworten: Ansichten: Letzter Beitrag
Big Grin Probleme mit pgm_read_word NoGi 9 1.168 23.04.2017 10:09
Letzter Beitrag: NoGi
  Probleme mit einem Sketch für einen LED Cube 5x5x5 Frank1234 5 333 13.03.2017 12:12
Letzter Beitrag: Tommy56
  Probleme bei Countdown ferdi 0 211 23.01.2017 10:45
Letzter Beitrag: ferdi
  ArduinoDroid Probleme Brother Tak 1 386 10.09.2016 22:12
Letzter Beitrag: Brother Tak
  Roboter-Bau Probleme blebbens 8 580 12.07.2016 07:35
Letzter Beitrag: Binatone
  Probleme mit sprintf() und dtostrf() GMBU 11 1.479 22.06.2016 10:52
Letzter Beitrag: GMBU
  Hardwareserial/Softserial: Problem mit Superklasse tuxedo0801 10 781 19.05.2016 12:25
Letzter Beitrag: amithlon
  Makeblock mit Scratch programmieren- Probleme Keinen Schimmer 6 1.934 06.05.2016 18:34
Letzter Beitrag: arduinopeter
  Programme vom UNO auf nano , mini Pro portieren Probleme anwo 19 1.662 17.04.2016 21:12
Letzter Beitrag: hotsystems
  Probleme beim Auslesen eines IR Empfängers linuxpaul 7 810 06.03.2016 14:44
Letzter Beitrag: hotsystems

Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste