INFO: Dieses Forum nutzt Cookies...
Cookies sind für den Betrieb des Forums unverzichtbar. Mit der Nutzung des Forums erklärst Du dich damit einverstanden, dass wir Cookies verwenden.

Es wird in jedem Fall ein Cookie gesetzt um diesen Hinweis nicht mehr zu erhalten. Desweiteren setzen wir Google Adsense und Google Analytics ein.

Antwort schreiben 
 
Themabewertung:
  • 0 Bewertungen - 0 im Durchschnitt
  • 1
  • 2
  • 3
  • 4
  • 5
Servo zu wenig Leistung
17.08.2015, 11:18
Beitrag #1
Servo zu wenig Leistung
Guten Morgen,
ich hab da ein kleines Problem mit meiner Schaltung Huh.

Mein folgendes Anliegen ist das ich einen kräftigen Servo mit meinen Arduino UNO betreiben möchte.
Da der Arduino aber die benötigte Spannung und den Strom nicht liefern kann wollte ich das ganze Extern betreiben.
Ich hab mir einen:
-LIPO Akku 4S (14,8Volt)
-YEP 20A BEC
gekauft.

Dann habe ich angefangen alles zu verdrahten und zu probieren,
und der Servo fuhr im Leerlauf auch recht gut.


.pdf  bec servo .pdf (Größe: 17,17 KB / Downloads: 105)

Da ich aber vorher die Kraft gemessen hab welche ich benötige (170Ncm) stellte ich
nach den Einbau ich die Mechanik schnell fest das der Servo viel zu schwach ist obwohl er das locker packen müsste (300Nm).

Hm, was nun?
Nach kurzer Überlegung fiel mir ein das ich in meinen alten Moped noch eine 6V 25W Glühbirne habe.
Nach meiner Rechnung 25W/6V= I->etwas über 4 A

Also hab ich den Servo wieder abgebaut und mir die Glühbirne über ein Multimeter an
den BEC verdrahtet.


.pdf  BEC Glühbirne .pdf (Größe: 17,73 KB / Downloads: 74)

Siehe da, anstatt etwas über 4 Ampere zieht das Leuchtmittel nur 2,4Ampere.
Also hat sich meine Vermutung bestätigt das der Servo nicht volle Leistung hat Dodgy.

Alle Bauteile sind keine Woche alt und wurden vorher noch nie verwendet und bei mir nur zu diesen Versuchsaufbau.

Habe ich einen Denkfehler oder ist da etwas Total im argen bei den Bauteilen ?

Danke für eure Hilfe,
mfg Martin
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
17.08.2015, 11:38
Beitrag #2
RE: Servo zu wenig Leistung
Hi,
kleine Anmerkung zu der Funzel.
Wenn du eine 6V Funzel an 5V betreibst dann zieht die logischerweise weniger Strom wie an 6V. Interessant ist an der Stelle wieviel Volt dein BEC Teil liefert wenn die Funzel angeschlossen ist. Und dann kannste ja mal den Test auf die Spitze treiben und mal für 2 Sekunden 2 6V Funzeln gleichzeitig ans BEC legen und dann schauen was die Spannung macht. Würde mal annehmen das ein gutes BEC das für paar Sekunden mitmacht. ...also schnell messen und Last wieder weg Blush
lgbk

1+1 = 10 Angel ...und ich bin hier nicht der Suchmaschinen-Ersatz Dodgy...nur mal so als genereller Tipp..
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
17.08.2015, 15:29 (Dieser Beitrag wurde zuletzt bearbeitet: 17.08.2015 15:30 von eddykett.)
Beitrag #3
RE: Servo zu wenig Leistung
Hi Bitklopfer,
das BEC macht je nachdem wie der Jumper gesteckt ist 5V, 5.5V, 6V, 7V oder 9V Ausgangsspannung.
Ich habe es in meinen Fall auf 6V eingestellt weil im Servo Datenblatt steht 300Ncm bei 6Volt, und 60 grad Drehung in 0.13sec bei 6 Volt.
Ich werde es nachher mal mit 2 Glühlampen probieren und mal beobachten was Strom und Spannung machen.
Das Ergebnis werde ich euch berichten.
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
17.08.2015, 15:37
Beitrag #4
RE: Servo zu wenig Leistung
(17.08.2015 11:18)eddykett schrieb:  Guten Morgen,
ich hab da ein kleines Problem mit meiner Schaltung Huh.

Mein folgendes Anliegen ist das ich einen kräftigen Servo mit meinen Arduino UNO betreiben möchte.
Da der Arduino aber die benötigte Spannung und den Strom nicht liefern kann wollte ich das ganze Extern betreiben.
Ich hab mir einen:
-LIPO Akku 4S (14,8Volt)
-YEP 20A BEC
gekauft.

Dann habe ich angefangen alles zu verdrahten und zu probieren,
und der Servo fuhr im Leerlauf auch recht gut.



Da ich aber vorher die Kraft gemessen hab welche ich benötige (170Ncm) stellte ich
nach den Einbau ich die Mechanik schnell fest das der Servo viel zu schwach ist obwohl er das locker packen müsste (300Nm).

Hm, was nun?
Nach kurzer Überlegung fiel mir ein das ich in meinen alten Moped noch eine 6V 25W Glühbirne habe.
Nach meiner Rechnung 25W/6V= I->etwas über 4 A

Also hab ich den Servo wieder abgebaut und mir die Glühbirne über ein Multimeter an
den BEC verdrahtet.



Siehe da, anstatt etwas über 4 Ampere zieht das Leuchtmittel nur 2,4Ampere.
Also hat sich meine Vermutung bestätigt das der Servo nicht volle Leistung hat Dodgy.

Alle Bauteile sind keine Woche alt und wurden vorher noch nie verwendet und bei mir nur zu diesen Versuchsaufbau.

Habe ich einen Denkfehler oder ist da etwas Total im argen bei den Bauteilen ?

Danke für eure Hilfe,
mfg Martin

ähm...hast du da bei der Schaltung mit dem Servo einen Fehler mit GND gemacht ?
FALLS der BEC Baustein eine Galvanische Trennung hat dann dürfte das so nicht funzen.... hier fehlt die Masseverbindung vom Servo zum Arduino.
Wenn der BEC eine durchgehende Masse hat dann ist eine weitere GND Leitung zum Servo auch doof weil dann hohe Ströme über die Arduino Masse laufen....HMMM...
Da wäre es fast angebracht den Arduino über einen DC/DC Wandler wo galvanisch trennt laufen zu lassen um der Masseschleife ein Schnippchen zu schlagen.
lgbk

1+1 = 10 Angel ...und ich bin hier nicht der Suchmaschinen-Ersatz Dodgy...nur mal so als genereller Tipp..
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
17.08.2015, 16:06
Beitrag #5
RE: Servo zu wenig Leistung
Code:
Nach kurzer Überlegung fiel mir ein das ich in meinen alten Moped noch eine 6V 25W Glühbirne habe.
Nach meiner Rechnung 25W/6V= I->etwas über 4 A

Bedenke das der Einschaltstrom solch einer Glühlampe ca. das 7-8 fach ist.
Auch die Einschaltzeit ist nicht zu vernachlässigen,was bei den Versuchen zu berücksichtigen ist.

Nicht jeder Neuling in einem Forum hat keine Ahnung über die Materie!
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
17.08.2015, 23:32
Beitrag #6
RE: Servo zu wenig Leistung
Hi,
danke für den Vorschlag mit der Masseleitung @ Bitklopfer.
So wie es jetzt gerade ist läuft es ja auch gut und es macht auch genau das was es machen soll(auch die Winkel stimmen).
Also denke ich nicht das es Galvanisch getrennt ist das BEC.
Nur wenn ich an den Servo 10 Kg Masse an einen Servoflügel hänge bei einen Abstand von 17mm zur Servowellenmitte (->170 N) hat er nicht mehr die Kraft das zu bewältigen obwohl der Hersteller 300Ncm angibt.
Und ich denke auch nicht das Savöx bei einen Servo im Preissegment von fast 100€ solche angaben machen würde wenn sie es nicht halten könnten.

Da dachte ich halt an sie Spannungsversorgung das die zu wenig leistet.
Also habe ich das provisorisch mir einer Glühbirne probiert und meine Vermutung hat sich ja bestätigt weil die Glühbirne
ja warum auch immer nur 2,4A gezogen hat obwohl sie rechnerisch über 4A ziehen müsste bei 6V oder?.
Der BEC ist angegeben mit 10A Dauerstrom und 20A Piek also sollte er es ja locker machen.
Das ist ja das Phänomen was ich mir nicht erklären kann.
Das schlimme ist das es schon der 2te BEC ist mit den ich es probiere und es nicht funktioniert .

Über den Einschaltstrom habe ich mir noch gar keine Gedanken gemacht @ fraju :-(.
Ich könnte maximal versuchen die Glühbirne vorher etwas mit einen Heißluftfön zu erwärmen damit sich der Widerstand schon etwas ändert und nicht ganz so ein hoher Einschaltstrom zustande kommt oder ?
Ich kann nur sagen das die Glühbirne gleich anging und dauerhaft 2,4A(5min) zog, was denke ich nicht richtig ist.
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
18.08.2015, 05:45
Beitrag #7
RE: Servo zu wenig Leistung
Moin
@eddykett , ähm du könntest mal was über die Spannungen am Servo erzählen...Strom alleine ist nicht alles. Zudem bringt jede Strommessung einen Spannungsabfall mit sich der sich je nach Messgerät auch noch unterscheidet - auch ein Messgerät hat da einen Widerstand in sich verbaut. Wenn mal annimmt das als Shunt 0,1 Ohm verbaut sind dann sind das bei 4A schon mal 0,4V wo dem Servo fehlen um seine Kraft zu entfalten.

Wie war das nun mit der Masseleitung, hat die eine Änderung im Verhalten gebracht ?
Hast du mal am BEC die Masseleitungen Eingang/Ausgang durchgeohmt ?
lgbk

1+1 = 10 Angel ...und ich bin hier nicht der Suchmaschinen-Ersatz Dodgy...nur mal so als genereller Tipp..
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
23.08.2015, 09:54
Beitrag #8
RE: Servo zu wenig Leistung
Guten Morgen,
ich messe den Strom mit einen Fluke 117 Digital Multimeter.
Bis jetzt war ich wirklich sehr zufrieden mit den Messgerät und es hat zuverlässig gearbeitet.
Ich hab damit auch die Spannung gemessen unter Last und die bricht laut dem Fluke von 6,01...V
auf 6,00..V zusammen also denke ich das dass Io ist.
Die Masseleitungen sind nur an der Batterie zusammen verbunden und es läuft wirklich gut bis auf das meines Erachtens
nen bissel Leistung fehlt (ca 40%) und ich der Meinung bin das der Servo nicht 180 Grad fährt sonder nur 120 Grad :-( .
Das macht der servo aber auch wenn ich ihn direkt von Arduino UNO betreibe

Langsam verzweifele ich daran weil ich extra den Servo auf genommen hab und eigentlich noch 50% reserve haben sollte .
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
Antwort schreiben 


Möglicherweise verwandte Themen...
Thema: Verfasser Antworten: Ansichten: Letzter Beitrag
  Shild-Wahl für Servo-Steuerung SkyFox 9 1.120 23.07.2015 12:49
Letzter Beitrag: SkyFox
  Wieviel Leistung verträgt der Transistor Tip 120 Das Auge 3 998 16.03.2015 23:40
Letzter Beitrag: Foto-Ralf
  Servo spring zw. SOLL-Position und 180° hin und her Aznagro 6 881 11.02.2015 10:24
Letzter Beitrag: Thorsten Pferdekämper
  Arduino wie LCD, Keypad und Servo anschließen AlexGPS 30 6.300 04.10.2014 19:57
Letzter Beitrag: Thorsten Pferdekämper
  Arduino & ext. Spannung steuert Servo torsten_156 4 1.853 27.09.2014 22:55
Letzter Beitrag: Bitklopfer
  TV mit Servo drehen knightrider 0 723 07.04.2014 12:26
Letzter Beitrag: knightrider

Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste