INFO: Dieses Forum nutzt Cookies...
Cookies sind für den Betrieb des Forums unverzichtbar. Mit der Nutzung des Forums erklärst Du dich damit einverstanden, dass wir Cookies verwenden.

Es wird in jedem Fall ein Cookie gesetzt um diesen Hinweis nicht mehr zu erhalten. Desweiteren setzen wir Google Adsense und Google Analytics ein.

Antwort schreiben 
 
Themabewertung:
  • 0 Bewertungen - 0 im Durchschnitt
  • 1
  • 2
  • 3
  • 4
  • 5
Serielle Verbindung + Relaiskarte = Problem
15.07.2013, 16:30
Beitrag #1
Serielle Verbindung + Relaiskarte = Problem
Guten Tag, ich habe folgendes Problem:
Ich habe den Arduino mit einem alten Netbook verbunden und an eine Relaiskarte mit 2 Relais angeschlossen.
Mit den Relais Soll später mal ein Pc gestartet werden ( Ein Relais zwischen Netzteil und ein Anderes, das den vorderen aus bzw an schalter Ersätzt ).
Das Programm reagiert auf ein "P" welches die Stromversorgung anschaltet, kurz danach einmal den Anschalter drückt und ein "O", welches den auschalter drückt, dannn 3 minuten zeit gibt zum herunterfahren und dann die stromversorgung ausschaltet.

So weit Funktioniert Alles auch wunderbar, aber nur solange man die Serielle Kommunikation permanent aufrecht erhält. Sobald man also das terminal Schließt, Schalten sich Beide Relais aus, Obwohl eigentlich das für die Stromversorgung an bleiben sollte..

Code:
int incomingByte;
int state;

void setup() {
  Serial.begin(9600);
  pinMode(7, OUTPUT);
  pinMode(8, OUTPUT);
  state = LOW;
}

void loop() {
// if (Serial.available() > 0) {  
    incomingByte = Serial.read();
    
    if (incomingByte == 'P') {
      digitalWrite(7, HIGH);
      delay(1200);
      digitalWrite(8, HIGH);
      delay(500);
      digitalWrite(8, LOW);
      Serial.println("System starting");
      state = HIGH;
    }
    else if (incomingByte == 'O') {
      digitalWrite(8, HIGH);
      delay(500);
      digitalWrite(8, LOW);
      Serial.println("Shutting down ...");
      delay(180000);
      digitalWrite(7, LOW);
      Serial.println("Shut down");
      state = LOW;
    }
    else {
      digitalWrite(7, state);
    }
// }
// else {
//   digitalWrite(7, state);
// }
}
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
19.07.2013, 19:57 (Dieser Beitrag wurde zuletzt bearbeitet: 19.07.2013 20:05 von Bitklopfer.)
Beitrag #2
RE: Serielle Verbindung + Relaiskarte = Problem
(15.07.2013 16:30)little_olli schrieb:  Guten Tag, ich habe folgendes Problem:
Ich habe den Arduino mit einem alten Netbook verbunden und an eine Relaiskarte mit 2 Relais angeschlossen.
Mit den Relais Soll später mal ein Pc gestartet werden ( Ein Relais zwischen Netzteil und ein Anderes, das den vorderen aus bzw an schalter Ersätzt ).
Das Programm reagiert auf ein "P" welches die Stromversorgung anschaltet, kurz danach einmal den Anschalter drückt und ein "O", welches den auschalter drückt, dannn 3 minuten zeit gibt zum herunterfahren und dann die stromversorgung ausschaltet.

So weit Funktioniert Alles auch wunderbar, aber nur solange man die Serielle Kommunikation permanent aufrecht erhält. Sobald man also das terminal Schließt, Schalten sich Beide Relais aus, Obwohl eigentlich das für die Stromversorgung an bleiben sollte..

Code:
......
    else {
      digitalWrite(7, state);
    }
// }
// else {
//   digitalWrite(7, state);
// }
}

Hallo,
also ich habe das mal auf meinem Ardi-Ethernet nachvollzogen, die LED eben ein und ausgeschaltet.
Also wenn ich die USB-Serielle Kommunikation in der Ardi-IDE zumache dann bleibt die LED an. ABER, wenn man das Terminalfenster wieder aufmacht wird der Arduino zurückgesetzt und die LED geht wieder aus. Das Problem kannst nicht so einfach lösen. Außer der Verwendung von Bistabilen Relais zumindest für die Powerleitung fällt mir da gerade nichts ein um den Reset zu überbrücken.
Schau dir doch dieses Relais mal an, das habe ich auch schonmal eingesetzt:
http://www.conrad.de/ce/de/product/507759

Ja, von deinem Code habe ich das mit dem "else" wieder gepostet....ähm den Teil braucht man eigentlich nicht....hatte ich zum Test komplett auskommentiert.

Gruß
bk

1+1 = 10 Angel ...und ich bin hier nicht der Suchmaschinen-Ersatz Dodgy...nur mal so als genereller Tipp..
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
22.07.2013, 17:49
Beitrag #3
RE: Serielle Verbindung + Relaiskarte = Problem
Versuche doch einfach einmal einen 120 Ohm Widerstand zwischen Reset und Vcc an deinem Arduino zu stecken, dann sollte das Reset Problem gelöst sein.

l.G. Jürgen

Verzeihe Deinen Feinden, aber vergesse nie Ihren Namen.....
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
Antwort schreiben 


Möglicherweise verwandte Themen...
Thema: Verfasser Antworten: Ansichten: Letzter Beitrag
  Problem mit LSM 303 Snörb 0 72 19.08.2017 16:51
Letzter Beitrag: Snörb
  Problem mit externem Interrupt manfred474 13 573 13.08.2017 08:54
Letzter Beitrag: MicroBahner
  Problem mit Klassen GuaAck 4 231 09.08.2017 09:28
Letzter Beitrag: MicroBahner
Question Problem mit TFT Sam217 8 557 20.07.2017 21:51
Letzter Beitrag: hotsystems
  Problem FastLED fliege_m 3 343 16.07.2017 16:56
Letzter Beitrag: Tommy56
  Fragen :serielle eingabe und Externe Interrupts Treeshort 7 357 02.06.2017 16:52
Letzter Beitrag: MicroBahner
  2 Arduinos Serielle Übertragung mit SPI RFID Kit OE5AMP 18 833 05.05.2017 20:46
Letzter Beitrag: OE5AMP
Question Problem beim Hochladen auf AtTiny45. Hilfe -.- Jonas Lindenblatt 17 1.120 16.04.2017 12:58
Letzter Beitrag: Jonas Lindenblatt
  Smart Home Webserver Basic Authentication Problem Osotastic 21 1.008 20.02.2017 18:00
Letzter Beitrag: Tommy56
  Problem mit Sketch senden an Uno feuerwehr 5 811 31.01.2017 20:41
Letzter Beitrag: Tommy56

Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste