INFO: Dieses Forum nutzt Cookies...
Cookies sind für den Betrieb des Forums unverzichtbar. Mit der Nutzung des Forums erklärst Du dich damit einverstanden, dass wir Cookies verwenden.

Es wird in jedem Fall ein Cookie gesetzt um diesen Hinweis nicht mehr zu erhalten. Desweiteren setzen wir Google Adsense und Google Analytics ein.

Antwort schreiben 
 
Themabewertung:
  • 0 Bewertungen - 0 im Durchschnitt
  • 1
  • 2
  • 3
  • 4
  • 5
Serielle Ports
06.09.2016, 17:48
Beitrag #1
Serielle Ports
Hallo zusammen
Habe folgendes Problem:
Ich kann bei meinen Arduino's (Uno, Leonardo, promicro) keine seriellen Ports auswählen
Kann bei der Port-Auswahl nur folgende 2 Ports auswählen:
/dec/cu.usbmodemFA121
und
der Bluetooth incoming Port
Ich brächte aber serielle Ports nur schon für Processing
Paar zusatzinfos: habe die neuste Arduino Software installiert auf einem Mac mit El Capitan
Hoffe das mir jemand hier helfen kann, bin schon xStunden im I-Net und finde keine Lösung des Problems
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
07.09.2016, 17:13
Beitrag #2
RE: Serielle Ports
Hast du evtl., keine passenden Treiber installiert.
Was für ein OS verwendest du, ein Linux ?
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
07.09.2016, 17:46
Beitrag #3
RE: Serielle Ports
(07.09.2016 17:13)Mathias schrieb:  Hast du evtl., keine passenden Treiber installiert.
Was für ein OS verwendest du, ein Linux ?

Wo finde ich den evt. passende Treiber?
Verwende normales Mac OSx keinLinux
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
09.09.2016, 19:08
Beitrag #4
RE: Serielle Ports
Echt niemand?Huh
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
10.09.2016, 09:42
Beitrag #5
RE: Serielle Ports
Hallo mittlig1977,

was möchtest du denn erreichen? Geht es dir nur um die Verbindung vom Mac / Arduino IDE zum Arduino?
Welches Gerät ist denn bei dir "/dec/cu.usbmodemFA121"?

Um den passenden Treiber zu finden, müsstest du wissen welcher "USB-Chip" auf deinen Arduinos verbaut ist.
Der Leonardo nutzt den ATmega32u4 für die USB Kommunikation und sollte ohne Treiberinstallation funktionieren.
Die Arduinos, die den Atmega16U2 für die USB Kommunikation verwenden, müssten auch ohne Treiberinstallation funktionieren.

Falls es einer mit einem CH340-Chip ist, musst du die Suchmaschine deiner Wahl zur Suche nach Treibern bemühen.

Wenn du Arduinos am Mac problemlos verwenden willst, achte beim Kauf auf den Atmega als "USB Kommunikations Chip". Sonst musst du immer passende Treiber suchen.

MfG Wolf
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
10.09.2016, 13:44
Beitrag #6
RE: Serielle Ports
Hi Werwolfi
Die Verbindung läuft bei allen Board's problemlos
Bei der Port Auswahl steht immer "/dec/cu.usbmodemFA121" und dann in Klammern das entsprechende Board das ich ausgewählt bzw angeschlossen habe z.b. beim Leonardo schaut das so aus: "/dec/cu.usbmodemFA121(Leonardo)"
Wie gesagt brauche ich serielle Ports für Processing. Ich habe das Processing Programm heruntergeladen und den entsprechenden Sketch geschrieben aber bei der Auswahl des seriellen Ports zeigt mir Processing nur den Bluetooth incoming Port an und über den kann ich nicht "kommunizieren"
Hoffe du verstehst jetzt mein Problem besser.
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
10.09.2016, 19:38
Beitrag #7
RE: Serielle Ports
Wenn Du die IDE schließt (damit der Port frei gegeben wird) , solltest Du den gleichen Port auch für Prozessing benutzen können.
Zumindest bei Win 7 funktioniert das.

Wenn Du einen anderen seriallen Port benutzen willst, musst Du diesen erst an den MAC anschließen.

Gruß Tommy
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
11.09.2016, 06:41
Beitrag #8
RE: Serielle Ports
Hallo mittlig1977,

ja, jetzt versteh ich dein Problem.
Es ist auf dem Mac auch so, wie Tommy es für Windows beschrieben hat.

Es dürfen entweder Processing oder die Arduino IDE auf den Port zugreifen, niemals beide gleichzeitig.
Bei mir zeigt er zwar den belegten Port in Processing an, aber sobald ich diesen öffne friert das Programm ein.

Gewöhn dir am besten an, die Arduino IDE gleich nach dem Upload des Sketches zu beenden und starte dann erst Processing.

MfG Wolf
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
Antwort schreiben 


Möglicherweise verwandte Themen...
Thema: Verfasser Antworten: Ansichten: Letzter Beitrag
  Anfänger braucht Hilfe: Serielle Daten auswerten und weiterverarbeiten Phreak2010 2 1.237 14.06.2015 18:34
Letzter Beitrag: Home38
  Serielle Kommunikation mit Mediaplayer tonioseiler 3 633 14.04.2015 11:31
Letzter Beitrag: Gelegenheitsbastler
  Mosfets über PWM nicht an allen Arduino Ports? lolufail 2 1.368 24.03.2014 14:36
Letzter Beitrag: lolufail
  USB-Serielle adapter für Arduino Mini Xtremefly 3 1.816 23.01.2014 12:33
Letzter Beitrag: burgi650
  Serielle Schnittstelle / Schnittstellen... Info´s? Schpiza 4 2.943 14.01.2014 19:05
Letzter Beitrag: Schpiza

Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste