INFO: Dieses Forum nutzt Cookies...
Cookies sind für den Betrieb des Forums unverzichtbar. Mit der Nutzung des Forums erklärst Du dich damit einverstanden, dass wir Cookies verwenden.

Es wird in jedem Fall ein Cookie gesetzt um diesen Hinweis nicht mehr zu erhalten. Desweiteren setzen wir Google Adsense und Google Analytics ein.

Antwort schreiben 
 
Themabewertung:
  • 0 Bewertungen - 0 im Durchschnitt
  • 1
  • 2
  • 3
  • 4
  • 5
SD-Karte schreiben mit Mega2560 und CTE70-Display
17.11.2015, 11:14
Beitrag #9
RE: SD-Karte schreiben mit Mega2560 und CTE70-Display
Hi,
anscheinend nicht. Ich wuerde Dir empfehlen, mal alles zu entfernen (Hardware und Software), was nichts mit der SD-Karte zu tun hat. Je nachdem, ob es dann geht oder nicht kann man weiterforschen.
Gruss,
Thorsten

Falls ich mit einer Antwort helfen konnte, wuerde ich mich freuen, ein paar Fotos oder auch ein kleines Filmchen des zugehoerigen Projekts zu sehen.
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
17.11.2015, 11:45
Beitrag #10
RE: SD-Karte schreiben mit Mega2560 und CTE70-Display
Das habe ich auch schon gemacht. Das Display entfernt und die SD direkt auf dem Adapter-Slot betrieben. Den Code soweit wie möglich eingekürzt. Immer noch das gleiche.
Ich vermute, dass die Ware evtl. nicht zum beschreiben einer SD-Karte gebaut wurde (fehlende Ansteuerung/Pins oder ähnliches), sondern nur zum lesen. Kann das jemand bestätigen?

Andererseits muss ich fürs lesen die Datei erstmal öffnen, was auch nicht funktioniert. Also fällt das wahrscheinlich auch weg.
Oder muss die CSV-Datei irgendwie speziell erstellt werden (FAT16/32 habe ich schon probiert) bzw. frisst der Arduino nur bevorzugte Karten?
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
17.11.2015, 14:09
Beitrag #11
RE: SD-Karte schreiben mit Mega2560 und CTE70-Display
Hi,
eigentlich gibt es hardwaremaessig gar nicht so viele Voraussetzungen. Zeig doch mal Deinen Minimal-Code.
Gruss,
Thorsten

Falls ich mit einer Antwort helfen konnte, wuerde ich mich freuen, ein paar Fotos oder auch ein kleines Filmchen des zugehoerigen Projekts zu sehen.
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
18.11.2015, 15:18
Beitrag #12
RE: SD-Karte schreiben mit Mega2560 und CTE70-Display
Ich weiß nicht, ob du die gleiche Hardware hast wie ich.
Aber wenn dein Display einen Kartenslot hat, dann nehm den mal. Da hat es bei mir dran gelegen, der Slot auf dem Adapter ging nicht.
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
29.11.2015, 11:57
Beitrag #13
RE: SD-Karte schreiben mit Mega2560 und CTE70-Display
Jetzt funktioniert es - auch mit dem Slot auf dem Adapter-Shield. Ich habe einfach als Beispielcoden den Datenlogger draufgeladen und promt geht es. Jetzt muss ich mal sukzessive den originale Code auseinander nehmen und dann mal testen. Ich vermute, dass sich Codeschnipsel aus verschiedenen Beispielen irgendwo beißen.
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
Antwort schreiben 


Möglicherweise verwandte Themen...
Thema: Verfasser Antworten: Ansichten: Letzter Beitrag
  matrix display elegoo uno R3 starter set lecker16 7 146 23.11.2016 21:14
Letzter Beitrag: Bitklopfer
  Data Logger Daten auf SD Card schreiben Crichton 12 301 22.11.2016 18:32
Letzter Beitrag: Crichton
  Se(h)Karte mit LED beleuchten manfredo 29 638 19.11.2016 16:29
Letzter Beitrag: Tommy56
  SD Karte wird nicht erkannt... Maxi290997 2 204 16.08.2016 14:36
Letzter Beitrag: Maxi290997
  Serial Monitor ASCII 1 schreiben BennIY 11 580 01.08.2016 16:42
Letzter Beitrag: Mathias
  Hilfe: Mega2560 - ENC 28J60 - MYSQL Gandalf 1 181 28.07.2016 16:30
Letzter Beitrag: Gandalf
  LCD Display plötzlich komische Zeichen Jessi97 2 243 28.07.2016 11:34
Letzter Beitrag: Bitklopfer
  Altes Digitales Display mit Text/Bits durch Genuino Micro versorgen - SPI-Bibliothek? RollingStone 0 202 25.06.2016 17:46
Letzter Beitrag: RollingStone
  Arduino MEGA2560 Timer PWM Einsteiger94 3 661 04.04.2016 10:38
Letzter Beitrag: RMR
  Problem mit OLED 0.96" Display torsten_156 3 541 03.04.2016 15:10
Letzter Beitrag: hotsystems

Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste