INFO: Dieses Forum nutzt Cookies...
Cookies sind für den Betrieb des Forums unverzichtbar. Mit der Nutzung des Forums erklärst Du dich damit einverstanden, dass wir Cookies verwenden.

Es wird in jedem Fall ein Cookie gesetzt um diesen Hinweis nicht mehr zu erhalten. Desweiteren setzen wir Google Adsense und Google Analytics ein.

Antwort schreiben 
 
Themabewertung:
  • 0 Bewertungen - 0 im Durchschnitt
  • 1
  • 2
  • 3
  • 4
  • 5
SD-Karte nicht ansprechbar....
31.07.2015, 12:54 (Dieser Beitrag wurde zuletzt bearbeitet: 31.07.2015 12:54 von alpenpower.)
Beitrag #1
SD-Karte nicht ansprechbar....
Hallo,

nun muss ich mich bzgl. meines Projektes um die Speicherung der anfallenden Daten auf SD-Karte kümmern.
Meine momentane Hardware sieht so aus:
1x Mega2560+TFT-Shield mit SD-Kartenslot + 5" TFT von coldtears mit ebenfalls SD-Kartenslot.

Zum Ansprechen der Karte verwende ich die Library SD, welche mit der IDE installiert wird.
Bei beiden Slots kommt immer die Meldung, dass die Karte nicht vorhanden sei.
Bevor ich mir nun einen Wolf suche, meine Frage an Euch, was hier falsch ist.

Diesen Pin
Code:
// change this to match your SD shield or module;
// Arduino Ethernet shield: pin 4
// Adafruit SD shields and modules: pin 10
// Sparkfun SD shield: pin 8
const int chipSelect = 53;
habe ich auf 53 gestellt.
Die Karte sollte auf FAT16 stehen und hat 2GB.

Das gleiche Problem hatte ich schon von Beginn an, als ich mir so ein Bundle mit Mega+3,2"TFT gekauft hatte. Damals war aber ein Layoutfehler auf dem TFT-Shield, welches ich hier sowieso nicht benutze. Irgendwann wechselte ich dann auf ein 5" TFT mit Font-IC.

Hat irgend jemand mit der Standard 'SD-Library' schon mal eine SD-Karte, welche typischerweise im Display steckt, in Betrieb?
Oder muss ich eine andere Lib verwenden?
Ich schliesse mal einen Hardwarefehler aus und vermute einen Fehler in der Einstellung oder einer falschen Lib.

Gruß Franz


Angehängte Datei(en) Thumbnail(s)
   
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
31.07.2015, 13:43 (Dieser Beitrag wurde zuletzt bearbeitet: 31.07.2015 13:44 von HaWe.)
Beitrag #2
RE: SD-Karte nicht ansprechbar....
hallo,
ich nutze sowohl SD slots auf eigenen Backpanes als auch die von TFT Displays problemlos mit den Standard-Libs, allerdings ist zu beachten, dass nicht alle (!) TFT-SPI- Displays gleichzeitig auf dem SPI Bus mitlaufen.
SD läuft aber immer auf Hardware-SPI einwandfrei mit den Standard-Libs:
http://www.mindstormsforum.de/viewtopic....491#p66429

dieses TFT musste ich getrennt per Software-SPI auf getrennten GPIOs konfigurieren:
http://www.mindstormsforum.de/viewtopic....491#p66123

und dieses hier habe ich ganz neu, da weiß ich es noch nicht sicher:
http://www.mindstormsforum.de/viewtopic....491#p66189
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
Antwort schreiben 


Möglicherweise verwandte Themen...
Thema: Verfasser Antworten: Ansichten: Letzter Beitrag
  LCD geht nicht - keine Ahnung warum?? DL1AKP 12 341 15.05.2017 13:17
Letzter Beitrag: DL1AKP
  433mHz Funkmodule senden/empfangen nicht metzgefa 2 349 06.05.2017 13:30
Letzter Beitrag: metzgefa
  Se(h)karte II manfredo 14 621 27.04.2017 15:10
Letzter Beitrag: manfredo
  SD Karte wird nicht erkannt Maxi290997 6 241 31.03.2017 06:05
Letzter Beitrag: Bitklopfer
Sad Sketch funktioniert auf dem Mega 2560 nicht Frank1234 16 643 26.03.2017 14:15
Letzter Beitrag: oOSpikeOo
  Mein Skript macht nicht das was es soll ;( DerMatze79 4 296 16.03.2017 22:19
Letzter Beitrag: MicroBahner
  Programmablauf macht nicht das was ich möchte !! ESP + Blynk b3ta 3 229 01.03.2017 14:29
Letzter Beitrag: Tommy56
Rainbow File geht nicht zum compilieren!!!! Jocky 7 338 19.02.2017 20:01
Letzter Beitrag: Binatone
  IRremote bringe ich nicht zum laufen Franz54 5 270 19.02.2017 11:56
Letzter Beitrag: Tommy56
  Code aus 1.6.9 geht mit 1.8.1 nicht mehr zu kompilieren DL1AKP 7 491 02.02.2017 12:16
Letzter Beitrag: Tommy56

Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste