INFO: Dieses Forum nutzt Cookies...
Cookies sind für den Betrieb des Forums unverzichtbar. Mit der Nutzung des Forums erklärst Du dich damit einverstanden, dass wir Cookies verwenden.

Es wird in jedem Fall ein Cookie gesetzt um diesen Hinweis nicht mehr zu erhalten. Desweiteren setzen wir Google Adsense und Google Analytics ein.

Antwort schreiben 
 
Themabewertung:
  • 0 Bewertungen - 0 im Durchschnitt
  • 1
  • 2
  • 3
  • 4
  • 5
Relais und Led
27.03.2015, 20:28
Beitrag #1
Relais und Led
Bitte mal nachsehen.
Hallo Gemeinde,
habe da einen Sketch welcher mit Leds einwandfrei läuft.
Wenn ich aber led1, led2 und muk mit einem Relais betreiben möchte, macht jeder Pin was er will.
Sobald Relais muk aktiviert wird ziehen auch Relais led1 und led2 an - gleichzeitig.
Weshalb Huh

Wäre schön könnte der Fehler gefunden werden.
Gruß
Gerd


Dies ist nur ein Teilsketch

int led1 = 5;
int led2 = 7;
int muk = 9;
void setup()
{

pinMode (led1, OUTPUT);
pinMode (led2, OUTPUT);
pinMode (muk, OUTPUT);
}
void loop ()
{
digitalWrite (muk, HIGH);
delay(2000);
digitalWrite (led1, HIGH);
delay(2990);
digitalWrite (led2, HIGH);
delay(2000);
digitalWrite (led2, LOW);
delay(2000);
digitalWrite (led1, LOW);
delay(2000);
digitalWrite (muk, LOW);
delay(3000);
}

Smile Schön dabei zu sein Smile
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
27.03.2015, 21:30
Beitrag #2
RE: Relais und Led
....Hi Berg..,
ist doch ganz einfach...die Spulen der Relais erzeugen induktive Spannungen und die schlagen auf den Rest der Schaltung durch.
Abhilfe ist erst mal eine Freilaufdiode parallel zu den Spulen. Dann kann man die Plus Versorgung der Relais vom Arduino trennen - sprich dafür ein anderes Netzteil verwenden. Dann sollte Ruhe sein.
lg
bk

1+1 = 10 Angel ...und ich bin hier nicht der Suchmaschinen-Ersatz Dodgy...nur mal so als genereller Tipp..
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
27.03.2015, 23:25
Beitrag #3
RE: Relais und Led
(27.03.2015 21:30)Bitklopfer schrieb:  ....Hi Berg..,
ist doch ganz einfach...die Spulen der Relais erzeugen induktive Spannungen und die schlagen auf den Rest der Schaltung durch.
Abhilfe ist erst mal eine Freilaufdiode parallel zu den Spulen. Dann kann man die Plus Versorgung der Relais vom Arduino trennen - sprich dafür ein anderes Netzteil verwenden. Dann sollte Ruhe sein.
lg
bk

Grüß di,
Danke .... also: Ich habe das Relais welches für das Arduino gedacht ist.
Kompl. D.h. mit Freilaufdoiden.
Aber ich probiers mit externer Stromversorgung - Danke für den Tipp
Versuch macht kluch
Gruß
Gerd

Smile Schön dabei zu sein Smile
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
28.03.2015, 09:27
Beitrag #4
RE: Relais und Led
(27.03.2015 23:25)bergfrei schrieb:  
(27.03.2015 21:30)Bitklopfer schrieb:  ....Hi Berg..,
ist doch ganz einfach...die Spulen der Relais erzeugen induktive Spannungen und die schlagen auf den Rest der Schaltung durch.
Abhilfe ist erst mal eine Freilaufdiode parallel zu den Spulen. Dann kann man die Plus Versorgung der Relais vom Arduino trennen - sprich dafür ein anderes Netzteil verwenden. Dann sollte Ruhe sein.
lg
bk

Grüß di,
Danke .... also: Ich habe das Relais welches für das Arduino gedacht ist.
Kompl. D.h. mit Freilaufdoiden.
Aber ich probiers mit externer Stromversorgung - Danke für den Tipp
Versuch macht kluch
Gruß
Gerd

Guten Morgen B.-klopfer,
habe bis in die Nachtstunden am Relais rumgepriemt und versch. Einstellungen probiert. -- Schlaflose Nacht - Big Grin
Heute Morgen den Fehler gefunden Idea
Relais kaputt !!
Merkwürdiger Fehler.
Versorgungsspannung OK -
sobald IN 1 dazukommt fällt die Spannung zusammen, es fliesst kein Strom ?
IN 1 getrennt und IN 2 angeschlossen - Relais brummt leise - es tut sich nichts
Ich habe ein 2 Kanal Relais Modul U = 5 Volt und Input = Pin 12
------ Relais entfernt, ein Wald und Wiesenrelais dran --- geht.
Willst das Relais zum probieren haben ? Ich schicke es dir zu - Null Problemo.
Have a nice day
Gerd

Smile Schön dabei zu sein Smile
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
28.03.2015, 14:03
Beitrag #5
RE: Relais und Led
(28.03.2015 09:27)bergfrei schrieb:  
(27.03.2015 23:25)bergfrei schrieb:  
(27.03.2015 21:30)Bitklopfer schrieb:  ....Hi Berg..,
ist doch ganz einfach...die Spulen der Relais erzeugen induktive Spannungen und die schlagen auf den Rest der Schaltung durch.
Abhilfe ist erst mal eine Freilaufdiode parallel zu den Spulen. Dann kann man die Plus Versorgung der Relais vom Arduino trennen - sprich dafür ein anderes Netzteil verwenden. Dann sollte Ruhe sein.
lg
bk

Grüß di,
Danke .... also: Ich habe das Relais welches für das Arduino gedacht ist.
Kompl. D.h. mit Freilaufdoiden.
Aber ich probiers mit externer Stromversorgung - Danke für den Tipp
Versuch macht kluch
Gruß
Gerd

Guten Morgen B.-klopfer,
habe bis in die Nachtstunden am Relais rumgepriemt und versch. Einstellungen probiert. -- Schlaflose Nacht - Big Grin
Heute Morgen den Fehler gefunden Idea
Relais kaputt !!
Merkwürdiger Fehler.
Versorgungsspannung OK -
sobald IN 1 dazukommt fällt die Spannung zusammen, es fliesst kein Strom ?
IN 1 getrennt und IN 2 angeschlossen - Relais brummt leise - es tut sich nichts
Ich habe ein 2 Kanal Relais Modul U = 5 Volt und Input = Pin 12
------ Relais entfernt, ein Wald und Wiesenrelais dran --- geht.
Willst das Relais zum probieren haben ? Ich schicke es dir zu - Null Problemo.
Have a nice day
Gerd

Hallo Gerd,
ähm wie hast du das Relais denn angeschlossen ? Über nen NPN Transistor oder ist das so ein fertiges Teil für Arduinos so mit Optokoppler drauf ?
Ne Danke...habe genug Material hier... wenn das Relais als Fehler erkannt wurde dann große Tonne....hab eh wenig Zeit zum basteln.
lg
bk

1+1 = 10 Angel ...und ich bin hier nicht der Suchmaschinen-Ersatz Dodgy...nur mal so als genereller Tipp..
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
28.03.2015, 21:23
Beitrag #6
RE: Relais und Led
(28.03.2015 14:03)Bitklopfer schrieb:  
(28.03.2015 09:27)bergfrei schrieb:  
(27.03.2015 23:25)bergfrei schrieb:  
(27.03.2015 21:30)Bitklopfer schrieb:  ....Hi Berg..,
ist doch ganz einfach...die Spulen der Relais erzeugen induktive Spannungen und die schlagen auf den Rest der Schaltung durch.
Abhilfe ist erst mal eine Freilaufdiode parallel zu den Spulen. Dann kann man die Plus Versorgung der Relais vom Arduino trennen - sprich dafür ein anderes Netzteil verwenden. Dann sollte Ruhe sein.
lg
bk

Grüß di,
Danke .... also: Ich habe das Relais welches für das Arduino gedacht ist.
Kompl. D.h. mit Freilaufdoiden.
Aber ich probiers mit externer Stromversorgung - Danke für den Tipp
Versuch macht kluch
Gruß
Gerd

Guten Morgen B.-klopfer,
habe bis in die Nachtstunden am Relais rumgepriemt und versch. Einstellungen probiert. -- Schlaflose Nacht - Big Grin
Heute Morgen den Fehler gefunden Idea
Relais kaputt !!
Merkwürdiger Fehler.
Versorgungsspannung OK -
sobald IN 1 dazukommt fällt die Spannung zusammen, es fliesst kein Strom ?
IN 1 getrennt und IN 2 angeschlossen - Relais brummt leise - es tut sich nichts
Ich habe ein 2 Kanal Relais Modul U = 5 Volt und Input = Pin 12
------ Relais entfernt, ein Wald und Wiesenrelais dran --- geht.
Willst das Relais zum probieren haben ? Ich schicke es dir zu - Null Problemo.
Have a nice day
Gerd

Hallo Gerd,
ähm wie hast du das Relais denn angeschlossen ? Über nen NPN Transistor oder ist das so ein fertiges Teil für Arduinos so mit Optokoppler drauf ?
Ne Danke...habe genug Material hier... wenn das Relais als Fehler erkannt wurde dann große Tonne....hab eh wenig Zeit zum basteln.
lg
bk
Hallo Bitklopfer,
spät der Abend, habe noch ne schöne Bergtour gemacht.
Ja das ist ein fertiges Bauteil. Wird ohne wenn und aber angeschlossen.
Ich haus in die Tonne Big Grin
Übrigens durch deinen Tipp, externes Netzteil probieren bin ich dahinter gekommen. Danke dir nochmals.
Gruß Gerd

Smile Schön dabei zu sein Smile
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
29.03.2015, 02:07
Beitrag #7
RE: Relais und Led
(28.03.2015 21:23)bergfrei schrieb:  ...
Hallo Bitklopfer,
spät der Abend, habe noch ne schöne Bergtour gemacht.
Ja das ist ein fertiges Bauteil. Wird ohne wenn und aber angeschlossen.
Ich haus in die Tonne Big Grin
Übrigens durch deinen Tipp, externes Netzteil probieren bin ich dahinter gekommen. Danke dir nochmals.
Gruß Gerd

Bergtour ist auch gut...ich war "nur" bei Watterott...da hätte es möglicherweise auch Relais gegeben...
Gibt es von dem Relais vielleicht eine Produktbeschreibung wo im Netz ? Dann kuck ich mir das mal an.
Keine Ursache.
lg
bk

1+1 = 10 Angel ...und ich bin hier nicht der Suchmaschinen-Ersatz Dodgy...nur mal so als genereller Tipp..
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
29.03.2015, 10:17
Beitrag #8
RE: Relais und Led
Watterott kann sehr schweißtreibend sein besonders bei schmalem Börsel Smile
Würde dir gerne - sehr gerne behilflich sein doch leider finde ich nur ein Bild und ich glaube für dich nichts neues. Ich hänge es trotzdem an um evtl. Missverstand zu vermeiden.
Wenn dir aber durch Sch..Wetter fad is, ich habe ein Sketch nach meiner Vorstellung
umgeschrieben (Melodie mit tone) und nun soll der Kack mittels Pir losbrüllen.
Das Einzige was tut, Orangeanzeige und engl. Sch.., da bin ich besonders gut.
Nur, wenn dir fad ist Tongue
Habe das Relais durchgeklingelt, wies ausschaut- Spule R= 8 (die 8 horizontal Tongue)
Liebe Grüße
Gerd


Angehängte Datei(en) Thumbnail(s)
   

Smile Schön dabei zu sein Smile
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
Antwort schreiben 


Möglicherweise verwandte Themen...
Thema: Verfasser Antworten: Ansichten: Letzter Beitrag
  Solid State Relais Zünden. Impuls vs Dauerfeuer BennIY 6 226 18.09.2016 23:44
Letzter Beitrag: BennIY
  Inrush Relais am Arduino MKnet83 1 202 07.09.2016 16:11
Letzter Beitrag: ardu_arne
  LED röhren schalten. Passt dieses SSD Relais? BennIY 10 1.088 06.01.2016 19:29
Letzter Beitrag: Bitklopfer
  Servos, Temperatursensoren, Relais und Lichtschranke Pw91 8 1.653 25.07.2015 14:03
Letzter Beitrag: Bitklopfer
  8-Kanal Relais in Hutschiene Thorsten Pferdekämper 13 3.043 19.07.2015 17:04
Letzter Beitrag: alpenpower
Question Arduino Uno + Relais Hans22 24 12.063 18.01.2015 22:02
Letzter Beitrag: Bitklopfer
Question Taster Relais Funk Verbindung MeRo113 22 4.964 30.11.2014 14:10
Letzter Beitrag: Bitklopfer
  LCD Shield & 4Kanal Relais Shield gleiche Pins hannes77 3 1.675 04.06.2014 00:25
Letzter Beitrag: ArduTux
  Multiplex Relais Karte Flippermaniac 3 2.478 06.03.2014 21:02
Letzter Beitrag: Stich73
  Gelöst: Ethernet Shield, SPI, Schieberegister, Relais - irgendwie klappt's nicht Thorsten Pferdekämper 3 2.116 28.02.2014 19:29
Letzter Beitrag: Thorsten Pferdekämper

Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste