INFO: Dieses Forum nutzt Cookies...
Cookies sind für den Betrieb des Forums unverzichtbar. Mit der Nutzung des Forums erklärst Du dich damit einverstanden, dass wir Cookies verwenden.

Es wird in jedem Fall ein Cookie gesetzt um diesen Hinweis nicht mehr zu erhalten. Desweiteren setzen wir Google Adsense und Google Analytics ein.

Antwort schreiben 
 
Themabewertung:
  • 0 Bewertungen - 0 im Durchschnitt
  • 1
  • 2
  • 3
  • 4
  • 5
RGB-LCD-Shield (ADA714) funktioniert über Kabelverbindung am Uno Rev. 3 nicht
14.11.2013, 08:06
Beitrag #1
RGB-LCD-Shield (ADA714) funktioniert über Kabelverbindung am Uno Rev. 3 nicht
Hi Mitstreiter,

habe mit vor wenigen Tagen ein Uno-Board Rev. 3 und ein Adafruit RGB-LCD-Shield gekauft. Ich habe das Shield koplettiert und das entprechende "Hello World" Demoprogramm auf dem Uno-Board eingespielt. Es funktionierte allles prima. Mit den Tasten konnte man die Displayfarben wechseln und den Text konnte man lesen. Big Grin

Da ich das Controllerboard und das Display in meinem Projekt (Kühlschrankthermostat) räumlich trennen muss, wollte ich die Komponenten mit Flachbandkabel verbinden. Also studierte ich die Dokumentation auf der Adafruit-Seite und verband die Spannungsversorgung (2-polig) und den I²C-Bus (2-polig). Nach dem Anlegen der Betriebsspannung blieb das Display dunkel. Sad Das Shield wieder direkt auf dem Controllerboard montiert und das Programm stelle alles wie gewohnt dar. Undecided

Kann es sein, dass ich abgesehen von den 4 Verbindungen zwischen Uno und shield noch weitere Verbindungen benötige? War der Annahme, dass die komplette Steuerung (auch Hintergrundbeleuchtung) über den Bus gesteuert werden. Huh

Vielen Dank für eure Tipps!

Andreas
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
14.11.2013, 20:51
Beitrag #2
RE: RGB-LCD-Shield (ADA714) funktioniert über Kabelverbindung am Uno Rev. 3 nicht
Hallo adx00356 (what a Name),

Zitat: und ein Adafruit RGB-LCD-Shield gekauft

Welches genau? Gibt's einen Link?

Grüße Ricardo
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
15.11.2013, 10:06
Beitrag #3
RE: RGB-LCD-Shield (ADA714) funktioniert über Kabelverbindung am Uno Rev. 3 nicht
Hi Ricardo,

(14.11.2013 20:51)rkuehle schrieb:  Hallo adx00356 (what a Name),

Zitat: und ein Adafruit RGB-LCD-Shield gekauft

Welches genau? Gibt's einen Link?

Grüße Ricardo

bin vielleicht etwas paranoid! Dodgy

Habe mit das Display bei Watterott gekauft und wird von Adafriut eigentlich als 716-er angeboten. Du findest Inforamtionen unter folgendem Link:

http://learn.adafruit.com/adafruit-shiel...lcd-shield

Gestern habe ich mit die Beschreibung nochmals durch gelesen und nach der Methode "Des genauen Hinsehens und Lesens" den Fehler entdeckt. Big Grin Irrtümlicherweise hatte ich das Kabel der Spannungsversorgung falsch gelötet. Neben dem 5Volt-Pin muss man den 2. GND-Pin nutzen. der erste scheint lt. Hersteller nicht verbunden zu sein. Jetz geht es (siehe Bild im Anhang)!

Werde mich nun der Thermostatsteuerung für einen Kühlschrank hingeben! Mit 'ner RTC-Uhr könnte man den Kompressor über nacht abschalten (stromsparen). Mal sehehn ob's Sinn macht. Einen DS18B20 für die Kühlung und den 2. für die Kompressorüberwachung (Anlaufen unter Druck bzw. Durchbrennen verhindern). Vielleicht zwirbeln wir den Thermostat dann am Ende noch an das ausstehende Hausinformationssystem!


VG Andy


Angehängte Datei(en) Thumbnail(s)
   
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
Antwort schreiben 


Möglicherweise verwandte Themen...
Thema: Verfasser Antworten: Ansichten: Letzter Beitrag
  8 Eingänge 5-24 Volt über I2C Bus Reaktionszeit Franz54 0 246 01.05.2017 13:15
Letzter Beitrag: Franz54
  CAN-Shield iVm 3,3V Arduino Pro Mini Clubsport 12 564 13.04.2017 22:56
Letzter Beitrag: Bitklopfer
  Sketch über HC-06 Wireless auf Arduino ? b3ta 12 605 06.04.2017 14:47
Letzter Beitrag: Tommy56
  Arduino Uno R3, servos reagieren nicht auf die Befehle Crossedsticks 5 407 22.02.2017 22:42
Letzter Beitrag: Binatone
  4-fach Relaiskarte HL-54 zieht nicht richtig an. Kriskind 13 648 12.02.2017 23:51
Letzter Beitrag: Tommy56
  SM5100B GSM shield huber5093 2 255 01.02.2017 04:19
Letzter Beitrag: bergfrei
  CNC Shield V3 + Nema 17 relay 2 839 26.12.2016 15:01
Letzter Beitrag: Ralla1
  Grundsatz Frage: Ethernet Shield 2 + SQL-Anbindung Beercules 7 504 16.12.2016 13:40
Letzter Beitrag: ardu_arne
  ws2812b + nodemcu Ich finde den Fehler nicht. Tha_Coralis 16 1.278 15.12.2016 18:37
Letzter Beitrag: Harry Hirsch
  USB-Gerät wird nicht erkannt kpc 4 719 13.12.2016 15:48
Letzter Beitrag: René Hitz

Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste