INFO: Dieses Forum nutzt Cookies...
Cookies sind für den Betrieb des Forums unverzichtbar. Mit der Nutzung des Forums erklärst Du dich damit einverstanden, dass wir Cookies verwenden.

Es wird in jedem Fall ein Cookie gesetzt um diesen Hinweis nicht mehr zu erhalten. Desweiteren setzen wir Google Adsense und Google Analytics ein.

Antwort schreiben 
 
Themabewertung:
  • 0 Bewertungen - 0 im Durchschnitt
  • 1
  • 2
  • 3
  • 4
  • 5
Programm läuft nicht
14.07.2014, 16:12
Beitrag #1
Programm läuft nicht
Hallo,

es ist mein erstes Programm doch ich bekomme es nicht zum Laufen. Es ist ein teensy 2.0 Board und es soll beim drücken des Tasters 10 den Befehl an den Rechner senden als wenn die Tasten CTRL+ALT+C des USB Keyboards gedrückt werden.
Was mache ich falsch?
Vielen Dank für Hinweise.

Datei habe ich angehangen.

.ino  gigap5.ino (Größe: 1 KB / Downloads: 47)
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
14.07.2014, 16:53
Beitrag #2
RE: Programm läuft nicht
Hallo teensy,

ich habe zwar keine Ahnung vom teensy, was mir aber auffällt sind schon mal diese Zeilen:
Code:
#define KEY_MODIFIER_LEFT_CTRL, KEY_MODIFIER_RIGHT_CTRL;
#define KEY_MODIFIER_LEFT_ALT, KEY_MODIFIER_RIGHT_ALT;
Einerseits werden #define - Anweisungen nicht mit einem Semikolon abgeschlossen, andererseits weist du den Variablen keine Werte zu, sondern zählst sie nur in den #define auf Huh

Grüße RK

Nüchtern betrachtet...ist besoffen besser Big Grin
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
Antwort schreiben 


Möglicherweise verwandte Themen...
Thema: Verfasser Antworten: Ansichten: Letzter Beitrag
  SD Karte wird nicht erkannt Maxi290997 6 195 31.03.2017 06:05
Letzter Beitrag: Bitklopfer
Sad Sketch funktioniert auf dem Mega 2560 nicht Frank1234 16 595 26.03.2017 14:15
Letzter Beitrag: oOSpikeOo
  Mein Skript macht nicht das was es soll ;( DerMatze79 4 218 16.03.2017 22:19
Letzter Beitrag: MicroBahner
Rainbow Programm mit Tastr unterbrechen Schwinge117 12 430 02.03.2017 21:17
Letzter Beitrag: Tommy56
  Programmablauf macht nicht das was ich möchte !! ESP + Blynk b3ta 3 199 01.03.2017 14:29
Letzter Beitrag: Tommy56
Rainbow File geht nicht zum compilieren!!!! Jocky 7 295 19.02.2017 20:01
Letzter Beitrag: Binatone
  IRremote bringe ich nicht zum laufen Franz54 5 231 19.02.2017 11:56
Letzter Beitrag: Tommy56
  Code aus 1.6.9 geht mit 1.8.1 nicht mehr zu kompilieren DL1AKP 7 424 02.02.2017 12:16
Letzter Beitrag: Tommy56
  Programm Elegoo Smart Robot kit Thorsten_S 3 429 29.01.2017 17:40
Letzter Beitrag: Micha06
  Arduino Läst sich nicht Programmieren Micha06 4 318 29.01.2017 17:27
Letzter Beitrag: Micha06

Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste