INFO: Dieses Forum nutzt Cookies...
Cookies sind für den Betrieb des Forums unverzichtbar. Mit der Nutzung des Forums erklärst Du dich damit einverstanden, dass wir Cookies verwenden.

Es wird in jedem Fall ein Cookie gesetzt um diesen Hinweis nicht mehr zu erhalten. Desweiteren setzen wir Google Adsense und Google Analytics ein.

Antwort schreiben 
 
Themabewertung:
  • 0 Bewertungen - 0 im Durchschnitt
  • 1
  • 2
  • 3
  • 4
  • 5
Programm läuft nicht
14.07.2014, 16:12
Beitrag #1
Programm läuft nicht
Hallo,

es ist mein erstes Programm doch ich bekomme es nicht zum Laufen. Es ist ein teensy 2.0 Board und es soll beim drücken des Tasters 10 den Befehl an den Rechner senden als wenn die Tasten CTRL+ALT+C des USB Keyboards gedrückt werden.
Was mache ich falsch?
Vielen Dank für Hinweise.

Datei habe ich angehangen.

.ino  gigap5.ino (Größe: 1 KB / Downloads: 43)
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
14.07.2014, 16:53
Beitrag #2
RE: Programm läuft nicht
Hallo teensy,

ich habe zwar keine Ahnung vom teensy, was mir aber auffällt sind schon mal diese Zeilen:
Code:
#define KEY_MODIFIER_LEFT_CTRL, KEY_MODIFIER_RIGHT_CTRL;
#define KEY_MODIFIER_LEFT_ALT, KEY_MODIFIER_RIGHT_ALT;
Einerseits werden #define - Anweisungen nicht mit einem Semikolon abgeschlossen, andererseits weist du den Variablen keine Werte zu, sondern zählst sie nur in den #define auf Huh

Grüße RK

Nüchtern betrachtet...ist besoffen besser Big Grin
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
Antwort schreiben 


Möglicherweise verwandte Themen...
Thema: Verfasser Antworten: Ansichten: Letzter Beitrag
  Fehler in meinem Programm Franz54 7 155 01.12.2016 23:58
Letzter Beitrag: hotsystems
  Text läuft wie verrückt Atwist 12 217 20.11.2016 18:41
Letzter Beitrag: Tommy56
  Arduino lässt sich nicht installieren bergfrei 4 145 20.11.2016 18:34
Letzter Beitrag: bergfrei
  Arduino Mega 2560 läuft nicht Wolfgang50 6 181 13.11.2016 10:50
Letzter Beitrag: Wolfgang50
  Ardublock übertragt nicht an IDE oder UNO R3 tobi83 5 339 16.10.2016 14:07
Letzter Beitrag: Pit
  Upload funktioniert nicht Levi 5 240 22.09.2016 20:19
Letzter Beitrag: hotsystems
  ESP8266 tuts nicht sowerum 7 392 19.09.2016 21:01
Letzter Beitrag: sowerum
  If-Bedingung funktioniert nicht bei Serial1.write Datatom 6 223 16.09.2016 20:36
Letzter Beitrag: Datatom
  SD Karte wird nicht erkannt... Maxi290997 2 202 16.08.2016 14:36
Letzter Beitrag: Maxi290997
  Arduino lässt sich nicht mehr beschreiben Maxi290997 15 975 07.08.2016 11:40
Letzter Beitrag: Maxi290997

Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste