INFO: Dieses Forum nutzt Cookies...
Cookies sind für den Betrieb des Forums unverzichtbar. Mit der Nutzung des Forums erklärst Du dich damit einverstanden, dass wir Cookies verwenden.

Es wird in jedem Fall ein Cookie gesetzt um diesen Hinweis nicht mehr zu erhalten. Desweiteren setzen wir Google Adsense und Google Analytics ein.

Antwort schreiben 
 
Themabewertung:
  • 0 Bewertungen - 0 im Durchschnitt
  • 1
  • 2
  • 3
  • 4
  • 5
Probleme mit ws2812b Led stripes
10.05.2016, 09:59
Beitrag #1
Probleme mit ws2812b Led stripes
Moin

Ich habe mir in den letzten Wochen eine Matrix aus WS2812b Streifen gebastelt. Sie wird über ein Arduino-board angesteuert und lässt sich ebenfalls erfolgreich über die Software "Glediator" steuern.
Jedoch habe ich folgendes Problem : Wenn ich die helligkeit im Glediator-programm zu hoch stelle , bzw wenn mein Arduino-programm eine längere zeit mit einer Helligkeit von ca 100 (ca 1/3) leuchtet passiert folgendes. :

Ein Pixel setzt aus und behält seinen aktuellen Zustand bei. Alle Pixel dahinter bleiben ebenfalls stehen; Auffällig ist das dieses Problem immer bei den selben 2 - 3 Pixeln entsteht. Nach mehrmaligen An- und Aus-schalten funktioniert die Matrix wieder einwandfrei bis sich das ganze irgendwann wiederholt ...

Woran könnte das Problem liegen ?

Infos ; Die Matrix besteht aus 408 Pixeln. Diese werden von einem 5V / 20 A Netzteil an 4 stellen mit Spannung versorgt.
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
10.05.2016, 10:22
Beitrag #2
RE: Probleme mit ws2812b Led stripes
(10.05.2016 09:59)Gravia schrieb:  ...Nach mehrmaligen An- und Aus-schalten funktioniert die Matrix wieder einwandfrei bis sich das ganze irgendwann wiederholt ...

Was schaltest du an und aus?
Den Arduino oder nur den Led-Stripe?

Hast du schon mal die Leds vertauscht?
Dann könntest du feststellen, ob es die Leds sind.

I2C = weniger ist mehr: weniger Kabel, mehr Probleme. Cool
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
10.05.2016, 10:30
Beitrag #3
RE: Probleme mit ws2812b Led stripes
Ich Schalte die Spannungsversorgung der Ledstreifen aus und an. Nach mehrmaligem Wiederholen funktionieren die Led´s wieder.

Einen Pixel auszutauschen habe ich noch nicht gewagt , ist aber einen versuch wert da immer nur 3 bestimmte Pixel ,bzw. alle dahinter nicher mehr funktionieren.
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
10.05.2016, 17:31
Beitrag #4
RE: Probleme mit ws2812b Led stripes
Das klingt nach einem thermischen Problem. Nach Abkühlung laufen sie wieder.

Du speist an 4 Stellen die Spannung ein. Das erscheint mir etwas wenig. Das wären grob ca. 100 LED pro Einspeisung.
Schau mal, ob die nicht funktionierenden LED die LED sind, die am weitesten von den Einspeisungen weg sind.
Du speist nicht nur VCC, sondern auch GND mehrfach ein, hoffe ich.

Gruß Tommy
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
04.06.2016, 08:58
Beitrag #5
RE: Probleme mit ws2812b Led stripes
ich hänge mich mal hier drann. ich habe noch nie mit 2812 streifen gearbeitet. wo gibt es datenblätter? google ergab bei meiner suche nix brauchbares. nur 20ma Imax. pro farbe? oder maximal? elektrotechnische grundkenntnisse habe ich. aufbau also kein problem.
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
04.06.2016, 14:50
Beitrag #6
RE: Probleme mit ws2812b Led stripes
danke, hat sich erledigt.
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
Antwort schreiben 


Möglicherweise verwandte Themen...
Thema: Verfasser Antworten: Ansichten: Letzter Beitrag
  Arduino Micro - Probleme madin 20 260 Heute 21:07
Letzter Beitrag: hotsystems
  Probleme mit ESP8266 BennIY 6 220 20.11.2016 14:49
Letzter Beitrag: BennIY
  Probleme mit mehreren DS18B20 Fühlern Uwa 12 326 15.10.2016 15:26
Letzter Beitrag: ardu_arne
  Probleme mit SIM900 GSM seit PinManagment test BennIY 0 172 31.07.2016 23:33
Letzter Beitrag: BennIY
  Probleme mit dem Arduino Ethernet-Shild jalu4601 25 1.346 06.06.2016 16:09
Letzter Beitrag: Bitklopfer
  Probleme mit Schrittmotorsteuerplatine Wetteronkel 2 542 16.03.2016 16:07
Letzter Beitrag: Wetteronkel
  Probleme beim Löten Binatone 18 1.714 14.01.2016 14:12
Letzter Beitrag: alpenpower
  Probleme mit ESP8266 giessbee 1 1.484 09.06.2015 22:47
Letzter Beitrag: Scherheinz
  LED stripes steuern roller64 2 1.154 21.04.2015 20:48
Letzter Beitrag: roller64
  Probleme mit Trinket Jumperdome 16 2.803 21.04.2015 18:14
Letzter Beitrag: Jumperdome

Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste