INFO: Dieses Forum nutzt Cookies...
Cookies sind für den Betrieb des Forums unverzichtbar. Mit der Nutzung des Forums erklärst Du dich damit einverstanden, dass wir Cookies verwenden.

Es wird in jedem Fall ein Cookie gesetzt um diesen Hinweis nicht mehr zu erhalten. Desweiteren setzen wir Google Adsense und Google Analytics ein.

Antwort schreiben 
 
Themabewertung:
  • 1 Bewertungen - 1 im Durchschnitt
  • 1
  • 2
  • 3
  • 4
  • 5
Probleme mit dem Sloeber-Plugin in Eclipse
24.06.2019, 08:11 (Dieser Beitrag wurde zuletzt bearbeitet: 24.06.2019 08:29 von mash3010.)
Beitrag #1
Probleme mit dem Sloeber-Plugin in Eclipse
Moin,

sonnige Grüße aus Schleswig-Holstein. Ich habe hier immer nur mitgelesen, jetzt kommt mein erster Beitrag.

Ich habe bis vor einiger Zeit immer mit der Atmel-IDE gearbeitet. Danach bin ich auf die Arduino-Hardware umgestiegen und habe die dazu gehörende IDE ausprobiert. Das Handling mit Referenzen usw. hat mich nicht befriedigt. Da ich berufsmäßig Jahre lang mit Eclipse (Java-Entwicklung) gearbeitet hatte (bin jetzt im Ruhestand), möchte ich gerne Eclipse weiter benutzen. Ich habe mir also die neueste Eclipse-Version (2019.06) geladen und das aktuelle Sloeber-Plugin aus dem Market-Place installiert. Das funktionierte gut. Ich kann aber kein neues Projekt anlegen. Ich fülle alle Felder im Dialog aus (Board-Typ usw.), beim Abschluss erscheint sofort eine Fehlermeldung:
'Failed to create project: java.lang.reflect.InvocationTargetException'

Übrigens ist es Egal auf welchem Betriebssystem (MAC Mojave, Windows 10) ich das probiere, der Fehler ist der gleiche.

Ist der Fehler hier bekannt?

Gruß,
Michael
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
24.06.2019, 20:49
Beitrag #2
RE: Probleme mit dem Sloeber-Plugin in Eclipse
Hallo Michael,
für Java benutze ich bis jetzt immer noch NetBeans, mit der Eclipse habe ich auch bissel gearbeitet. Relativ lange jedoch, habe mir der Eclipse (grundsätzlich) App´s geschrieben. Die “Mächtigen“ machen die Eclipse jedoch “dicht“. Hier spreche ich nicht nur für Apps Entwicklung … Heute mit der Eclipse ist App´s Programmieren nicht machbar. Gehe daher davon aus, dass die Arduino DIDE Entwickler (jetzt allgemein) keinerlei Interesse haben, die Eclipse, für die Arduino und Co Plattform zu erweitern. Ist aber nur meine Private Meinung dazu.
Zum Thema;
Zitat:Ist der Fehler hier bekannt?
Vermute nicht dass hier jemand für die Arduino die Eclipse benutzt.
Gruß Georg

Sorry für mein nicht korrektes Deutsch. Sad
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
24.06.2019, 21:41
Beitrag #3
RE: Probleme mit dem Sloeber-Plugin in Eclipse
(24.06.2019 20:49)georg01 schrieb:  Vermute nicht dass hier jemand für die Arduino die Eclipse benutzt.
Gruß Georg

Naja, es gibt ja einige Alternativen:
  • PlatformIO IDE
  • MPLABX-IDE
  • AtmelStudio mit oder ohne Plugin (VisualMicro)
  • Das erwähnte Sloeber-Plugin für Eclipse
  • VisualStudio mit Plugin (VisualMicro)

Ich nutze zur Zeit PlatformIO, weil das Plugin VisualMicro für AtmelStudio und VisualStudio inzwischen nicht mehr kostenlos ist (vorher gab es wenigstens die Basis-Version gratis).
Die PlatformIO-IDE läuft auf dem tollen Editor "VisualStudioCode" (, den man nicht mit dem "VisualStudio" verwechseln darf!) oder auf dem ebenfalss tollen Editor "Atom". So weit funktioniert das ganz gut - sogar mit dem ArduinoDue, mit ich z.Zt. arbeite. Leider ist da noch nicht "Find all references..." möglich. Aber Code-Completion und IntelliSense funktionieren ansonsten gut. Auch "Go to definition" etc. und IDE-integrierter Upload zum Controller klappt.

Das Sloeber-Plugin habe ich noch nicht probiert. Es wird aber durchaus von anderen empfohlen.

Die MPLABX-IDE von Microchip war früher nur für PIC-Controller. Da Microchip aber Atmel gekauft hat, sind inzwischen damit auch viele Atmels damit nutzbar und es gibt sogar eine Projekt-Unterstützung für Arduino.
Das ganze basiert auf NetBeans und wäre meine Wahl, wenn der ArduinoDue unterstützt würde, was leider nicht so ist. Es werden zwar SAM-Controller unterstützt, aber nicht der 3X8E des Due.

Für VisualStudio gilt das selbe wie für AtmelStudio: Das Plugin kostet inzwischen leider Geld. Das AtmelStudio basiert noch auf einer älteren Version von VisualStudio. Wenn man direkt VisualStudio verwendet, kann man die neueren Versionen nehmen.
Aber ich persönlich will für das Plugin "VisualMicro" einfach kein Geld bezahlen. Wer dazu bereit ist bekommt aber durchaus eine vernünftige Software.
Man kann man auch Gnu-C++ Projekte für Arduino schreiben und auf das Plugin verzichten.
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
26.06.2019, 09:44 (Dieser Beitrag wurde zuletzt bearbeitet: 26.06.2019 09:45 von mash3010.)
Beitrag #4
RE: Probleme mit dem Sloeber-Plugin in Eclipse
Moin,

erstmal vielen Dank für die Antworten. Auch, wenn sie mir nicht direkt weiter geholfen haben. Ich habe mir jetzt die Sloeber-IDE geladen, die funktioniert zumindest auch auf meinem Mac. Die ist allerdings nur 32bittig und Apple stellt die Unterstützung mit der nächsten MacOs-Version ein.

Die PlatformIO-IDE gibt ja auch für MacOs, die werde ich mir mal ansehen.

Gruß,
Michael
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
26.06.2019, 15:15
Beitrag #5
RE: Probleme mit dem Sloeber-Plugin in Eclipse
(26.06.2019 09:44)mash3010 schrieb:  Die PlatformIO-IDE gibt ja auch für MacOs, die werde ich mir mal ansehen.

Das ist bestimmt kein Fehler. Ich bin damit ganz zufrieden.
Bin gespannt auf Deinen Bericht.

Wenn schon vor Jahren angekündigte neue ArduinoIDE endlich mal fertig würde, könnte man evtl. auf andre IDEs verzichten. Da sollen CodeCompletion etc. ja funktionieren. Das klappt in der Beta schon ansatzweise.

Aber ganz ohne solche features wie im aktuellen Release - geht gar nicht für mich.
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
Antwort schreiben 


Möglicherweise verwandte Themen...
Thema: Verfasser Antworten: Ansichten: Letzter Beitrag
  Probleme mit SD-Karten und Displayansteuerung gleichzeitig reichs 7 237 13.11.2019 18:55
Letzter Beitrag: reichs
  Probleme mit Blinklicht auf bestimmte Zeit Prospekteur 15 524 20.10.2019 17:08
Letzter Beitrag: Tommy56
  Nextion und die Probleme mit Arduino.... alpenpower 7 465 17.10.2019 13:51
Letzter Beitrag: Tommy56
  Makeblock mit Scratch programmieren- Probleme Keinen Schimmer 18 12.511 27.05.2019 15:53
Letzter Beitrag: Hellow2
  LAN- Probleme mit Arduino UNO und W5100 Ethernet Shield SpooN 32 2.850 13.05.2019 16:54
Letzter Beitrag: SpooN
  Probleme Mit Sleep Hoeuzitry 1 558 20.04.2019 22:36
Letzter Beitrag: Chopp
  Probleme mit DCF-77 Empfänger von Pollin unkreativ 11 1.351 04.04.2019 10:48
Letzter Beitrag: unkreativ
  Wiegezelle und hx711 Probleme Haukini 2 778 24.03.2019 16:27
Letzter Beitrag: Haukini
  Probleme im Editor 1.8.8 Petrowitsch 29 2.209 10.02.2019 14:11
Letzter Beitrag: Petrowitsch
  Probleme mit Kuman Tft Screen unkreativ 4 625 17.01.2019 11:36
Letzter Beitrag: unkreativ

Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste