INFO: Dieses Forum nutzt Cookies...
Cookies sind für den Betrieb des Forums unverzichtbar. Mit der Nutzung des Forums erklärst Du dich damit einverstanden, dass wir Cookies verwenden.

Es wird in jedem Fall ein Cookie gesetzt um diesen Hinweis nicht mehr zu erhalten. Desweiteren setzen wir Google Adsense und Google Analytics ein.

Antwort schreiben 
 
Themabewertung:
  • 0 Bewertungen - 0 im Durchschnitt
  • 1
  • 2
  • 3
  • 4
  • 5
Probleme mit dem FTDI-Chip
05.12.2016, 14:53 (Dieser Beitrag wurde zuletzt bearbeitet: 05.12.2016 14:55 von Harry Hirsch.)
Beitrag #1
Probleme mit dem FTDI-Chip
Ich habe Probleme mit dem FTD Chip. Mein USB zu Seriel Adapter will nicht, wie hier schon mal für den Arduino mit diesem Chip beschrieben. Ich habe Zwei mit der Bezeichnung FTD1232 vom Chinamann. Bei Einem leuchten alle LED, aber nach etlichen Versuchen nach Anleitungen hier im Netz habe ich es hinbekommen das er gefunden wird und das auch von der IDE.
Das ein Sketch überspielt wird sehe ich nur am angeschlossenen Mini (der Arduino ohne USB) wenn ich den Blink aufspiele und er läuft. Somit gehe ich mal davon aus das Er leidlich geht. Am Adapter brennen unverändert alle LED, da sehe ich nichts von der Datenübertragung.
Beim 2 leuchtet die Kontroll- Led und beim Einstecken manchmal die beiden anderen LED.
Nach einer hier im Forum verlinkten Anleitung steht nun zwar ein USB zu Seriell Adapter im Hardwaremanager mit COM23, der soll auch betriebsbereit sein, nur mit der IDE (in der er auch aufgeführt) ist bekomme ich trotz dem keinen Sketch überspielt. Es folgt die hier schon öfter beschriebene Fehlermeldung am Ende des Ladevorganges, das war´s dann auch.
Mit dem Terminal habe ich es auch schon mal versucht (TXT mit RXT gebrückt) geht auch nicht. Ich befürchte das ich den in die Tonne werfen kann, es gibt im Netzt zwar Anleitungen wie der Chipeeprom neu programmiert werden kann aber nur mit 2 seriellen Schnittstellen.
Scheint mir sehr kompliziert, weiß hier noch einer einen Tip?
Die Problem habe ich schon mal in einem anderen Thead beschrieben. dort ist mir aber "Kapern" vorgeworfen worden.
Ich denke zwar das es egal ist ob das Problem bei einem Arduino mit diesem Chip drauf auftritt oder auf einen solo USB- Wandler, was soll´s mach ich halt einen neuen Thread auf.
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
08.12.2016, 14:09
Beitrag #2
RE: Probleme mit dem FTDI-Chip
Na das Verschieben hat ja wohl nichts genutzt....
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
08.12.2016, 14:26
Beitrag #3
RE: Probleme mit dem FTDI-Chip
Du hast offenbar gefälschte Chips bekommen. Die werden von gewissen FTDI-Treibern umgeflasht und danach vom PC nicht mehr richtig erkannt. Ich habe schon mal Originalchips von FTDI bestellt und die Chinachips rausgeschmissen. Kostet aber fast gleich viel wie neue Chinaboards. Das Umflashen war nicht so kompliziert, kann aber jederzeit durch ein Update bei den Treibern wieder zunichte gemacht werden. Mit dem aktuellen Treiber sollte eigentlich nichts passieren, ich habe aber keine Chinachips mehr zum testen. --> Zurückflashen auch wenns für Dich mühsam ist oder in die Tonne mit den Boards.

Wenn der IC raucht wird viel Strom verbraucht.
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
08.12.2016, 15:53
Beitrag #4
RE: Probleme mit dem FTDI-Chip
(08.12.2016 14:26)René Hitz schrieb:  Du hast offenbar gefälschte Chips bekommen. Die werden von gewissen FTDI-Treibern umgeflasht und danach vom PC nicht mehr richtig erkannt. Ich habe schon mal Originalchips von FTDI bestellt und die Chinachips rausgeschmissen. Kostet aber fast gleich viel wie neue Chinaboards. Das Umflashen war nicht so kompliziert, kann aber jederzeit durch ein Update bei den Treibern wieder zunichte gemacht werden. Mit dem aktuellen Treiber sollte eigentlich nichts passieren, ich habe aber keine Chinachips mehr zum testen. --> Zurückflashen auch wenns für Dich mühsam ist oder in die Tonne mit den Boards.
Ich habe die CP2102, auch aus China. Treiber installiert und geht.

Gruß Tommy

"Wer den schnellen Erfolg sucht, sollte nicht programmieren, sondern Holz hacken." (Quelle unbekannt)
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
08.12.2016, 18:18
Beitrag #5
RE: Probleme mit dem FTDI-Chip
(08.12.2016 14:09)Harry Hirsch schrieb:  Na das Verschieben hat ja wohl nichts genutzt....

Mit dem "Verschieben" hat das sicher nichts zu tun und die Antwort hatte ich dir schon im anderen Thread gegeben. Diese wurde hier ja auch bestätigt.

Nimm die CP2102 wie Tommy56 schreibt oder einen Lieferanten aus DL (ca. 1 Euro teurer) und du kannst reklamieren.

Gruß Dieter

I2C = weniger ist mehr: weniger Kabel, mehr Probleme. Cool
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
08.12.2016, 18:43
Beitrag #6
RE: Probleme mit dem FTDI-Chip
Ist ja bei dem Preis auch nicht so wild das die nicht wollen, nur man ärgert sich halt. Einer geht jetzt wohl, mal sehen wie lange. Sind die Chips über USB zu flashen? wenn das der FDTI- Treiber kann sollte es doch gehen, wurde das hier schon mal probiert?
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
08.12.2016, 19:08
Beitrag #7
RE: Probleme mit dem FTDI-Chip
Du musst nach einem Tool dafür googeln. Ich habe das leider schon gelöscht. Geflasht wird über USB, die Device ID wird korrigiert, so dass es kein unbekanntes Gerät mehr ist.

Wenn der IC raucht wird viel Strom verbraucht.
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
12.12.2016, 12:29
Beitrag #8
RE: Probleme mit dem FTDI-Chip
Hallo René, ich habe ein Tool gefunden "Mprog" war es das welches Du hattest? Einen Adapter habe ich hinbekommen, der zweite wird auch erkannt will aber nicht. Es kommt immer zum Schluss die Meldung ...... not in sync.
Ich denke das da RXD nicht will, die TXD Led leuchtet und der Arduino "zuckt", mal nach einer verdächtigen Lötstelle suchen.
Das Ganze ist jetzt eher noch ein "warum will der nicht" als eine Notwendigkeit bei den paar € die der gekostet hat.
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
Antwort schreiben 


Möglicherweise verwandte Themen...
Thema: Verfasser Antworten: Ansichten: Letzter Beitrag
  Probleme mit USB-Port Herby007 0 87 Gestern 18:19
Letzter Beitrag: Herby007
  Pro Micro: SerialMonitor-Probleme AnFi 14 1.142 20.05.2019 16:10
Letzter Beitrag: AnFi
  Probleme mit 1,54" Oled von SPI auf i2c MasterOfPuppets 10 1.817 11.01.2019 12:54
Letzter Beitrag: Tommy56
  Windows 10 FTDI USB und CH340 USB parallel installieren Franzel007 14 3.085 14.01.2018 21:48
Letzter Beitrag: hotsystems
  Probleme mit dem Arduino Ethernet-Shild jalu4601 46 11.230 26.12.2017 00:26
Letzter Beitrag: ArduTux
  Arduino (Uno?) mit herausnehmbarem Chip Anfängerfrage famecastle 13 5.647 01.10.2017 17:40
Letzter Beitrag: Chopp
  SPI Probleme mit MCP25625 Cancontroller und MISO BennIY 15 2.352 15.05.2017 19:54
Letzter Beitrag: ardu_arne
  Arduino Micro - Probleme madin 65 13.736 07.01.2017 18:50
Letzter Beitrag: Harry Hirsch
  Probleme mit mehreren DS18B20 Fühlern Uwa 12 4.327 15.10.2016 15:26
Letzter Beitrag: ardu_arne
  Probleme mit SIM900 GSM seit PinManagment test BennIY 0 1.180 31.07.2016 23:33
Letzter Beitrag: BennIY

Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste