INFO: Dieses Forum nutzt Cookies...
Cookies sind für den Betrieb des Forums unverzichtbar. Mit der Nutzung des Forums erklärst Du dich damit einverstanden, dass wir Cookies verwenden.

Es wird in jedem Fall ein Cookie gesetzt um diesen Hinweis nicht mehr zu erhalten. Desweiteren setzen wir Google Adsense und Google Analytics ein.

Antwort schreiben 
 
Themabewertung:
  • 0 Bewertungen - 0 im Durchschnitt
  • 1
  • 2
  • 3
  • 4
  • 5
Probleme mit Sainsmart 16x2 Display
02.02.2014, 21:21
Beitrag #17
RE: Probleme mit Sainsmart 16x2 Display
(02.02.2014 20:03)spoernc schrieb:  Hallo,
das ist das Relaisboard:
http://www.ebay.de/itm/390457342663?ru=h...26_rdc%3D1

Das ist das Display:
http://www.ebay.de/itm/1602-Character-Bl...3f2c92f698

Die Schirmung ist jeweils einseitig auf 230V Erde angehängt. Sobald ich sie auf Arduino Masse hänge bekomme ich das Display nichtmal gestartet.
Hab spasseshalber auch mal +5V probiert, bringt auch nichts.

Gruss Christian

Auf was für einen Arduino ist das Displayshield gesteckt? Welche Pins benutzt du für die Relaiskarte?
Deine Gesamtkonfiguration ist mir im Moment etwas Rätselhaft. Ganz besonders die Leitungsverbindung zwischen LCD Display und Arduino wirft Fragen auf.
Ich denke, die Displaykarte sollte direkt auf den Arduino gesteckt sein.

Diese PINS dürfen auf jeden Fall nicht von der Relaiskarte benutzt werden sonst wird das Display nur noch Mist produzieren:

Analog 0--Button (select, up, right, down and left)

Digital 4--DB4

Digital 5--DB5

Digital 6--DB6

Digital 7--DB7

Digital 8--RS (Data or Signal Display Selection)

Digital 9--Enable

Digital 10--Backlit Control

und die Sainsmart Lib für das Display muß eingebunden sein.

VG emstade
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
02.02.2014, 21:53
Beitrag #18
RE: Probleme mit Sainsmart 16x2 Display
Hallo emstade,
hier die Pinconfig:
A0 Analogeingang für die Tasten
A2 Analogeingang PH Sonde
A3 Analogeingang Onboard Temp Fühler PH Shield
2,3,4,5,6,7 fürs Display mit Standart <LiquidCrystal.h>
8 Eichtaste am PH Shield
10 Hintergrundbeleuchtung Display
22,23,24,25,26,27,28,29 fürs Relaisboard
30 für den Temperaturfühler DS18S20
sollte keine Doppelbelegung vorhanden sein.

Das Display war früher direkt draufgesteckt, danach habe ich das Display in ein externes Bedienteil eingebaut mitsamt den Tasten. Die Kabel habe ich eins zu eins angelötet.

Arduino ist ein Sainsmart Mega

Was ich nicht habe die Sainsmart lib, ich hab die Standart liquidcrystal lib.
Das wäre mal ein Versuch wert, kann es leider nicht mehr probieren, da ich diese Woche beruflich in der Schweiz bin.

Danke
Gruss Christian
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
02.02.2014, 23:03
Beitrag #19
RE: Probleme mit Sainsmart 16x2 Display
(02.02.2014 21:53)spoernc schrieb:  Hallo emstade,
hier die Pinconfig:
A0 Analogeingang für die Tasten
A2 Analogeingang PH Sonde
A3 Analogeingang Onboard Temp Fühler PH Shield
2,3,4,5,6,7 fürs Display mit Standart <LiquidCrystal.h>
8 Eichtaste am PH Shield
10 Hintergrundbeleuchtung Display
22,23,24,25,26,27,28,29 fürs Relaisboard
30 für den Temperaturfühler DS18S20
sollte keine Doppelbelegung vorhanden sein.

Das Display war früher direkt draufgesteckt, danach habe ich das Display in ein externes Bedienteil eingebaut mitsamt den Tasten. Die Kabel habe ich eins zu eins angelötet.

Arduino ist ein Sainsmart Mega

Was ich nicht habe die Sainsmart lib, ich hab die Standart liquidcrystal lib.
Das wäre mal ein Versuch wert, kann es leider nicht mehr probieren, da ich diese Woche beruflich in der Schweiz bin.

Danke
Gruss Christian

Ich würde bei der Standardbibliothek bleiben.
Die Standard liquidcrystal.h und Beispielanschaltungen verwenden die D2-D5 und D11 - D12, warum hast du stattdessen D6 - D7 zur Steuerung der Übertragung ans Display benutzt?
Das Verhalten der Schirmung ist etwas merkwürdig. Das Timing beim schreiben/lesen des LCD kann durch die Verbindung des Schirms mit 0V durcheinander kommen. Der Schirm wirkt dann gegen die Signalleitung wie ein Kondensator von einigen pF mit dementsprechenden Signalverzögerungen.

Gruß emstade
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
03.02.2014, 05:46
Beitrag #20
RE: Probleme mit Sainsmart 16x2 Display
Im Zuge der Verkabelung des Displays habe ich die Ausgänge aufgeräumt.
Hat sonst keinen Grund.

Gruss Christian
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
03.02.2014, 09:41
Beitrag #21
RE: Probleme mit Sainsmart 16x2 Display
Hallo!

Die Pinbelegung vom LCD war ja durchs Shield vorgegeben.
Durch LiquidCrystal lcd( 8,9,4,5,6,7);
kannst beliebige Pins den Funktionen RS,EN,D4-D7 zuweisen..(reihenfolge beachten).

Die Freilaufdioden sind ja bereits auf der Karte...zudem gehts ja ohne Last.

Gibts bei der Verdrahtung unbenutzte Leiter ? "Reserven" immer beidseitig Erden.
Welche Leistungen werden geschaltet ?
Passiert der "Absturz" mit jedem Relais ?
Hast die Baugruppe schon mal mit einem Akku versorgt ?

mfg Martin
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
03.02.2014, 11:02
Beitrag #22
RE: Probleme mit Sainsmart 16x2 Display
(03.02.2014 09:41)P.Martin schrieb:  Hallo!

Die Pinbelegung vom LCD war ja durchs Shield vorgegeben.
Durch LiquidCrystal lcd( 8,9,4,5,6,7);
kannst beliebige Pins den Funktionen RS,EN,D4-D7 zuweisen..(reihenfolge beachten).

Die Freilaufdioden sind ja bereits auf der Karte...zudem gehts ja ohne Last.

Gibts bei der Verdrahtung unbenutzte Leiter ? "Reserven" immer beidseitig Erden.
Welche Leistungen werden geschaltet ?
Passiert der "Absturz" mit jedem Relais ?
Hast die Baugruppe schon mal mit einem Akku versorgt ?

mfg Martin

Hallo Martin,
die Pins habe ich sauberzugeordnet, ich denke sonst würde es gar nicht laufen.
jawohl die Freilaufdioden sind auf dem Relaisboard, das habe ich schon kontrolliert.

Freie Leiter zum Display gibts keine, zum Relaisboard schon.
Leistungen sind:
Relais 1: Bodenheizung 40W
Relais 2: Heizstab 300W
Relais 3: Leuchtstoffröhren 2x 58W
Relais 4: Leuchtstoffröhren 2x 58W
Relais 5: LED Mondlicht Steckernetzteil (Leistung unbekannt, aber wenig)
Relais 6: Dosierpumpe Steckernetzteil (Leistung unbekannt, aber wenig)
Relais 7: Dosierpumpe Steckernetzteil (Leistung unbekannt, aber wenig)
Relais 8: CO2 Ventil (Reserve)

Ja der Absturz passiert mit jedem Relais, auch beim abfallen des Relais.

Das mit dem Akku werde ich prüfen, wenn ich am Wochenende wieder zu Hause bin.

Danke
Gruss Christian
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
06.12.2014, 22:41
Beitrag #23
RE: Probleme mit Sainsmart 16x2 Display
*hochhol*

Ich habe das Ähnliche Problem mit einem ArduinoProMini, einem 1602 Display (Pins 2,3,4,5,6,7), einem OneWire an Pin 8, 3 Buttons an Pin 9,12,13 und genau wie oben ein Relaisboard von Saintsmart an Pin 10 und 11.

Die Absturz-Situation des Displays tritt nur auf wenn das Relais die 230V-Pumpe schaltet, im Leerlauf passiert das nicht. Die Steuerung arbeitet auch ganz normal weiter, nur das Display ist nicht zu erkennen.

Hat da noch jemand eine Idee? Schirmung des Displays ? Pufferelko ?
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
07.12.2014, 08:44
Beitrag #24
RE: Probleme mit Sainsmart 16x2 Display
Hallo...(hier könnte Dein Name stehen),
ich hab das Problem immer noch, weiss aber mittlerweile wo es herkommt.
Die Leiterbahn zum A1 des Relais verläuft zu nah an der Leiterbahn der Last.
Ich hab schon alles probiert, Elko, zwei verschiedene Netzteile, Schirmung usw..

Das für mich komische ist, es passiert nicht bei jedem schalten,
auch beim abfallen des Relais und vermehrt wenn in der zu schaltenden Steckdose ein Netzteil eingesteckt ist.
Es kann teilweise mehrere Tage funktionieren, teilweise stürzt es beim ersten schalten ab.
Wenn ich mal Zeit und Lust habe baue ich auf Solid state Relais um.

Gruss Christian
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
Antwort schreiben 


Möglicherweise verwandte Themen...
Thema: Verfasser Antworten: Ansichten: Letzter Beitrag
  Arduino Micro - Probleme madin 26 388 Gestern 15:55
Letzter Beitrag: Harry Hirsch
  Probleme mit dem FTDI-Chip Harry Hirsch 0 43 05.12.2016 14:53
Letzter Beitrag: Harry Hirsch
  Probleme mit ESP8266 BennIY 6 229 20.11.2016 14:49
Letzter Beitrag: BennIY
  Störungen auf LCD Display celle 11 438 05.11.2016 19:52
Letzter Beitrag: hotsystems
  Probleme mit mehreren DS18B20 Fühlern Uwa 12 331 15.10.2016 15:26
Letzter Beitrag: ardu_arne
  Probleme mit SIM900 GSM seit PinManagment test BennIY 0 175 31.07.2016 23:33
Letzter Beitrag: BennIY
  PiFace Control and Display am Arduino? Tueftler1971 1 228 12.06.2016 14:57
Letzter Beitrag: hotsystems
  Probleme mit dem Arduino Ethernet-Shild jalu4601 25 1.356 06.06.2016 16:09
Letzter Beitrag: Bitklopfer
Heart Bitte um Hilfe um auf Display Temperatur auzugeben Mischa 6 512 04.06.2016 20:49
Letzter Beitrag: hotsystems
  Probleme mit ws2812b Led stripes Gravia 5 726 04.06.2016 14:50
Letzter Beitrag: Digit_AL

Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste