INFO: Dieses Forum nutzt Cookies...
Cookies sind für den Betrieb des Forums unverzichtbar. Mit der Nutzung des Forums erklärst Du dich damit einverstanden, dass wir Cookies verwenden.

Es wird in jedem Fall ein Cookie gesetzt um diesen Hinweis nicht mehr zu erhalten. Desweiteren setzen wir Google Adsense und Google Analytics ein.

Antwort schreiben 
 
Themabewertung:
  • 0 Bewertungen - 0 im Durchschnitt
  • 1
  • 2
  • 3
  • 4
  • 5
Probleme mit Funkmodul E53-TTL-100
07.12.2019, 12:24 (Dieser Beitrag wurde zuletzt bearbeitet: 07.12.2019 13:13 von fluxkor.)
Beitrag #1
Probleme mit Funkmodul E53-TTL-100
Hat schon mal jemand eine Funkverbindung mit dem Modul E53-TTL-100 geschafft ?
Ich bekommen keinen Empfang Zustande.
Am Sendermodul habe ich dien PIN's VCC, GND u. TXD belegt,
am Empfänger VCC, GND, RXD.
Die Sketche dazu sind die hier erhältlichen.
Sendersketch:
Code:
// library
#include <VirtualWire.h>

void setup()
{
  Serial.begin(9600);

  // virtual wire
  vw_set_tx_pin(12); // pin
  vw_setup(2000);    // bps
}

void loop()
{
  sendString("Leer", true);
  delay(100);
}

void sendString(String message, bool wait)
{
  byte messageLength = message.length() + 1;

  // convert string to char array
  char charBuffer[messageLength];
  message.toCharArray(charBuffer, messageLength);

  vw_send((uint8_t *)charBuffer, messageLength);

  if (wait) vw_wait_tx();

  Serial.println("sent: " + message);
}
Empfängersketch:
Code:
// library
#include <VirtualWire.h>

byte message[VW_MAX_MESSAGE_LEN]; // a buffer to store the incoming messages
byte messageLength = VW_MAX_MESSAGE_LEN; // the size of the message

void setup()
{
  Serial.begin(9600);
  Serial.println("device is ready...");

  vw_set_rx_pin(12);
  vw_setup(2000); // bps
  vw_rx_start();
}

void loop()
{
    Serial.println("Warte auf Empfang...");
  if (vw_get_message(message, &messageLength)) // non-blocking
  {
    Serial.print("received: ");
    for (int i = 0; i < messageLength; i++)
    {
      Serial.write(message[i]);
    }
    Serial.println();
  }
}


Angehängte Datei(en)
.ino  Sender_868.ino (Größe: 579 Bytes / Downloads: 20)
.ino  Empf_nger_868.ino (Größe: 629 Bytes / Downloads: 16)
.pdf  E53-TTL-100_Datasheet-V10-1.pdf (Größe: 778,23 KB / Downloads: 25)
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
07.12.2019, 12:38 (Dieser Beitrag wurde zuletzt bearbeitet: 07.12.2019 12:41 von hotsystems.)
Beitrag #2
RE: Probleme mit Funkmodul E53-TTL-100
(07.12.2019 12:24)fluxkor schrieb:  Hat schon mal jemand eine Funkverbindung mit dem Modul E53-TTL-100 geschafft ?

Wenn du uns einen Link zum Funkmodul postest, können sicher mehr helfen.

Und poste deinen Sketch bitte hier in Code-Tags.
Wie das geht, steht hier.

Edit:
Wenn es das von mir vermutete Modul ist, musst du es seriell ansprechen.
Per Hardware oder Software Serial.

Gruß Dieter

I2C = weniger ist mehr: weniger Kabel, mehr Probleme. Cool
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
07.12.2019, 13:15
Beitrag #3
RE: Probleme mit Funkmodul E53-TTL-100
O.K. habe den Code u. die Anleitung des Funkmoduls angehängt.
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
07.12.2019, 13:48
Beitrag #4
RE: Probleme mit Funkmodul E53-TTL-100
(07.12.2019 13:15)fluxkor schrieb:  O.K. habe den Code u. die Anleitung des Funkmoduls angehängt.
Ok, wie ich es vermutete, du musst das Teil per serieller Schnittstelle ansprechen. So wie du es im Sketch machst, geht das def. nicht.
Dann brauchst du noch die genaue Info, welche Steuerbefehle du senden musst.
Auch evtl. für die notwendige Konfiguration des Moduls.

Gruß Dieter

I2C = weniger ist mehr: weniger Kabel, mehr Probleme. Cool
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
07.12.2019, 15:17
Beitrag #5
RE: Probleme mit Funkmodul E53-TTL-100
O.K. das hilft mir schon mal weiter.
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
07.12.2019, 15:20
Beitrag #6
RE: Probleme mit Funkmodul E53-TTL-100
Und je nachdem welchen Controller du verwendest, nimmst du Hardware oder SoftwareSerial.

Gruß Dieter

I2C = weniger ist mehr: weniger Kabel, mehr Probleme. Cool
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
Antwort schreiben 


Möglicherweise verwandte Themen...
Thema: Verfasser Antworten: Ansichten: Letzter Beitrag
Wink Probleme beim Senden und Empfangen von Daten svemueller 11 2.069 11.12.2019 14:52
Letzter Beitrag: svemueller
  NodeMCU V3 und TCA9538A Probleme daniel.s 10 1.609 01.12.2019 13:44
Letzter Beitrag: Tommy56
  Probleme mit USB-Port Herby007 4 2.284 05.08.2019 13:41
Letzter Beitrag: Tommy56
  immer wieder USB-Probleme AnFi 17 4.361 21.07.2019 19:42
Letzter Beitrag: hotsystems
  Pro Micro: SerialMonitor-Probleme AnFi 14 2.993 20.05.2019 16:10
Letzter Beitrag: AnFi
  Probleme mit 1,54" Oled von SPI auf i2c MasterOfPuppets 10 3.193 11.01.2019 12:54
Letzter Beitrag: Tommy56
  Probleme mit dem Arduino Ethernet-Shild jalu4601 46 16.024 26.12.2017 00:26
Letzter Beitrag: ArduTux
  SPI Probleme mit MCP25625 Cancontroller und MISO BennIY 15 3.517 15.05.2017 19:54
Letzter Beitrag: ardu_arne
  Arduino Micro - Probleme madin 65 19.104 07.01.2017 18:50
Letzter Beitrag: Harry Hirsch
  Probleme mit dem FTDI-Chip Harry Hirsch 13 5.191 15.12.2016 00:54
Letzter Beitrag: Harry Hirsch

Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste