INFO: Dieses Forum nutzt Cookies...
Cookies sind für den Betrieb des Forums unverzichtbar. Mit der Nutzung des Forums erklärst Du dich damit einverstanden, dass wir Cookies verwenden.

Es wird in jedem Fall ein Cookie gesetzt um diesen Hinweis nicht mehr zu erhalten. Desweiteren setzen wir Google Adsense und Google Analytics ein.

Antwort schreiben 
 
Themabewertung:
  • 0 Bewertungen - 0 im Durchschnitt
  • 1
  • 2
  • 3
  • 4
  • 5
Probleme mit ESP8266
09.06.2015, 20:55
Beitrag #1
Probleme mit ESP8266
Dies ist mein erster Beitrag. Servus zusammen!

Mein Ziel ist es, über WLAN mit einem Arduino UNO zu kommunizieren. Dieses ist an ein ESP8266 WLAN Modul angeschlossen und soll Relais Module schalten (z.B. Lampen).

Leider bin ich schon ganz am Anfang des Weges auf grosse Probleme gestossen. Das ESP8266 arbeitet nicht so wie es soll. Wie ich vorgegangen bin:

Ich habe das Arduino UNO per USB Kabel an meinen PC und per transmission lines (wie sagt man auf deutsch? ) an den ESP8266 angeschlossen. Dann habe ich den ESP mit einer aktuellen Firmware geflashed (ESP_8266_BIN0.92.bin), was auch gut funktioniert hat.

Anschliessend wollte ich mit dem Arduino Editor die AT Befehle testen - und ab hier funktioniert gar nichts mehr.

Wie ihr mir eventuell weiterhelfen könntet:
  • Kennt ihr eine step-by-step Anleitung bei der die AT Befehle ganz sicher funktionieren?
  • Ist die Firmware die Richtige?
  • Was sind so die häufig gemachten Fehler? Woran könnte es liegen, dass es nicht funktioniert?

Sobald das AT Problem gelöst ist, warten bestimmt noch etliche weitere Probleme auf uns - aber es wäre ein Schritt in die richtige Richtung! Für Eure Mithilfe schon mal einen lieben Dank!

LG,
giessbee
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
09.06.2015, 22:47
Beitrag #2
RE: Probleme mit ESP8266
(09.06.2015 20:55)giessbee schrieb:  Dies ist mein erster Beitrag. Servus zusammen!

Mein Ziel ist es, über WLAN mit einem Arduino UNO zu kommunizieren. Dieses ist an ein ESP8266 WLAN Modul angeschlossen und soll Relais Module schalten (z.B. Lampen).

Leider bin ich schon ganz am Anfang des Weges auf grosse Probleme gestossen. Das ESP8266 arbeitet nicht so wie es soll. Wie ich vorgegangen bin:

Ich habe das Arduino UNO per USB Kabel an meinen PC und per transmission lines (wie sagt man auf deutsch? ) an den ESP8266 angeschlossen. Dann habe ich den ESP mit einer aktuellen Firmware geflashed (ESP_8266_BIN0.92.bin), was auch gut funktioniert hat.

Anschliessend wollte ich mit dem Arduino Editor die AT Befehle testen - und ab hier funktioniert gar nichts mehr.

Wie ihr mir eventuell weiterhelfen könntet:
  • Kennt ihr eine step-by-step Anleitung bei der die AT Befehle ganz sicher funktionieren?
  • Ist die Firmware die Richtige?
  • Was sind so die häufig gemachten Fehler? Woran könnte es liegen, dass es nicht funktioniert?

Sobald das AT Problem gelöst ist, warten bestimmt noch etliche weitere Probleme auf uns - aber es wäre ein Schritt in die richtige Richtung! Für Eure Mithilfe schon mal einen lieben Dank!

LG,
giessbee
Ich gehe einfach mal davon aus das die Verkabelung stimmt.
Du musst auch für den Arduino ein Programm schreiben das die Daten die du vom PC an den USB Anschluss schickst weitergibt an die Pins an die du den ESP8266 angeschlossen hast. Dazu brauchst du auch Software Serial, such im Netz mal ein paar Beispiele dazu.

Gruß
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
Antwort schreiben 


Möglicherweise verwandte Themen...
Thema: Verfasser Antworten: Ansichten: Letzter Beitrag
  ESP8266 Agotto 0 93 06.04.2017 14:54
Letzter Beitrag: Agotto
  802.11n mit ESP8266 ( ESP01 / ESP12-F ) b3ta 5 271 19.02.2017 21:40
Letzter Beitrag: Tommy56
Lightbulb ESP8266 ESP-12E & BME280 Lurchi 7 548 26.01.2017 22:12
Letzter Beitrag: Tommy56
  Arduino Micro - Probleme madin 65 2.582 07.01.2017 18:50
Letzter Beitrag: Harry Hirsch
  Probleme mit dem FTDI-Chip Harry Hirsch 13 736 15.12.2016 00:54
Letzter Beitrag: Harry Hirsch
  Probleme mit ESP8266 BennIY 6 492 20.11.2016 14:49
Letzter Beitrag: BennIY
  Probleme mit mehreren DS18B20 Fühlern Uwa 12 722 15.10.2016 15:26
Letzter Beitrag: ardu_arne
  ESP8266-01 wird heiß ? cuteemo 5 637 20.08.2016 10:16
Letzter Beitrag: HDT
Question Arduino Uno und ESP8266 WLAN-HotSpot TeaAge 2 534 04.08.2016 11:56
Letzter Beitrag: TeaAge
  ESP8266-01 Problem mit UDP loglo 5 607 03.08.2016 07:49
Letzter Beitrag: loglo

Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste