INFO: Dieses Forum nutzt Cookies...
Cookies sind für den Betrieb des Forums unverzichtbar. Mit der Nutzung des Forums erklärst Du dich damit einverstanden, dass wir Cookies verwenden.

Es wird in jedem Fall ein Cookie gesetzt um diesen Hinweis nicht mehr zu erhalten. Desweiteren setzen wir Google Adsense und Google Analytics ein.

Antwort schreiben 
 
Themabewertung:
  • 0 Bewertungen - 0 im Durchschnitt
  • 1
  • 2
  • 3
  • 4
  • 5
Probleme mit Attiny85
18.07.2015, 16:24
Beitrag #1
Probleme mit Attiny85
Hallo zusammen !

Ich habe da ein kleines Problem mit einem Attiny85 den ich mir für einen kleinen RTW Wagen programmieren möchte
=> Blaulicht(4Kanal Lauflicht) und Frontblitzer(5.Kanal)
Habe dies auch schon erfolgreich per Ardublock auf einem Arduino laufenlassen, so wie ich es haben möchte (passt nur nicht ins Auto :coolSmile

So habe ich mich dran gesetzt und mir diverse Attinys bei Reichel bestellt, zum Einsatz soll halt der Attiny85 als SMD kommen.

Habe auch schon erfolgreich per Arduino/ISP das Blinkbeispiel und ein kleines Lauflichtprogramm am laufen gehbat am als 3 oder 4 Kanallauflicht.

Und hier fängt mein Problem an sobald ich PIN PB4 mit einbinde ins Programm läuft da garnix mehr Dodgy

Hat jemand vielleicht eine Ahnung warum dies so ist, habe hier im Forum auch nix gefunden was mir bei diesem Problem weiterhelfen könnte.

Ich benötige aber auch insgesamt 5 Ausgänge und PIN PB5 ist ja als Reset tabu sonst kann ich ja nix mehr draufschreiben bzw ändern.

Bin für jeden hilfreichen Vorschlag dankbar Rolleyes
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
18.07.2015, 18:37
Beitrag #2
RE: Probleme mit Attiny85
Danke für die schnelle Antwort !

das mit dem Charlieplexing hat was nur wenn ich das richtig gelesen habe können da nur die Led´s nach einander angehen.
Mein Programmablauf für den RTW ist das 1-4 nacheinander angehen und alle 4 kurz aufblitzen um vom neuen wieder vollzulaufen sage ich mal so Rolleyes

Habe aber jetzt den Fehler wohl gefunden es liegt nicht am Code sondern an der Hardware der blöde neue Tiny ist wohl auf PIN 4 defekt Dodgy

Mit einem anderen hat es sofort geklappt

Trotzdem danke für die Antwort
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
19.07.2015, 21:54
Beitrag #3
RE: Probleme mit Attiny85
eigentlich nicht, war ja nix großes angeschlossen ausser zu Testzwecken meine 6-Kanal Ledkontrollplatine und die auch erst immer nach dem brennen zum ausprobieren
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
20.07.2015, 05:26
Beitrag #4
RE: Probleme mit Attiny85
(19.07.2015 21:54)raubein01 schrieb:  eigentlich nicht, war ja nix großes angeschlossen ausser zu Testzwecken meine 6-Kanal Ledkontrollplatine und die auch erst immer nach dem brennen zum ausprobieren

6 LED'S und die alle nur aus dem einen Port gespeist ?
lgbk

1+1 = 10 Angel ...und ich bin hier nicht der Suchmaschinen-Ersatz Dodgy...nur mal so als genereller Tipp..
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
20.07.2015, 13:19 (Dieser Beitrag wurde zuletzt bearbeitet: 20.07.2015 13:19 von raubein01.)
Beitrag #5
RE: Probleme mit Attiny85
(20.07.2015 05:26)Bitklopfer schrieb:  
(19.07.2015 21:54)raubein01 schrieb:  eigentlich nicht, war ja nix großes angeschlossen ausser zu Testzwecken meine 6-Kanal Ledkontrollplatine und die auch erst immer nach dem brennen zum ausprobieren

6 LED'S und die alle nur aus dem einen Port gespeist ?
lgbk

da steht 6-Kanal nicht 6 Led´s an einem Port, die Platine lässt sich ganz einfach mit einer Stiftleiste auf´s Breadboard stecken und nach belieben anschließen zu Testzwecken jede Led einzeln Rolleyes

erspar ich mir das ganze stecken von Led´s und Widerständen weil alles auf der Platine schon kompakt zusammen gefasst ist
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
20.07.2015, 13:51
Beitrag #6
RE: Probleme mit Attiny85
also eine LED pro Port und mit Widerstand davor ?
Solange der R nicht deutlich kleiner wie 220R ist ist das unkritisch.
lgbk

1+1 = 10 Angel ...und ich bin hier nicht der Suchmaschinen-Ersatz Dodgy...nur mal so als genereller Tipp..
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
20.07.2015, 19:19
Beitrag #7
RE: Probleme mit Attiny85
(20.07.2015 13:51)Bitklopfer schrieb:  also eine LED pro Port und mit Widerstand davor ?
Solange der R nicht deutlich kleiner wie 220R ist ist das unkritisch.
lgbk

klar eine Led mit 220R pro Port und das ganze 6mal auf Lochraster zusammen mit Stiftleiste zum drauf stecken auf das Board


Jetzt läuft mein 4 Kanallauflicht auf dem Tiny sehr schön in dem Muster wie ich es haben will für meinen Rettungswagen, nur knobel ich jetzt daran den Frontblitzer noch einzubinden und zwar nahtlos

wie lasse ich zwei Unterprogramme gleichzeitig laufen und nicht in der loop Schleife hintereinander ?

Unterprogramm 1 benutzt 4 Pin´s für das Lauflicht
Unterprogramm 2 benutzt den 5. Pin für den Frontblitzer

nur durch das hintereinander abarbeiten ensteht eine Pause im Ablauf die nicht wirklich schön aussieht Confused

einer eine Ahnung wie ich so etwas in Ardublock löse ?
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
20.07.2015, 22:00
Beitrag #8
RE: Probleme mit Attiny85
Ardublock sagt mir nichts.
Aber beim Standart Arduino kannste einen Timerinterrupt für kleine Funktionen benutzen. Schau dir das mal an. Ob das auch auf dem Tiny funzt kann ich dir auch nicht garantieren weil der Tiny einen Timer weniger hat wie eine 328er CPU.
lgbk

1+1 = 10 Angel ...und ich bin hier nicht der Suchmaschinen-Ersatz Dodgy...nur mal so als genereller Tipp..
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
Antwort schreiben 


Möglicherweise verwandte Themen...
Thema: Verfasser Antworten: Ansichten: Letzter Beitrag
  Attiny85 bergfrei 3 135 17.11.2016 21:33
Letzter Beitrag: bergfrei
  ArduinoDroid Probleme Brother Tak 1 205 10.09.2016 22:12
Letzter Beitrag: Brother Tak
  mit Attiny85 Feuchtigkeitssensor auslesen toto1975 17 574 19.08.2016 22:40
Letzter Beitrag: hotsystems
  Roboter-Bau Probleme blebbens 8 379 12.07.2016 07:35
Letzter Beitrag: Binatone
  Probleme mit sprintf() und dtostrf() GMBU 11 815 22.06.2016 10:52
Letzter Beitrag: GMBU
  Makeblock mit Scratch programmieren- Probleme Keinen Schimmer 6 968 06.05.2016 18:34
Letzter Beitrag: arduinopeter
  Programme vom UNO auf nano , mini Pro portieren Probleme anwo 19 1.176 17.04.2016 21:12
Letzter Beitrag: hotsystems
  Probleme beim Auslesen eines IR Empfängers linuxpaul 7 574 06.03.2016 14:44
Letzter Beitrag: hotsystems
  Strombegrenzung mit ATTiny85 Chef_2 12 818 01.03.2016 16:53
Letzter Beitrag: Chef_2
  I²C vom NANO zum PI Probleme mit High/Low Bit Tobias1984 4 332 29.02.2016 00:00
Letzter Beitrag: hotsystems

Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste