INFO: Dieses Forum nutzt Cookies...
Cookies sind für den Betrieb des Forums unverzichtbar. Mit der Nutzung des Forums erklärst Du dich damit einverstanden, dass wir Cookies verwenden.

Es wird in jedem Fall ein Cookie gesetzt um diesen Hinweis nicht mehr zu erhalten. Desweiteren setzen wir Google Adsense und Google Analytics ein.

Antwort schreiben 
 
Themabewertung:
  • 0 Bewertungen - 0 im Durchschnitt
  • 1
  • 2
  • 3
  • 4
  • 5
Problem mit SD Card Library
05.10.2016, 20:37
Beitrag #1
Problem mit SD Card Library
Guten Abend,

ich habe ein Problem mit der SD Card Library von Arduino.

Ich versuche eine Textdatei mit dem Arduino auszulesen.
Ich benutze das Kartenmodul des 2.2" TFT Displays und habe dieses korrekt an den SPI meines Arduino UNO angeschlossen.

Die Karte ist mit FAT32 Formatiert. Ich lade das Programm "CardInfo" Auf den UNO.
Nun wird die Karte genau einmal erkannt. Nicht beim erneuten öffnen des Serial monitors.

Das Beispielprogramm Read/Write erkennt die Karte garnicht. Von der Verdrahtung muss alles korrekt sein, da die manchmal erkannt wird manchmal nicht.

Es handelt sich im eine SanDisk MicroSD 32GB im Adapter.



Ich habe noch eine Alte SD Karte mit 512 MB schreibgeschützt mit FAT16 formatiert dabei bekomme ich folgenden Fehler.
Could not find FAT16/FAT32 partition.\nMake sure you've formatted the card.

Nun ist das natürlich sehr unschön.
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
05.10.2016, 20:47
Beitrag #2
RE: Problem mit SD Card Library
Hi,
also ich meine mal wo gelesen zu haben das Karten über 4GB nicht von der Software angesprochen werden können. Ich selber verwende da nur 2GB Karten und damit gibt es keine Probleme. Ausser...man entfernt die Karte während dem das Programm läuft (wird natürlich vorher abgemeldet) und setzt sie dann wieder ein. Selbst wenn ich dann die SD-Init Routine wieder aufrufe gibt es keinen Zugriff auf die SD...nur ein Reset hilft da dann weiter... bzw. ein JMP 0 per Assemblerbefehl.
lgbk

1+1 = 10 Angel ...und ich bin hier nicht der Suchmaschinen-Ersatz Dodgy...nur mal so als genereller Tipp..
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
05.10.2016, 21:09 (Dieser Beitrag wurde zuletzt bearbeitet: 05.10.2016 21:09 von BennIY.)
Beitrag #3
RE: Problem mit SD Card Library
Um das richtig zu verstehen.
Ich renn morgen zum SD Karten händler und kauf ne karte nicht größer als 2GB
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
06.10.2016, 12:45
Beitrag #4
RE: Problem mit SD Card Library
Der Händler meiner Wahl hat keine Karten mit solch geringer Kapazität.

Also werde ich mir eine bestellen. Irgendwelche Empfehlungen?
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
06.10.2016, 18:38
Beitrag #5
RE: Problem mit SD Card Library
(06.10.2016 12:45)BennIY schrieb:  Der Händler meiner Wahl hat keine Karten mit solch geringer Kapazität.

Also werde ich mir eine bestellen. Irgendwelche Empfehlungen?

..SanDisk ist immer gut...
klapper doch mal einfach die üblichen Verdächtigen Elektro Märkte im Umkreis ab...irgendeiner wird schon noch so was Altertümliches ( 2 oder 4GB ) haben...
lgbk

1+1 = 10 Angel ...und ich bin hier nicht der Suchmaschinen-Ersatz Dodgy...nur mal so als genereller Tipp..
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
Antwort schreiben 


Möglicherweise verwandte Themen...
Thema: Verfasser Antworten: Ansichten: Letzter Beitrag
  Data Logger Daten auf SD Card schreiben Crichton 12 280 22.11.2016 18:32
Letzter Beitrag: Crichton
  Library unter Linux Mint installieren atmel900 1 81 22.11.2016 14:12
Letzter Beitrag: rkuehle
  Zahl von SD-Card Modul einlesen und Var. zuweisen Nafetz 13 294 28.10.2016 10:12
Letzter Beitrag: hotsystems
  Dallas Temp Library und LiquidCrystal_i2c relay 20 465 27.10.2016 12:20
Letzter Beitrag: hotsystems
  Problem mit SD.remove Eichner 6 210 22.08.2016 19:42
Letzter Beitrag: Eichner
  4x16 Tastermatrix Problem Michel 16 842 14.07.2016 10:02
Letzter Beitrag: StephanBuerger
  Problem mit Delay und Millis funnyzocker 1 454 26.06.2016 09:54
Letzter Beitrag: hotsystems
  Problem mit ESP8266 und EMail senden torsten_156 1 595 13.06.2016 21:14
Letzter Beitrag: torsten_156
  Wo kann ich hier noch Code spahren? (SPI-,Ethernet-,SD-,GSM-Library) avoid 4 377 05.06.2016 14:16
Letzter Beitrag: avoid
  ESP8266_01 flashen - Problem torsten_156 12 1.043 30.05.2016 20:12
Letzter Beitrag: torsten_156

Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste