INFO: Dieses Forum nutzt Cookies...
Cookies sind für den Betrieb des Forums unverzichtbar. Mit der Nutzung des Forums erklärst Du dich damit einverstanden, dass wir Cookies verwenden.

Es wird in jedem Fall ein Cookie gesetzt um diesen Hinweis nicht mehr zu erhalten. Desweiteren setzen wir Google Adsense und Google Analytics ein.

Antwort schreiben 
 
Themabewertung:
  • 0 Bewertungen - 0 im Durchschnitt
  • 1
  • 2
  • 3
  • 4
  • 5
Problem mit Kompassmodul HMC5883
08.01.2016, 15:31 (Dieser Beitrag wurde zuletzt bearbeitet: 08.01.2016 15:54 von arduinofan.)
Beitrag #9
RE: Problem mit Kompassmodul HMC5883
Ich habe eine Abweichung von 3 - 5 Grad.
Es geht von 0 - 360 Grad.

Die Formel zur Umrechnung kann auch evtl falsch sein.

In der Zip sind 4 Dateien. Ich habe den MEGA2560.

Arduino IDE 1.6.7

Gruss


Angehängte Datei(en)
.zip  hmc5883-3.zip (Größe: 3,57 KB / Downloads: 14)
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
10.01.2016, 10:32 (Dieser Beitrag wurde zuletzt bearbeitet: 10.01.2016 11:28 von torsten_156.)
Beitrag #10
RE: Problem mit Kompassmodul HMC5883
Hallo arduinofan,

ich habe die vier Scetche ausprobiert. Laufen tun sie, aber ich bekomme nur statische Werte. Ich nutze dazu keinen MEGA sondern meinen UNO. Verdrahtet habe ich ihn wie folgt:
3,3V & GND
SDA -> A4
SCL -> A5

Ich habe den Scetch 5883-1 aufgespielt. Er findet leider mein Kompassmodul nicht. Ich vermute mal das liegt an der verwendeten Adresse. Wie finde ich denn die richtige heraus?


Gruß
Torsten
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
10.01.2016, 12:26 (Dieser Beitrag wurde zuletzt bearbeitet: 10.01.2016 12:27 von arduinofan.)
Beitrag #11
RE: Problem mit Kompassmodul HMC5883
Die beiden müssten auch die Adressen wissen :
#include <Wire.h>
#include <HMC5883L.h>

--------------
ich bekomme nur statische Werte...
--------------
Was meinst du jetzt genau damit ?

Gruss
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
10.01.2016, 12:27
Beitrag #12
RE: Problem mit Kompassmodul HMC5883
...sind beide eingebundenHuh
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
10.01.2016, 12:31 (Dieser Beitrag wurde zuletzt bearbeitet: 10.01.2016 12:36 von arduinofan.)
Beitrag #13
RE: Problem mit Kompassmodul HMC5883

.zip  HMC5883L.zip (Größe: 4,77 KB / Downloads: 27) Pack diesen Compass-Demo-Ordner mal in den Ordner : d:\Arduino\libraries
Bei dir wahrscheinlich ein anderer Pfad.

Wire ist mit in der Arduino IDE 1.6.7


Hier gibt einen I"C-Scanner, der findet die Adressen von Modulen :

Gruss


Angehängte Datei(en)
.zip  I2C_Scanner.zip (Größe: 502 Bytes / Downloads: 16)
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
10.01.2016, 14:50
Beitrag #14
RE: Problem mit Kompassmodul HMC5883
Ich habe jetzt die Demo gestartet. Wie es aussieht, findet er das Kompassmodul. Ich erhalte allerding immer (fast) die gleichen Messwerte. Folgendes wird angezeigt:
Zitat:Raw: 932 1670 813 Scaled: 857.44 1536.40 747.96 Heading: 1.11 Radians 63.45 Degrees
Raw: 934 1670 813 Scaled: 859.28 1536.40 747.96 Heading: 1.11 Radians 63.40 Degrees

Wenn ich den Kompass bewege tut sich nichts an den Messwerten. Ich setze allerdings die IDE 1.6.5 ein. Aber daran sollte es doch nicht liegen.

Ich weis auch nicht, was ich noch am Code anpassen sollte???

Was bekommst du denn angezeigt?

Gruß
Torsten
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
10.01.2016, 21:19 (Dieser Beitrag wurde zuletzt bearbeitet: 10.01.2016 21:19 von arduinofan.)
Beitrag #15
RE: Problem mit Kompassmodul HMC5883
Nimm mal diese Datei, da wird nur das Haeding angezeigt.
Hab 3-5 Grad Abweichung und geht von 0 -360 Grad.

Gruss


Angehängte Datei(en)
.ino  hmc5883-heading.ino (Größe: 760 Bytes / Downloads: 23)
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
11.01.2016, 01:00
Beitrag #16
RE: Problem mit Kompassmodul HMC5883
Hallo,
ich werde es leider erst in einer Woche testen können. Bin jetzt erst mal im UrlaubBig Grin

Gruß
Torsten
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
Antwort schreiben 


Möglicherweise verwandte Themen...
Thema: Verfasser Antworten: Ansichten: Letzter Beitrag
Question Problem beim Hochladen auf AtTiny45. Hilfe -.- Jonas Lindenblatt 17 593 16.04.2017 12:58
Letzter Beitrag: Jonas Lindenblatt
  ESP8622 - 01 sendet UDP - Problem WLan Kriskind 37 2.851 14.03.2017 19:49
Letzter Beitrag: Tommy56
  Smart Home Webserver Basic Authentication Problem Osotastic 21 675 20.02.2017 18:00
Letzter Beitrag: Tommy56
  Problem mit Sketch senden an Uno feuerwehr 5 529 31.01.2017 20:41
Letzter Beitrag: Tommy56
  Beim Hochladen USB Problem Nils 10 773 29.12.2016 21:05
Letzter Beitrag: renid55
  Problem mit SD Card Library BennIY 4 458 06.10.2016 18:38
Letzter Beitrag: Bitklopfer
  Problem mit SD.remove Eichner 6 356 22.08.2016 19:42
Letzter Beitrag: Eichner
  4x16 Tastermatrix Problem Michel 16 1.233 14.07.2016 10:02
Letzter Beitrag: StephanBuerger
  Problem mit Delay und Millis funnyzocker 1 723 26.06.2016 09:54
Letzter Beitrag: hotsystems
  Problem mit ESP8266 und EMail senden torsten_156 1 1.078 13.06.2016 21:14
Letzter Beitrag: torsten_156

Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste