INFO: Dieses Forum nutzt Cookies...
Cookies sind für den Betrieb des Forums unverzichtbar. Mit der Nutzung des Forums erklärst Du dich damit einverstanden, dass wir Cookies verwenden.

Es wird in jedem Fall ein Cookie gesetzt um diesen Hinweis nicht mehr zu erhalten. Desweiteren setzen wir Google Adsense und Google Analytics ein.

Antwort schreiben 
 
Themabewertung:
  • 0 Bewertungen - 0 im Durchschnitt
  • 1
  • 2
  • 3
  • 4
  • 5
Problem mit KS0108 GLCD und Libary
13.02.2016, 09:43 (Dieser Beitrag wurde zuletzt bearbeitet: 13.02.2016 09:44 von amithlon.)
Beitrag #9
RE: Problem mit KS0108 GLCD und Libary
Hallo,

ich benutze die 1.6.7, die scheint stabil zu sein, davor die 1.6.5.
Zur 1.6.6 und 1.7.8 habe ich schon negatives gelesen.

Libs von GitHub als ZIP runterladen und über
Sketch->Bibliothek einbinden->.ZIP Bibliothek hinzufügen
direkt das ZIP-Archiv auswählen.

Das klappt meist problemlos oder gibt die Fehlermeldung, daß keine gültige Lib im Archiv gefunden wurde.
Wenn das passiert, die IDE schließen! und das ZIP von Hand entpacken und das Ergebnis anschauen. Da muß es eine <libname>.cpp und eine <libname>.h geben.
Einen Ordner im Sketchbook anlegen, der wie <libname> heißt und den Inhalt genau dieses Ordners, wo sich .cpp und .h befinden, dorthin kopieren.
Meist ist da noch ein Ordner examples und Dateien wie keywords.txt readme usw. bei, einfach alles mitkopieren.
Jetzt die IDE starten, wenn examples bei waren sind die jetzt unter dem Libnamen bei den Beispielen zu finden. Einfach eins laden und kompilieren, ob alles glatt geht.

Wenn nicht, eben in den leeren Sketch oben das inlude eintragen
#include <libname>
So wie angegeben, in spitzen Klammernn, keine Anführungszeichen, Groß-Klein beachten.
In spitzen Klammern sucht die IDE zurest in Sketchbook/libraries, dann im internen Arduino Lib-Ordner. In Anführungszeichen wird zuerst im aktuellen Projektordner gesucht.

Gruß aus Berlin
Michael
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
Antwort schreiben 


Möglicherweise verwandte Themen...
Thema: Verfasser Antworten: Ansichten: Letzter Beitrag
  SerialComInstruments 4 Problem Darstellung Nextero 35 411 Gestern 18:51
Letzter Beitrag: ElEspanol
  Problem mit Nema17 und A4988 Philthy 6 178 08.12.2017 12:35
Letzter Beitrag: Tommy56
  Arduino -> Controllino [Problem gelöst] Cyrilsneer 17 730 27.11.2017 18:49
Letzter Beitrag: Franz54
Question Problem beim seriellen Einlesen von RFID-Reader Bezel 5 314 05.11.2017 22:37
Letzter Beitrag: Tommy56
  NodeMCU 12E - Libary für Arduino für den Node kompatibel machen ? Stargazer 4 301 04.11.2017 17:36
Letzter Beitrag: Stargazer
  NeoPixels: Sketch will nicht - Problem mit delay? Zabsi 5 502 22.08.2017 15:17
Letzter Beitrag: Tommy56
  Problem mit LSM 303 Snörb 1 337 22.08.2017 14:16
Letzter Beitrag: Snörb
  Problem mit externem Interrupt manfred474 13 1.172 13.08.2017 08:54
Letzter Beitrag: MicroBahner
  Problem mit Klassen GuaAck 4 515 09.08.2017 09:28
Letzter Beitrag: MicroBahner
Question Problem mit TFT Sam217 8 892 20.07.2017 21:51
Letzter Beitrag: hotsystems

Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste