INFO: Dieses Forum nutzt Cookies...
Cookies sind für den Betrieb des Forums unverzichtbar. Mit der Nutzung des Forums erklärst Du dich damit einverstanden, dass wir Cookies verwenden.

Es wird in jedem Fall ein Cookie gesetzt um diesen Hinweis nicht mehr zu erhalten. Desweiteren setzen wir Google Adsense und Google Analytics ein.

Antwort schreiben 
 
Themabewertung:
  • 0 Bewertungen - 0 im Durchschnitt
  • 1
  • 2
  • 3
  • 4
  • 5
Problem mit KS0108 GLCD und Libary
13.02.2016, 09:43 (Dieser Beitrag wurde zuletzt bearbeitet: 13.02.2016 09:44 von amithlon.)
Beitrag #9
RE: Problem mit KS0108 GLCD und Libary
Hallo,

ich benutze die 1.6.7, die scheint stabil zu sein, davor die 1.6.5.
Zur 1.6.6 und 1.7.8 habe ich schon negatives gelesen.

Libs von GitHub als ZIP runterladen und über
Sketch->Bibliothek einbinden->.ZIP Bibliothek hinzufügen
direkt das ZIP-Archiv auswählen.

Das klappt meist problemlos oder gibt die Fehlermeldung, daß keine gültige Lib im Archiv gefunden wurde.
Wenn das passiert, die IDE schließen! und das ZIP von Hand entpacken und das Ergebnis anschauen. Da muß es eine <libname>.cpp und eine <libname>.h geben.
Einen Ordner im Sketchbook anlegen, der wie <libname> heißt und den Inhalt genau dieses Ordners, wo sich .cpp und .h befinden, dorthin kopieren.
Meist ist da noch ein Ordner examples und Dateien wie keywords.txt readme usw. bei, einfach alles mitkopieren.
Jetzt die IDE starten, wenn examples bei waren sind die jetzt unter dem Libnamen bei den Beispielen zu finden. Einfach eins laden und kompilieren, ob alles glatt geht.

Wenn nicht, eben in den leeren Sketch oben das inlude eintragen
#include <libname>
So wie angegeben, in spitzen Klammernn, keine Anführungszeichen, Groß-Klein beachten.
In spitzen Klammern sucht die IDE zurest in Sketchbook/libraries, dann im internen Arduino Lib-Ordner. In Anführungszeichen wird zuerst im aktuellen Projektordner gesucht.

Gruß aus Berlin
Michael
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
Antwort schreiben 


Möglicherweise verwandte Themen...
Thema: Verfasser Antworten: Ansichten: Letzter Beitrag
  Problem mit SD Card Library BennIY 4 193 06.10.2016 18:38
Letzter Beitrag: Bitklopfer
  Problem mit SD.remove Eichner 6 212 22.08.2016 19:42
Letzter Beitrag: Eichner
  4x16 Tastermatrix Problem Michel 16 846 14.07.2016 10:02
Letzter Beitrag: StephanBuerger
  Problem mit Delay und Millis funnyzocker 1 459 26.06.2016 09:54
Letzter Beitrag: hotsystems
  Problem mit ESP8266 und EMail senden torsten_156 1 602 13.06.2016 21:14
Letzter Beitrag: torsten_156
  ESP8266_01 flashen - Problem torsten_156 12 1.052 30.05.2016 20:12
Letzter Beitrag: torsten_156
  Hardwareserial/Softserial: Problem mit Superklasse tuxedo0801 10 482 19.05.2016 12:25
Letzter Beitrag: amithlon
  ESP8266 HTML Problem arduino_weatherstation 1 497 25.04.2016 21:52
Letzter Beitrag: rkuehle
  Problem mit OLED 0.96" Display torsten_156 3 542 03.04.2016 15:10
Letzter Beitrag: hotsystems
  Problem: SDFat - Das Ende einer Datei finden und Schleife beenden MartinK 4 490 01.04.2016 05:49
Letzter Beitrag: MartinK

Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste