INFO: Dieses Forum nutzt Cookies...
Cookies sind für den Betrieb des Forums unverzichtbar. Mit der Nutzung des Forums erklärst Du dich damit einverstanden, dass wir Cookies verwenden.

Es wird in jedem Fall ein Cookie gesetzt um diesen Hinweis nicht mehr zu erhalten. Desweiteren setzen wir Google Adsense und Google Analytics ein.

Antwort schreiben 
 
Themabewertung:
  • 0 Bewertungen - 0 im Durchschnitt
  • 1
  • 2
  • 3
  • 4
  • 5
Problem mit KS0108 GLCD und Libary
04.02.2016, 19:54
Beitrag #1
Problem mit KS0108 GLCD und Libary
Hallo,
ich möchte für mein Projekt ein GLCD verwenden, da mein 2-zeiliges Textdisplay zu wenig Zeichen darstellen kann. Jetzt habe ich mir ein Display 192x64 mit KS0108 Chipsatz bestellt. Ich habe auf der Seite: http://www.amateurfunkbasteln.de/arduino...index.html ein Bild zum Anschließen des Displays an den Arduino gefunden. Im Downloadbereich sollten eigentlich Beispiele und die Libary sein, es gibt aber nur die Beispiele. Jetzt habe ich im Netz hin und hergesucht nach einer passenden Libary für mein Grafikdisplay. Habe schon Glcd.h Version 3.5, die KS0108.h und U8glib.h runtergeladen und versucht einen Beispielsketch aus dem jeweiligen Ordner auszuprobieren, aber beim Kompilieren kommt jedesmal die Meldung, dass die Libary nicht gefunden wird.
Hat einer von euch so ein Display am Arduino laufen und kann mir weiterhelfen? Oder kann mir jemand sagen, woran es liegen könnte, dass ich die Libarys nicht zum Laufen bekomme?

Matthias
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
04.02.2016, 20:49 (Dieser Beitrag wurde zuletzt bearbeitet: 04.02.2016 20:50 von hotsystems.)
Beitrag #2
RE: Problem mit KS0108 GLCD und Libary
Ich vermute mal, du hast die Library nicht richtig installiert bzw. eingebunden.

Schau mal hier: https://www.arduino.cc/en/Guide/Libraries

oder: http://www.kriwanek.de/arduino/grundlage...aries.html

Evtl. musst du den Library-Ordnernamen auch anpassen. Der muss den selben Namen haben, wie die Library.

I2C = weniger ist mehr: weniger Kabel, mehr Probleme. Cool
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
09.02.2016, 19:49
Beitrag #3
RE: Problem mit KS0108 GLCD und Libary
Ich bin langsam echt am Verzweifeln. Ich habe nun sämtliche Grafik LCD Libarys, die ich gefunden habe ausprobiert, aber ich bekomme keine einzige über #include... ins Programm eingefügt. Jedesmal kommt die Fehlermeldung, dass die Libary nicht gefunden wird.
Ich habe es mit kopieren des Ordners in den Libaryordner probiert, über Libary hinzufügen auch. Keine Chance.
Mit meiner DHT und der DallasTemperature Libary hat es geklappt, aber ich bekomme keine Grafik LCD Libary hin.Momentan probiere ich es gerade mit der u8glib von
https://github.com/olikraus/u8glib

Kann mir vielleicht noch mal einer einen anfängertauglichen Tipp dazu geben?

Matthias Huh
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
09.02.2016, 22:12
Beitrag #4
RE: Problem mit KS0108 GLCD und Libary
(09.02.2016 19:49)MKnet83 schrieb:  Ich bin langsam echt am Verzweifeln.
Kann mir vielleicht noch mal einer einen anfängertauglichen Tipp dazu geben?
Dann solltest du uns mal die Fehlermeldungen posten.

So sind wir nur am raten. Huh

I2C = weniger ist mehr: weniger Kabel, mehr Probleme. Cool
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
10.02.2016, 17:08
Beitrag #5
RE: Problem mit KS0108 GLCD und Libary
Ich habe jetzt nur mal einen leeren Sketch genommen, die "DHT.h" eingefügt und kompiliert - funktioniert.
Als nächstes versucht über "Sketch - Bibliothek importieren - u8glib" die "U8glib.h" einzufügen - es wird nur eine leere Zeile im Sketch eingefügt.
Also die "U8glib.h" per Hand in den Sketch geschrieben und kompiliert - ergibt folgende Fehlermeldung:

Arduino: 1.7.8 (Windows 8.1), Platine: "Arduino Mega or Mega 2560, ATmega2560 (Mega 2560)"

sketch_feb10a.ino:1:20: fatal error: U8glib.h: No such file or directory

compilation terminated.

Fehler beim Kompilieren.



Das gleiche ist mir auch mit GLCD und K0108 passiert. Ich bekomme keine GLCD-Bibliothek zum Laufen.

Matthias
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
10.02.2016, 17:56
Beitrag #6
RE: Problem mit KS0108 GLCD und Libary
(10.02.2016 17:08)MKnet83 schrieb:  folgende Fehlermeldung:

sketch_feb10a.ino:1:20: fatal error: U8glib.h: No such file or directory
Das klingt ganz nach fehlender oder falscher Library.
Hast du den Ordner auch richtig benannt?
Vielfach muss man den umbenennen, so wie die Lib heißt.

I2C = weniger ist mehr: weniger Kabel, mehr Probleme. Cool
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
12.02.2016, 17:48
Beitrag #7
RE: Problem mit KS0108 GLCD und Libary
(10.02.2016 17:56)hotsystems schrieb:  
(10.02.2016 17:08)MKnet83 schrieb:  folgende Fehlermeldung:

sketch_feb10a.ino:1:20: fatal error: U8glib.h: No such file or directory
Das klingt ganz nach fehlender oder falscher Library.
Hast du den Ordner auch richtig benannt?
Vielfach muss man den umbenennen, so wie die Lib heißt.

Ich habe die Libary bei https://github.com/olikraus/u8glib heruntergeladen. Das ist die einzige Quelle, die ich gefunden habe - wird auch öfters darauf verwiesen. Ich habe den Libary Ordner in U8glib umbenannt. Die Lib heißt auch so. Habe extra noch einen src-Ordner drinn angelegt, in den ich die *.h und die *.cpp reinkopiert habe. Habe die beiden Dateien auch noch in einen anderen Unterordner reinkopiert, in dem sich Libary Dateien befinden. Die Lib ist also mehrmals an verschiedenen Orten vorhanden, wird aber an keinem einzigen erkannt.
Wie erkenne ich denn, ob eine Lib funktioniert oder nicht? Wenn sie nicht funktionieren würde, würde sie doch wahrscheinlich nicht dort zum Download stehen, oder? Hat jemand eine funktionierende Lib oder kann mir da so noch einen Rat geben? Ich bin doch bestimmt nicht der einzige, der so ein Display nutz.

Matthias
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
12.02.2016, 20:38
Beitrag #8
RE: Problem mit KS0108 GLCD und Libary
(12.02.2016 17:48)MKnet83 schrieb:  Ich habe die Libary bei https://github.com/olikraus/u8glib heruntergeladen.
Ich glaube nicht, dass es an der Library liegt. Ich verwende die auch, allerdings mit einem anderen Display.

Entweder da ist noch ein Fehler in der Einrichtung der Lib oder die IDE macht Fehler.
Ich verwende hier die 1.6.5 und habe keinerlei Probleme.

Kannst du mal einen Screenshot posten, wie der Library-Ordner bei dir eingebunden ist. Das hört sich nach deiner Beschreibung seltsam an.

I2C = weniger ist mehr: weniger Kabel, mehr Probleme. Cool
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
Antwort schreiben 


Möglicherweise verwandte Themen...
Thema: Verfasser Antworten: Ansichten: Letzter Beitrag
  Problem mit SD Card Library BennIY 4 186 06.10.2016 18:38
Letzter Beitrag: Bitklopfer
  Problem mit SD.remove Eichner 6 210 22.08.2016 19:42
Letzter Beitrag: Eichner
  4x16 Tastermatrix Problem Michel 16 832 14.07.2016 10:02
Letzter Beitrag: StephanBuerger
  Problem mit Delay und Millis funnyzocker 1 453 26.06.2016 09:54
Letzter Beitrag: hotsystems
  Problem mit ESP8266 und EMail senden torsten_156 1 593 13.06.2016 21:14
Letzter Beitrag: torsten_156
  ESP8266_01 flashen - Problem torsten_156 12 1.040 30.05.2016 20:12
Letzter Beitrag: torsten_156
  Hardwareserial/Softserial: Problem mit Superklasse tuxedo0801 10 474 19.05.2016 12:25
Letzter Beitrag: amithlon
  ESP8266 HTML Problem arduino_weatherstation 1 491 25.04.2016 21:52
Letzter Beitrag: rkuehle
  Problem mit OLED 0.96" Display torsten_156 3 534 03.04.2016 15:10
Letzter Beitrag: hotsystems
  Problem: SDFat - Das Ende einer Datei finden und Schleife beenden MartinK 4 486 01.04.2016 05:49
Letzter Beitrag: MartinK

Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste