INFO: Dieses Forum nutzt Cookies...
Cookies sind für den Betrieb des Forums unverzichtbar. Mit der Nutzung des Forums erklärst Du dich damit einverstanden, dass wir Cookies verwenden.

Es wird in jedem Fall ein Cookie gesetzt um diesen Hinweis nicht mehr zu erhalten. Desweiteren setzen wir Google Adsense und Google Analytics ein.

Antwort schreiben 
 
Themabewertung:
  • 0 Bewertungen - 0 im Durchschnitt
  • 1
  • 2
  • 3
  • 4
  • 5
Problem mit Folientatstatur
12.05.2015, 15:55 (Dieser Beitrag wurde zuletzt bearbeitet: 12.05.2015 15:55 von Tomodachi.)
Beitrag #9
RE: Problem mit Folientatstatur
(12.05.2015 14:00)Bitklopfer schrieb:  
(12.05.2015 13:50)Tomodachi schrieb:  
(12.05.2015 06:54)Bitklopfer schrieb:  ...au da ist mal wieder einer Beratungsresistent...wie ich schon im Beitrag #3 geschrieben hatte....das einfachste wurde mal wieder nicht überprüft...
Aber mit Librarys um sich schmeißen wo man keine braucht...LOL...

Wenn ich gemeint war mit "beratungsresistent", dann habe ich offensichtlich einen Hinweis nicht verstanden. Ich HABE doch nun alle Buchsen an den Arduino angeschlossen. Der ganz rechte war offensichtlich nicht ground, sonst hätte es funktioniert. Dass eine Buchse aus der Mitte zu ground führen soll erscheint mir nicht sinnvoll/logisch/so gewollt.

Den Schaltplan habe ich im Web auch nicht finden können.
Also was kann man noch tun ??
Bin Huh

...ja wer denn sonst Huh
ist ja egal welcher Pin der Gemeinsame ist...aber einer MUSS es ja sein...dann müßten dagegen sich alle per Tastendruck kurzschliesen lassen. Haste das schon überprüft ?

Also, so weit ich Dir folgen kann fragst Du, ob alle Tasten HIGH ergeben: Ja das machen sie. War es anders gemeint, versteh ich noch zu wenig davon, um korrekter zu antworten.

(12.05.2015 14:08)t.a.f.k.a.Z. schrieb:  und zum dritten Mal:
"ausklingeln" (elektrisch messen)

Dafür hab ich leider keine Geräte.
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
12.05.2015, 18:36
Beitrag #10
RE: Problem mit Folientatstatur
(12.05.2015 15:59)t.a.f.k.a.Z. schrieb:  Spannungsversorgung - LED und Vorwiderstand auf Steckbrett - 2 lange Kabel
OK, klingelt zwar nicht, könnte man aber als "ausleuchten" bezeichnen;
ganz wichtig: Hirn einschalten Tongue

(Randbemerkung: langsam komme ich mir veralbert vor)

Vielleicht stellst Du Dir einfach vor, dass ich zum ersten Mal mit Elektronik in Kontakt gekommen bin. Einerseits dürfte es logisch sein, dass ich dann verschiedentlich "angedeutete" Hinweise nicht interpretieren kann, da nützt auch nicht der Vorwurf "Hirn einschalten", wenn das Wissen dafür gar nicht vorhanden ist.
Und sei vergewissert, ich kann mein Hirn einschalten, aber bislang eben in anderen Bereichen des Lebens und ich wollte meinen Horizont erweitern.

Ich muss mich nicht anmachen lassen, dass ich Dich veralbern würde!
Ich denke, dass Du z. B. in rechtlichen Dingen, wenns drauf ankommt, auch zu einem Experten gehst, um Dich beraten zu lassen. Ich hoffe, Du kommst mal zu mir, dass ich Dir sagen kann: Steht doch alles im Gesetz, musst nur lesen!

Danke für Deine Mühen, aber herunter putzen lassen muss ich mich nicht.
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
12.05.2015, 19:01
Beitrag #11
RE: Problem mit Folientatstatur
Hi,
ok, jetzt versuch ich's mal.
Doch, Du hast ein Gerät, um das Ding durchzumessen: Einen Arduino!
Ich würde jetzt folgendermaßen vorgehen: Schließe mal einen der ganz äußeren Pins auf GND und alle anderen auf irgendwelche Ports. Außerdem schreib' Dir mal einen Sketch (ganz ohne jegliche Library), der folgendes macht:
1. Die angeschlossenen Pins mit INPUT_PULLUP als Input mit Pullup-Widerstand schalten.
2. Einmal pro Sekunde (oder von mir aus auch dauernd) alle Pins abfragen und das Ergebnis per Serial.print ausgeben.
Lass das laufen und drück dann nacheinander langsam alle Tasten.
Du solltest dann sehen, dass sich in der Ausgabe was tut. Falls Du zufällig den richtigen Anschluss für GND genommen hast, dann sieht man direkt welche Taste an welchem Pin hängt. Ansonsten sollte man genau für eine Taste eine Reaktion feststellen können. Dann ist das, was an dem Pin hängt, eigentlich die gemeinsame Leitung und die vermutete gemeinsame Leitung ist die für die Taste.
Wenn das nicht so ist, dann sind entweder irgendwelche Dioden verbaut oder irgendwas ist kaputt. ...oder die Vermutung, wie die Leitungen verlaufen, ist komplett quatsch.
Gruß,
Thorsten

Falls ich mit einer Antwort helfen konnte, wuerde ich mich freuen, ein paar Fotos oder auch ein kleines Filmchen des zugehoerigen Projekts zu sehen.
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
12.05.2015, 19:07 (Dieser Beitrag wurde zuletzt bearbeitet: 12.05.2015 19:08 von Tomodachi.)
Beitrag #12
RE: Problem mit Folientatstatur
Hi und danke für Deine ausführliche Anleitung.
Ich werde mich da mal durchkämpfen und hoffentlich schon am Wochenende neue Erkenntnisse liefern können Big Grin
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
12.05.2015, 22:13
Beitrag #13
RE: Problem mit Folientatstatur
Wink ok
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
Antwort schreiben 


Möglicherweise verwandte Themen...
Thema: Verfasser Antworten: Ansichten: Letzter Beitrag
  Problem mit Fingerprinter mgm099 2 201 11.06.2018 14:05
Letzter Beitrag: hotsystems
  PWM Problem, Ventilator macht Geräusche malsehen 8 771 25.02.2018 20:16
Letzter Beitrag: malsehen
  Schrittmotor a4988 Problem iceweasel7 15 1.590 02.01.2018 16:16
Letzter Beitrag: iceweasel7
  Servo Problem Winkel ansteuerung HaiAusDerDOse 7 784 22.09.2017 16:34
Letzter Beitrag: MicroBahner
  Anfänger Problem Lil-De 3 995 16.08.2017 09:47
Letzter Beitrag: Enno62
Bug Hardware Problem (!) Gandalf 34 3.706 06.11.2016 07:29
Letzter Beitrag: Pardini
  Arduino Esplora und Medion Life-Tab P9516, Problem mit usb-Schnittstelle MSchroeder 2 651 15.10.2016 22:18
Letzter Beitrag: MSchroeder
  Problem mit adafruit motor shield Philthy 13 3.834 22.12.2015 15:27
Letzter Beitrag: hotsystems
  Bootloader/Port/Programmer Problem mit altem Diecimila HaWe 7 2.621 29.07.2015 13:10
Letzter Beitrag: HaWe
  FTDI FT232R Problem BennIY 5 2.664 07.07.2015 22:38
Letzter Beitrag: BennIY

Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste