INFO: Dieses Forum nutzt Cookies...
Cookies sind für den Betrieb des Forums unverzichtbar. Mit der Nutzung des Forums erklärst Du dich damit einverstanden, dass wir Cookies verwenden.

Es wird in jedem Fall ein Cookie gesetzt um diesen Hinweis nicht mehr zu erhalten. Desweiteren setzen wir Google Adsense und Google Analytics ein.

Antwort schreiben 
 
Themabewertung:
  • 0 Bewertungen - 0 im Durchschnitt
  • 1
  • 2
  • 3
  • 4
  • 5
Problem mit DMX senden
31.01.2016, 21:37 (Dieser Beitrag wurde zuletzt bearbeitet: 31.01.2016 22:25 von ardu_arne.)
Beitrag #1
Bug Problem mit DMX senden
Hallo zusammen,

ich möchte versuchen mit meinem AVR DMX zu senden. Ich benutze ein Arduino Mega 2560 und die Arduino IDE 1.6.7.

Ich benutze den Quellcode und die Schaltung für die RS-485 Übertragung von Ulrich Radig.

http://www.ulrichradig.de/home/index.php.../avr---dmx

Den Quellcode habe ich auf den ATMega2560 angepasst, jedoch tut sich am Ausgang garnichts.

Im Anhang ist ein Bild der Schaltung. Das einzige was ich nicht gemacht habe ist dass ich keine 22 Ohm Widerstände benutzt habe, da ich keine da habe. Kann es daran liegen?
Hier das Bild
http://www2.pic-upload.de/img/29604073/sende-Kopie.jpg
Ansonsten hier der Quellcode:

Code:
#include <avr/interrupt.h>
#include <avr/io.h>
#include <stdio.h>

#define F_CPU 16000000
#include <util/delay.h>

#define DMX_BAUD 250000
#define DMX_BAUD_BREAK 80000
#define DMX_BAUD_BREAK_UBBR ((F_CPU+DMX_BAUD_BREAK*8)/(DMX_BAUD_BREAK*16)-1)
#define DMX_BAUD_UBBR ((F_CPU+DMX_BAUD*8)/(DMX_BAUD*16)-1)


volatile unsigned char dmx_buffer[512];


//############################################################################
//DMX Senderoutine
ISR (USART_TX_vect)
//############################################################################
{
  static unsigned int  dmx_channel_tx_count = 0;
  static unsigned char dmx_tx_state = 0;
  
  switch (dmx_tx_state)
  {
    case (0):
      UBRR0   = DMX_BAUD_BREAK_UBBR;
      UDR0 = 0; //RESET Frame
      dmx_tx_state = 1;
      break;

    case (1):
      UBRR0   = DMX_BAUD_UBBR;
      UDR0 = 0; //Start Byte
      dmx_tx_state = 2;
      break;

    case (2):
      _delay_us(10);
      //Ausgabe des Zeichens
      UDR0 = dmx_buffer[dmx_channel_tx_count];
      dmx_channel_tx_count++;
      
      if(dmx_channel_tx_count == 512)
      {
        dmx_channel_tx_count = 0;
        dmx_tx_state = 0;
      }
      break;
  }
}

void setup() {
//Init usart DMX-BUS
UBRR0   = DMX_BAUD_UBBR;
  DDRE |= (1<<PE1); //Output TXD Pin ATmega2560
  UCSR0B|=(1<<TXEN0)|(1<<TXCIE0); // TXEN0 Transmitter enable / TXCIE0 TX complete interrupt enable
  UCSR0C|=(1<<USBS0); //USBS0 2 Stop bits
  sei();//Globale Interrupts Enable
  UDR0 = 0;//Start DMX

}

void loop() {
  // put your main code here, to run repeatedly:
    dmx_buffer[4]=255;
    _delay_ms(1000);
    dmx_buffer[5]=255;
     _delay_ms(1000);
    dmx_buffer[6]=255;
    _delay_ms(1000);
    dmx_buffer[4]=0;
    _delay_ms(1000);
    dmx_buffer[5]=0;
     _delay_ms(1000);
    dmx_buffer[6]=0;
     _delay_ms(1000);

}

Edit: Codebereich formatiert
Gruß Arne
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
31.01.2016, 23:06
Beitrag #2
RE: Problem mit DMX senden
Hallo und herzlich willkommen.

Vermutlich funktioniert es nicht weil du TX0 zum senden verwendest.
RX0 und TX0 wird beim Arduino standardmäßig für die Kommunikation mit dem PC über USB verwendet.
Beim MEGA hast du aber noch drei weitere serielle Ports auf die du ausweichen kannst.

Gruß
Arne

Gruß Arne
ExclamationMit zunehmender Anzahl qualifizierter Informationen bei einer Problemstellung, erhöht sich zwangsläufig die Gefahr auf eine zielführende Antwort.Exclamation
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
31.01.2016, 23:20 (Dieser Beitrag wurde zuletzt bearbeitet: 31.01.2016 23:22 von Helyx.)
Beitrag #3
RE: Problem mit DMX senden
(31.01.2016 23:06)ardu_arne schrieb:  Hallo und herzlich willkommen.

Vermutlich funktioniert es nicht weil du TX0 zum senden verwendest.
RX0 und TX0 wird beim Arduino standardmäßig für die Kommunikation mit dem PC über USB verwendet.
Beim MEGA hast du aber noch drei weitere serielle Ports auf die du ausweichen kannst.

Gruß
Arne

Danke danke.

Aaaaaah ja das macht Sinn.

SUPER Vielen Dank.

Saß da echt lange dran.
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
Antwort schreiben 


Möglicherweise verwandte Themen...
Thema: Verfasser Antworten: Ansichten: Letzter Beitrag
  Bootloader update mit USBASP Problem sepp01 15 559 12.05.2018 17:23
Letzter Beitrag: sepp01
  C++ Library Datenübergabe Problem jose_ph 9 339 08.05.2018 14:10
Letzter Beitrag: Tommy56
  Problem mit der Textauswertung Franz54 13 479 15.04.2018 18:17
Letzter Beitrag: Tommy56
  Problem mit RIFD UID ParadoxDev 6 295 27.03.2018 12:04
Letzter Beitrag: ParadoxDev
  Problem mit OLED 0.96" Display torsten_156 5 1.803 07.03.2018 23:27
Letzter Beitrag: Tommy56
  Ucglib Library Problem Bully 26 1.177 05.03.2018 18:47
Letzter Beitrag: Tommy56
  UDP Paket über UART senden (nicht SPI) Wampo 9 641 04.03.2018 18:49
Letzter Beitrag: Tommy56
  Problem mit Wire.available() abfrage avoid 1 377 11.01.2018 13:40
Letzter Beitrag: Tommy56
  SerialComInstruments 4 Problem Darstellung Nextero 35 1.582 15.12.2017 18:51
Letzter Beitrag: ElEspanol
Information DHT 22 Daten per 433 Mhz senden Niklas 5 792 10.12.2017 17:15
Letzter Beitrag: hotsystems

Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste