INFO: Dieses Forum nutzt Cookies...
Cookies sind für den Betrieb des Forums unverzichtbar. Mit der Nutzung des Forums erklärst Du dich damit einverstanden, dass wir Cookies verwenden.

Es wird in jedem Fall ein Cookie gesetzt um diesen Hinweis nicht mehr zu erhalten. Desweiteren setzen wir Google Adsense und Google Analytics ein.

Antwort schreiben 
 
Themabewertung:
  • 0 Bewertungen - 0 im Durchschnitt
  • 1
  • 2
  • 3
  • 4
  • 5
Problem mit Arduino
03.07.2018, 20:15
Beitrag #1
Problem mit Arduino
hallo ich bin noch anfänger. ich benutze einen einfache Programierung das eine led per taster leuchtet.
Code:
int ledPin = 7;
int tasterPin = 11;

void setup(){
  pinMode(ledPin,OUTPUT);
  pinMode(tasterPin,INPUT);
}

void loop(){
  if (digitalRead(tasterPin)==HIGH){
    digitalWrite(ledPin, HIGH);
  } else {
    digitalWrite(ledPin, LOW);
  }
}
ich habe jetzt einfach die kabel vom taster abgezogen und nur wen ich das kabel von pin 11 berühre leuchte die led hin und wieder und machmal auch länger, immer was anderes. sollte die led nicht erst leuchten wen pin 11 ein impuls vom 5V pin kriegt oder bin ich da jetzt falsch? würde mich auf eure hilf freuen
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
03.07.2018, 20:23 (Dieser Beitrag wurde zuletzt bearbeitet: 03.07.2018 20:24 von Tommy56.)
Beitrag #2
RE: Problem mit Arduino
Warum steht das in sonstiges? Egal, es kann heute sowieso ja keiner mehr eine Subforenüberschrift lesen.

Ein offener Kontakt wirkt wie eine Antenne und fängt alles (un)mögliche ein.

Wenn Du HIGH als gedrückt werten willst, brauchst Du einen externen Pulldown-Widerstand vom Eingang gegen GND.

Ansonsten benutze den internen Pullup mit
Code:
pinMode(tasterPin,INPUT_PULLUP);
Schalte den Taster gegen GND und frage ihn gegen LOW ab:
Code:
if (digitalRead(tasterPin)==LOW)

Gruß Tommy

"Wer den schnellen Erfolg sucht, sollte nicht programmieren, sondern Holz hacken." (Quelle unbekannt)
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
06.07.2018, 22:09
Beitrag #3
RE: Problem mit Arduino
...habs hierher gesetzt weil es doch eher ein Hardwarproblem ist was da ansteht.
lgbk

1+1 = 10 Angel ...und ich bin hier nicht der Suchmaschinen-Ersatz Dodgy...nur mal so als genereller Tipp..
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
Antwort schreiben 


Möglicherweise verwandte Themen...
Thema: Verfasser Antworten: Ansichten: Letzter Beitrag
  Problem mit Fingerprinter mgm099 2 309 11.06.2018 14:05
Letzter Beitrag: hotsystems
  PWM Problem, Ventilator macht Geräusche malsehen 8 836 25.02.2018 20:16
Letzter Beitrag: malsehen
  Schrittmotor a4988 Problem iceweasel7 15 1.691 02.01.2018 16:16
Letzter Beitrag: iceweasel7
  Servo Problem Winkel ansteuerung HaiAusDerDOse 7 846 22.09.2017 16:34
Letzter Beitrag: MicroBahner
  Anfänger Problem Lil-De 3 1.038 16.08.2017 09:47
Letzter Beitrag: Enno62
Bug Hardware Problem (!) Gandalf 34 3.841 06.11.2016 07:29
Letzter Beitrag: Pardini
  Arduino Esplora und Medion Life-Tab P9516, Problem mit usb-Schnittstelle MSchroeder 2 684 15.10.2016 22:18
Letzter Beitrag: MSchroeder
  Problem mit adafruit motor shield Philthy 13 3.941 22.12.2015 15:27
Letzter Beitrag: hotsystems
  Bootloader/Port/Programmer Problem mit altem Diecimila HaWe 7 2.716 29.07.2015 13:10
Letzter Beitrag: HaWe
  FTDI FT232R Problem BennIY 5 2.740 07.07.2015 22:38
Letzter Beitrag: BennIY

Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste