INFO: Dieses Forum nutzt Cookies...
Cookies sind für den Betrieb des Forums unverzichtbar. Mit der Nutzung des Forums erklärst Du dich damit einverstanden, dass wir Cookies verwenden.

Es wird in jedem Fall ein Cookie gesetzt um diesen Hinweis nicht mehr zu erhalten. Desweiteren setzen wir Google Adsense und Google Analytics ein.

Antwort schreiben 
 
Themabewertung:
  • 0 Bewertungen - 0 im Durchschnitt
  • 1
  • 2
  • 3
  • 4
  • 5
Problem mit 3x3x3 LED Würfel
30.04.2014, 10:58
Beitrag #9
RE: Problem mit 3x3x3 LED Würfel
Hallo!
Geht sicher, wenn du immer nur die Leds einer Ebene betreibst.
Die Vorwiderstände sind auf eine Led ausgelegt
Beim zuschalten einer zweiten Ebene müssen sich die Leds den Strom teilen,
leuchten nur noch schwach oder gar nicht.

..jede Led einen eigenen Vorwiderstand und ein Transistor oder Mosfet für
die 3 Leds einer Gruppe plus 3 Transistoren für die Ebenen.
Dann könnte man alle Leds voll leuchten lassen.
Für sporadisches Flackern passt die Schaltung.

mfg Martin
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
30.04.2014, 11:09
Beitrag #10
RE: Problem mit 3x3x3 LED Würfel
Jetzt zu Busmasters Schaltung:
Ich denke, das ist besser. Die Transistoren haben einen Vorwiderstand.
Du schreibst, blaue LEDs mit einer Vorwaertsspannung von 3,2V. Ich habe mal nachgesehen und gefunden, dass blaue eine Spannung von 3,4-4V haben. Gehen wir mal von 3,2V aus, um sicher zu gehen. Um das Board nicht zu ueberlasten, gehen wir mal von 20mA pro Pin aus. Dann ergibt sich fuer den Vorwiderstand der LEDs:
(5V - 3,2V) / 20mA = 90Ohm
D.h. tiefer als 90Ohm wuerde ich nicht gehen.

Die Sache ist nur die (bei beiden Schaltungen): Wenn alle drei LEDs an sind, die an einem gemeinsamem Widerstand haengen, dann muessen sie sich den Strom teilen. D.h. jede bekommt nur ungefaehr 7mA. Den Widerstand zu verkleinern bringt's jetzt aber nicht wirklich, da es auch vorkommt, dass nur eine LED an ist. Diese wuerde dann zu viel Strom abbekommen.

Eigentlich sollte also jede LED ihren Widerstand haben. Dann sollte man aber nicht ueber 7mA pro LED gehen (da sonst die Ports nicht mitmachen). Er ergibt sich also:
(5V - 3,2V) / 7mA = 257Ohm
...oder lieber etwas mehr, je nachdem was der naechste verfuegbare Wert ist.
Wenn dann die LEDs zu dunkel leuchten, dann braucht's neun Transistoren mehr und eine eigene Stromversorgung.

Falls ich mit einer Antwort helfen konnte, wuerde ich mich freuen, ein paar Fotos oder auch ein kleines Filmchen des zugehoerigen Projekts zu sehen.
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
30.04.2014, 20:20
Beitrag #11
RE: Problem mit 3x3x3 LED Würfel
Wie wäre es mit einem MAX7219 Treiberbaustein von Maxim der kann 8x8 LED's ansteuern und wird über die SPI Schnittstelle gefüttert. Das würde für einen 4x4x4 Würfel sogar reichen und man ist alle Schaltungstechnischen Probleme los.
lg
bk

1+1 = 10 Angel ...und ich bin hier nicht der Suchmaschinen-Ersatz Dodgy...nur mal so als genereller Tipp..
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
01.05.2014, 09:05
Beitrag #12
RE: Problem mit 3x3x3 LED Würfel
Also mit 9 Transistoren hab ich hier mal ein Plan gefunden:

[Bild: d9bab3-1398931186.jpg]

Aber jede LED mit eigenem Vorwiderstand das hab ich noch nie gesehen !
Wie soll ich dann die LEDs als Cube verlöten wenn ich jeden Pin auf einen Widerstand bringen muss ?

Am liebsten wäre mir schon die Stromversorgung vom UNO selber !
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
01.05.2014, 09:26 (Dieser Beitrag wurde zuletzt bearbeitet: 01.05.2014 09:42 von Thorsten Pferdekämper.)
Beitrag #13
RE: Problem mit 3x3x3 LED Würfel
(01.05.2014 09:05)Busmaster schrieb:  Also mit 9 Transistoren hab ich hier mal ein Plan gefunden:
Mir scheinen das eher 12 zu sein...
Ich glaube, die LEDs sind falschrum eingezeichnet. Ansonsten sieht das prinzipiell ok aus. Ich würde allerdings keine 12V Spannungsversorung nehmen, da hier das meiste über die Widerstände verheizt wird. 5V wären da meiner Meinung nach passender. Natürlich muss man dann die Widerstandswerte anpassen.
Zitat:Aber jede LED mit eigenem Vorwiderstand das hab ich noch nie gesehen !
Wie soll ich dann die LEDs als Cube verlöten wenn ich jeden Pin auf einen Widerstand bringen muss ?
Tja, dann werden die LEDs halt mit unterschiedlicher Helligkeit leuchten, je nachdem wie viele der drei LEDs am selben Widerstand gerade an sind.
Zitat:Am liebsten wäre mir schon die Stromversorgung vom UNO selber !
Dann musst Du das ganze so dimensionieren, dass insgesamt nie mehr als 200mA fließen und pro Port nie mehr als 20mA.
Gruß,
Thorsten

Ok, das mit den Vorwiderständen war quatsch. Das ganze geht ja sowieso über Multiplexing und es leuchtet eigentlich immer nur eine LED in einer Dreierreihe. So lange man auch immer brav mit Multiplexing arbeitet, sollte eine 3er Matrix auch kein Problem mit der Stromversorgung machen.
Gruß,
Thorsten

Falls ich mit einer Antwort helfen konnte, wuerde ich mich freuen, ein paar Fotos oder auch ein kleines Filmchen des zugehoerigen Projekts zu sehen.
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
01.05.2014, 09:47
Beitrag #14
RE: Problem mit 3x3x3 LED Würfel
(01.05.2014 09:05)Busmaster schrieb:  Also mit 9 Transistoren hab ich hier mal ein Plan gefunden:

[Bild: d9bab3-1398931186.jpg]

Aber jede LED mit eigenem Vorwiderstand das hab ich noch nie gesehen !
Wie soll ich dann die LEDs als Cube verlöten wenn ich jeden Pin auf einen Widerstand bringen muss ?

Am liebsten wäre mir schon die Stromversorgung vom UNO selber !

Tolle Schaltung, oder wie kille ich 27 LED's auf einen Streich !!
LED's betreibt man in Durchlassrichtung...sind keine Z-Dioden.
Und die Ansteuerung von dem Plus Zweig mit NPN Transistoren ist ja wohl auch ein Witz oder fehlt da noch ein bedeutender Teil der Ansteuerschaltung ?
Weil nähme man da PNP Transistoren dann käme man auch mit einer 5V Versorgung aus.
Nur mal so am Rande was Schaltungstechnik angeht.
lg
bk

1+1 = 10 Angel ...und ich bin hier nicht der Suchmaschinen-Ersatz Dodgy...nur mal so als genereller Tipp..
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
01.05.2014, 09:56
Beitrag #15
RE: Problem mit 3x3x3 LED Würfel
Hallo!
Man könnte ja die Versorgung vom UNO aufteilen, dann geht der Laststrom
am Board vorbei.
Bei der Schaltung ist für 12 Volt der Vorwiderstand für eine Ebene
unterdimensioniert. So kann man auch auf kosten der Led Lebensdauer eine
zweite Ebene gut versorgen...bei der dritten wirds dann knapp.

Die R14 bis R22 entfallen, die einzelnen Widerstände ( R220 bei 5Volt) können auch direkt an den Led-Anschlüssen verlötet werden.
Kurz und "Kühl" löten (Bleifreies Lot vermeiden), den Draht zur Led mit einer Spitz oder Flachzange kühlen,
Vor dem weiteren zusammenbau auf Funktion prüfen.

mfg Martin
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
02.05.2014, 07:27
Beitrag #16
RE: Problem mit 3x3x3 LED Würfel
Also lange Diskussion Huh, obwohl mein Plan vom 1. Post ja dann doch gepasst hat wenn ich Multiplexing mache ?!!

[Bild: 49b3f3-1398538428.jpg]

Da immer nur eine LED an ist wird das Board nicht überlastet und die LEDs sind auch hell genug mit nur einem Widerstand davor Idea

lg
Mike
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
Antwort schreiben 


Möglicherweise verwandte Themen...
Thema: Verfasser Antworten: Ansichten: Letzter Beitrag
Bug Hardware Problem (!) Gandalf 34 838 06.11.2016 07:29
Letzter Beitrag: Pardini
  Arduino Esplora und Medion Life-Tab P9516, Problem mit usb-Schnittstelle MSchroeder 2 119 15.10.2016 22:18
Letzter Beitrag: MSchroeder
  ESP8266-01 Problem mit UDP loglo 5 382 03.08.2016 07:49
Letzter Beitrag: loglo
  Problem mit adafruit motor shield Philthy 13 1.827 22.12.2015 15:27
Letzter Beitrag: hotsystems
  Bootloader/Port/Programmer Problem mit altem Diecimila HaWe 7 1.224 29.07.2015 13:10
Letzter Beitrag: HaWe
  FTDI FT232R Problem BennIY 5 1.428 07.07.2015 22:38
Letzter Beitrag: BennIY
  Problem mit tone() bei Frequenz >11kHz torsten_156 9 2.051 04.07.2015 18:29
Letzter Beitrag: torsten_156
Question Zwei RC522 RFID Reader -> Problem durch Kabel? vtx 2 814 24.06.2015 11:13
Letzter Beitrag: vtx
  LCD 1602 (ohne SPI) - Problem mit Sonderfunktionen ?!? zauche 4 948 19.06.2015 14:04
Letzter Beitrag: zauche
  Arduino MEGA 2560 - HoodLoader v2 Problem zauche 0 867 18.06.2015 22:54
Letzter Beitrag: zauche

Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste