INFO: Dieses Forum nutzt Cookies...
Cookies sind für den Betrieb des Forums unverzichtbar. Mit der Nutzung des Forums erklärst Du dich damit einverstanden, dass wir Cookies verwenden.

Es wird in jedem Fall ein Cookie gesetzt um diesen Hinweis nicht mehr zu erhalten. Desweiteren setzen wir Google Adsense und Google Analytics ein.

Antwort schreiben 
 
Themabewertung:
  • 0 Bewertungen - 0 im Durchschnitt
  • 1
  • 2
  • 3
  • 4
  • 5
Problem bei Schleife
23.08.2014, 16:21
Beitrag #9
RE: Problem bei Schleife
(22.08.2014 19:06)Thorsten Pferdekämper schrieb:  Hi,
es gibt keinen "Schluss". Loop() wird so lange aufgerufen, bis der Strom leer ist.
Ich glaube jetzt aber, dass ich verstehe, was Du willst.
Packe das, was Du bisher hast, in eine eigene Funktion. Die rufst Du auf, wenn der Näherungssensor auslöst. In der loop() wartest Du einfach auf den Näherungssensor. Also etwa:
Code:
void loop() {
  if(Näherungssensor löst aus)
       deineFunktion();
}

Das dürfte alles sein, da ansonsten loop() einfach wieder und wieder aufgerufen wird.
Gruß,
Thorsten



Okay ich probiere es mal aus wenn der Sensor da ist. Danke
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
23.08.2014, 17:03
Beitrag #10
RE: Problem bei Schleife
..naja...man kann alles improvisieren...
man packt den Code in eine while Schleife rein und schafft ein Abbruchkriterium und die CPU ackert nur noch die Loop durch ohne wirklich was auszuführen...
Code:
byte loopflag;

void setup()   {    
loopflag = true;
}

void loop() {
  
while(loopflag){      //  while Schleife Start

......hier kommt dann der Code hin...

  if(Loop == fertig)loopflag = false;   // Abbruch einleiten
}                          // while Schleife Ende

    // nichts zu tun...while wieder abfragen
}
habe ich so zum Spaß mal getestet mit Taster abfragen als Abbruchkriterium.
lg
bk

1+1 = 10 Angel ...und ich bin hier nicht der Suchmaschinen-Ersatz Dodgy...nur mal so als genereller Tipp..
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
Antwort schreiben 


Möglicherweise verwandte Themen...
Thema: Verfasser Antworten: Ansichten: Letzter Beitrag
  Problem mit externem Interrupt manfred474 13 501 13.08.2017 08:54
Letzter Beitrag: MicroBahner
  Problem mit Klassen GuaAck 4 204 09.08.2017 09:28
Letzter Beitrag: MicroBahner
Question Problem mit TFT Sam217 8 553 20.07.2017 21:51
Letzter Beitrag: hotsystems
  Problem FastLED fliege_m 3 340 16.07.2017 16:56
Letzter Beitrag: Tommy56
Question Problem beim Hochladen auf AtTiny45. Hilfe -.- Jonas Lindenblatt 17 1.104 16.04.2017 12:58
Letzter Beitrag: Jonas Lindenblatt
  Welche schleife macht Sinn? Franklin 11 495 18.03.2017 15:39
Letzter Beitrag: MicroBahner
  Programmierung Schleife florikus 0 262 03.03.2017 18:46
Letzter Beitrag: florikus
  Smart Home Webserver Basic Authentication Problem Osotastic 21 993 20.02.2017 18:00
Letzter Beitrag: Tommy56
  Problem mit Sketch senden an Uno feuerwehr 5 807 31.01.2017 20:41
Letzter Beitrag: Tommy56
  Loop Schleife abbrechen mittlig1977 1 588 06.01.2017 22:18
Letzter Beitrag: Tommy56

Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste