INFO: Dieses Forum nutzt Cookies...
Cookies sind für den Betrieb des Forums unverzichtbar. Mit der Nutzung des Forums erklärst Du dich damit einverstanden, dass wir Cookies verwenden.

Es wird in jedem Fall ein Cookie gesetzt um diesen Hinweis nicht mehr zu erhalten. Desweiteren setzen wir Google Adsense und Google Analytics ein.

Antwort schreiben 
 
Themabewertung:
  • 0 Bewertungen - 0 im Durchschnitt
  • 1
  • 2
  • 3
  • 4
  • 5
Problem bei Schleife
22.08.2014, 12:45
Beitrag #1
Problem bei Schleife
Hallo ich bin neu hier und hab einige Probleme zu Zeit noch mit meinem Arduino Uno.
Ich möchte gerne einen Servo Motor eine bestimmte Abfolge mehrmals wiederholen lassen zB: 5 mal die Bewegung 90-150° verfahren, ohne das ich 5 mal den Eingabetext wiederholen muss. Wie ist das möglich, dass in eine Schleife zu packen die nach den 5 mal auch aufhört und das danach meine Programm mit den weiteren Servors weiter macht?

Vielen Dank
Gruß Lukas


#include <Servo.h>
Servo Mund ;
Servo Nicken;

void setup()
{
Mund.attach(3);
Nicken.attach(5);
}
void loop()
{

Nicken.write(90);
delay(350); // ( 5 x wiederholen)
Nicken.write(150);
delay(350);


}


Mund.write(0);
delay(2050);
Mund.write(110);
delay(250);

.................
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
22.08.2014, 13:13
Beitrag #2
RE: Problem bei Schleife
Code:
for(int i = 0; i < 5; i++) {
  // hier Deinen Code
}

Falls ich mit einer Antwort helfen konnte, wuerde ich mich freuen, ein paar Fotos oder auch ein kleines Filmchen des zugehoerigen Projekts zu sehen.
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
22.08.2014, 13:43 (Dieser Beitrag wurde zuletzt bearbeitet: 22.08.2014 13:46 von lukass89.)
Beitrag #3
RE: Problem bei Schleife
Es funktioniert einwandfrei hatte vergessen den 2 Servo frei zuschalten (//) , deshalb machte er nur die Nicken Bewegung und das mehr als 5 mal dann.

Vielen Dank
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
22.08.2014, 13:52
Beitrag #4
RE: Problem bei Schleife
Hi,
wenn möglich Nachfragen nicht als PM, dann haben alle was davon.
Da sich das ganze in loop() abspielt geht es am Ende natürlich wieder von vorne los.
Gruß,
Thorsten

Falls ich mit einer Antwort helfen konnte, wuerde ich mich freuen, ein paar Fotos oder auch ein kleines Filmchen des zugehoerigen Projekts zu sehen.
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
22.08.2014, 14:27 (Dieser Beitrag wurde zuletzt bearbeitet: 22.08.2014 14:27 von lukass89.)
Beitrag #5
RE: Problem bei Schleife
Okay verstanden, dann hätte ich noch eine Frage wie kann ich zwei Servos Parallel laufen lassen, unterschiedliche Pins und unterschiedliche Winkel Zeiten usw?
Und wie kann ich das ganze Programm benenden?
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
22.08.2014, 14:53
Beitrag #6
RE: Problem bei Schleife
(22.08.2014 14:27)lukass89 schrieb:  Okay verstanden, dann hätte ich noch eine Frage wie kann ich zwei Servos Parallel laufen lassen, unterschiedliche Pins und unterschiedliche Winkel Zeiten usw?
Das ist jetzt das übliche Spiel. Du musst als erstes die delay() loswerden. Such mal nach "blink without delay". Bau' das nach und verstehe jedes Bit davon.
Danach hast Du eine Chance etwas zu machen, dass so aussieht, als ob zwei Sachen parallel laufen.
Zitat:Und wie kann ich das ganze Programm benenden?
Gar nicht. Das ist auch gar nicht Sinn der Sache. Warum auch?

Gruß,
Thorsten

Falls ich mit einer Antwort helfen konnte, wuerde ich mich freuen, ein paar Fotos oder auch ein kleines Filmchen des zugehoerigen Projekts zu sehen.
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
22.08.2014, 18:16
Beitrag #7
RE: Problem bei Schleife
(22.08.2014 14:53)Thorsten Pferdekämper schrieb:  
(22.08.2014 14:27)lukass89 schrieb:  Okay verstanden, dann hätte ich noch eine Frage wie kann ich zwei Servos Parallel laufen lassen, unterschiedliche Pins und unterschiedliche Winkel Zeiten usw?
Das ist jetzt das übliche Spiel. Du musst als erstes die delay() loswerden. Such mal nach "blink without delay". Bau' das nach und verstehe jedes Bit davon.
Danach hast Du eine Chance etwas zu machen, dass so aussieht, als ob zwei Sachen parallel laufen.
Zitat:Und wie kann ich das ganze Programm benenden?
Gar nicht. Das ist auch gar nicht Sinn der Sache. Warum auch?

Gruß,
Thorsten


Okay vielen Dank,
wie bekomme ich es dann theoretisch hin, wenn ich das Programm mit einem Näherungssensor starten will, durchlaufen lassen will und das es nicht von vorne anfängt, wenn jemand den Sensor während des Programms wieder aktiviert durch eine Bewegung.
Oder ist der Arduino so schlau und läuft das Programm bis zum Schluss durch.?
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
22.08.2014, 19:06
Beitrag #8
RE: Problem bei Schleife
Hi,
es gibt keinen "Schluss". Loop() wird so lange aufgerufen, bis der Strom leer ist.
Ich glaube jetzt aber, dass ich verstehe, was Du willst.
Packe das, was Du bisher hast, in eine eigene Funktion. Die rufst Du auf, wenn der Näherungssensor auslöst. In der loop() wartest Du einfach auf den Näherungssensor. Also etwa:
Code:
void loop() {
  if(Näherungssensor löst aus)
       deineFunktion();
}

Das dürfte alles sein, da ansonsten loop() einfach wieder und wieder aufgerufen wird.
Gruß,
Thorsten

Falls ich mit einer Antwort helfen konnte, wuerde ich mich freuen, ein paar Fotos oder auch ein kleines Filmchen des zugehoerigen Projekts zu sehen.
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
Antwort schreiben 


Möglicherweise verwandte Themen...
Thema: Verfasser Antworten: Ansichten: Letzter Beitrag
  mit if aus do-while oder while Schleife aussteigen Nafetz 6 116 05.12.2016 21:41
Letzter Beitrag: Pit
  while Schleife nach sleep mode interrupt tklaus 13 262 23.11.2016 17:40
Letzter Beitrag: Tommy56
  Do-While-Schleife Abbruchbedinung Majera 14 261 22.11.2016 18:07
Letzter Beitrag: Pit
  Schleife Hannes 3 196 16.11.2016 00:54
Letzter Beitrag: Hannes
  Problem mit SD Card Library BennIY 4 193 06.10.2016 18:38
Letzter Beitrag: Bitklopfer
  Problem mit SD.remove Eichner 6 212 22.08.2016 19:42
Letzter Beitrag: Eichner
  4x16 Tastermatrix Problem Michel 16 852 14.07.2016 10:02
Letzter Beitrag: StephanBuerger
  Problem mit Delay und Millis funnyzocker 1 459 26.06.2016 09:54
Letzter Beitrag: hotsystems
  Problem mit ESP8266 und EMail senden torsten_156 1 605 13.06.2016 21:14
Letzter Beitrag: torsten_156
  ESP8266_01 flashen - Problem torsten_156 12 1.056 30.05.2016 20:12
Letzter Beitrag: torsten_156

Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste