INFO: Dieses Forum nutzt Cookies...
Cookies sind für den Betrieb des Forums unverzichtbar. Mit der Nutzung des Forums erklärst Du dich damit einverstanden, dass wir Cookies verwenden.

Es wird in jedem Fall ein Cookie gesetzt um diesen Hinweis nicht mehr zu erhalten. Desweiteren setzen wir Google Adsense und Google Analytics ein.

Antwort schreiben 
 
Themabewertung:
  • 0 Bewertungen - 0 im Durchschnitt
  • 1
  • 2
  • 3
  • 4
  • 5
Plötzlicher Tod von 2 Nanos zu betrauern...
05.02.2015, 10:46 (Dieser Beitrag wurde zuletzt bearbeitet: 05.02.2015 10:52 von Kyrill.)
Beitrag #1
Plötzlicher Tod von 2 Nanos zu betrauern...
Ich habe für eine Lipo-Transport-Kiste eine Wärmeeinheit nach dem anhängenden Schaltplan mit einem Arduino Nano geregelt.
Die Regelung funktionierte einwandfrei. Der Wärmeakku, ein 3 S Lipo (12,6 Volt) versorgt den Arduino Nano und auch die Wärmeeinheit aus einem 12 Volt Lüfter und einer Heizwicklung aus Widerstandsdraht.
Gleichzeitig wird an einem Analog-pin die Eingangsspannung überwacht und bei Unterspannung wird ebenfalls abgeschaltet.
An einem anderen Analog-pin wird mittels Spannungsteiler aus Festwiderstand und NTC die Temperatur gemessen und bei Überschreiten abgeschaltet.

Das ging alles wunderbar bis zu dem Zeitpunkt wo ich gestern an das laufende System das USB Kabel anschloß um die Variablen ein wenig nachzujustieren. Im Augenblick wo ich den USB Stecker einsteckte rauchte der Arduino ab. Prozessor wurde heiß.

Auch ein zweiter Versuch mit einem weiteren Nano überlebte dieser nicht.

Aufgefallen ist mir nur, dass der Nano offenbar einen Reset durchführt wenn das USB Kabel eingesteckt wird, oder der serial Monitor in der Software ausgewählt wird. Aber woran stirbt der Nano? Einen Kurzschluß oder ähnliche Defekte konnte ich nicht nachweisen auf der Platine. Hat ja auch vorher einwandfrei gearbeitet. Hat jemand eine Idee?


Angehängte Datei(en) Thumbnail(s)
   

Gruß aus Lünen

Peter
Webseite des Benutzers besuchen Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
05.02.2015, 11:09
Beitrag #2
RE: Plötzlicher Tod von 2 Nanos zu betrauern...
Hi,
also der Reset ist normal, würde ich mal sagen. Allerdings:
Zitat:The Arduino Nano can be powered via the Mini-B USB connection, 6-20V unregulated external power supply (pin 30), or 5V regulated external power supply (pin 27). The power source is automatically selected to the highest voltage source.
Das ist von http://arduino.cc.
D.h. wenn man über den 5V (Vcc) Pin versorgt und dann USB ansteckt, kann ich mir vorstellen, dass es Probleme bereitet. Bei einer Spannungsversorgung über Vin mit über 6V dürfte das allerdings nicht passieren.
Ist das vielleicht irgend ein Clone, bei dem die entsprechende Schaltung einfach weggelassen wurde?

Ich bin inzwischen dazu übergegangen, immer entweder über USB zu versorgen oder anders. D.h. die Spannungsversorgung ist bei mir immer mit einem Stecker versehen, den ich abstöpsle, bevor ich USB verbinde. Eine andere Alternative ist, den 5V-Draht im USB-Kabel zu kappen.

Gruß,
Thorsten

Falls ich mit einer Antwort helfen konnte, wuerde ich mich freuen, ein paar Fotos oder auch ein kleines Filmchen des zugehoerigen Projekts zu sehen.
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
05.02.2015, 11:38
Beitrag #3
RE: Plötzlicher Tod von 2 Nanos zu betrauern...
Ja war ein China clon. Gott sei dank. so hält sich der Verlust in Grenzen :-). Aber das nächste Mal werde ich auch nur entweder oder anstöpseln.

Ist der serial Monitor noch nutzbar wenn die 5 Volt Strippe im USB Kabel durchtrennt wird? Und kann ich dann trotzdem mit Fremdspannungsversorgung an +Vin den Arduino noch umprogrammieren über das Kabel?

Gruß aus Lünen

Peter
Webseite des Benutzers besuchen Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
05.02.2015, 12:02
Beitrag #4
RE: Plötzlicher Tod von 2 Nanos zu betrauern...
(05.02.2015 11:38)Kyrill schrieb:  Ist der serial Monitor noch nutzbar wenn die 5 Volt Strippe im USB Kabel durchtrennt wird?
Das geht auf jeden Fall, ich habs ausprobiert.

Zitat: Und kann ich dann trotzdem mit Fremdspannungsversorgung an +Vin den Arduino noch umprogrammieren über das Kabel?
Da bin ich mir nicht 100%ig sicher, aber ich glaube schon.
Gruß,
Thorsten

Falls ich mit einer Antwort helfen konnte, wuerde ich mich freuen, ein paar Fotos oder auch ein kleines Filmchen des zugehoerigen Projekts zu sehen.
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
06.02.2015, 06:53
Beitrag #5
RE: Plötzlicher Tod von 2 Nanos zu betrauern...
Hab jetzt eine neue Platine gefertigt. Diese hat zunächst mal Buchsenleisten zum einfacheren Austausch des Arduionos. Außerdem kann man so an bislang unbenutzte Kontakte nachträglich noch eine Buchse zwischenlöten zB für eine zusätzliche Anzeige über LED oder so etwas. Zur Not kann man den Arduino auch mal entnehmen und zu anderen Zwecken verwenden wenn mal gerade keiner zur Hand ist.

Ich werde nicht mehr ohne Buchsenleisten aufbauen, das Auslöten eines Arduino gestaltet sich mehr als schwierig. (Ohne Entlötpumpe nur mit Sauglitze.) Außerdem bekommt man so unterhalb 1 cm Platz für weitere Bauteile.

Nun ja viel gelernt aus dem Schaden und nun geht sie wieder die Kiste wie sie soll.

Jetzt noch eine LED nach außen zur Betriebszustandsanzeige und fertig...

Gruß aus Lünen

Peter
Webseite des Benutzers besuchen Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
06.02.2015, 07:13
Beitrag #6
RE: Plötzlicher Tod von 2 Nanos zu betrauern...
(05.02.2015 10:46)Kyrill schrieb:  Ich habe für eine Lipo-Transport-Kiste eine Wärmeeinheit nach dem anhängenden Schaltplan mit einem Arduino Nano geregelt.
Die Regelung funktionierte einwandfrei. Der Wärmeakku, ein 3 S Lipo (12,6 Volt) versorgt den Arduino Nano und auch die Wärmeeinheit aus einem 12 Volt Lüfter und einer Heizwicklung aus Widerstandsdraht.
Gleichzeitig wird an einem Analog-pin die Eingangsspannung überwacht und bei Unterspannung wird ebenfalls abgeschaltet.
An einem anderen Analog-pin wird mittels Spannungsteiler aus Festwiderstand und NTC die Temperatur gemessen und bei Überschreiten abgeschaltet.

Das ging alles wunderbar bis zu dem Zeitpunkt wo ich gestern an das laufende System das USB Kabel anschloß um die Variablen ein wenig nachzujustieren. Im Augenblick wo ich den USB Stecker einsteckte rauchte der Arduino ab. Prozessor wurde heiß.

Auch ein zweiter Versuch mit einem weiteren Nano überlebte dieser nicht.

Aufgefallen ist mir nur, dass der Nano offenbar einen Reset durchführt wenn das USB Kabel eingesteckt wird, oder der serial Monitor in der Software ausgewählt wird. Aber woran stirbt der Nano? Einen Kurzschluß oder ähnliche Defekte konnte ich nicht nachweisen auf der Platine. Hat ja auch vorher einwandfrei gearbeitet. Hat jemand eine Idee?

Hallo,
also deine Schaltung scheint so einwandfrei zu sein, daher vermute ich eher mal das es irgendwo eine weitere Verbindung von deinem 12V Stromkreis der Lipo's und dem PC gibt...und zwar müßten da die +12V irgendwie Kontakt mit der Masse vom PC haben und wenn dann der USB Stecker gesteckt wird wirds bischen warm...
oder der MOSFet ist falsch angeschlossen...was ist das denn für ein Typ genau ?
Und der Reset darf so nichts ausmachen weil dann der Ausgang zum MOSFet Hochohmig wird und dein 10K Widerstand den MOSi zum sperren bringt.
Weil ich habe auch schon was ähnlich aufgebaut 12V (8xMignon) und dann auch über USB Daten ausgelesen bzw. den Nano programmiert und da hatte ich nie Probleme....war allerdings auch kein Fernost Produkt sondern von nem renomierten Distri in Germany.
lg
bk

1+1 = 10 Angel ...und ich bin hier nicht der Suchmaschinen-Ersatz Dodgy...nur mal so als genereller Tipp..
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
Antwort schreiben 


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste