INFO: Dieses Forum nutzt Cookies...
Cookies sind für den Betrieb des Forums unverzichtbar. Mit der Nutzung des Forums erklärst Du dich damit einverstanden, dass wir Cookies verwenden.

Es wird in jedem Fall ein Cookie gesetzt um diesen Hinweis nicht mehr zu erhalten. Desweiteren setzen wir Google Adsense und Google Analytics ein.

Antwort schreiben 
 
Themabewertung:
  • 0 Bewertungen - 0 im Durchschnitt
  • 1
  • 2
  • 3
  • 4
  • 5
Pin 5 an Pro Micro funktioniert nicht
06.09.2016, 08:10
Beitrag #1
Pin 5 an Pro Micro funktioniert nicht
Hallo zusammen. Für einen Multicopter nutze ich als Flugcontroller einen
Pro Micro. Einer der Motoren bzw. Speed-Controller hängt an Pin 5.
Leider funktioniert der hier angeschlossene Motor nicht. Der Fehler
bleibt wenn ich einen anderen Motor an diesem Pin teste. Ich dachte
zuerst das läge daran dass der Pin defekt ist, bei einem nagelneuen Pro
Micro ist es aber dasselbe Problem. Was kann man da machen, woran kann
das liegen? Im Anhang ist der Code zu finden, falls es hilft.


Angehängte Datei(en)
.zip  MultiWii.zip (Größe: 163,43 KB / Downloads: 17)
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
07.09.2016, 13:54
Beitrag #2
RE: Pin 5 an Pro Micro funktioniert nicht
Hallo,
hast du das Programm selbst geschrieben?

Es sieht sehr aufgeräumt aus, wegen der vielen Tabs ist es aber auch wieder unübersichtlich. Rolleyes

An welcher Stelle wird Pin 5 den initialisiert?

Gruß
Arne

ExclamationMit zunehmender Anzahl qualifizierter Informationen bei einer Problemstellung, erhöht sich zwangsläufig die Gefahr auf eine zielführende Antwort.Exclamation
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
Antwort schreiben 


Möglicherweise verwandte Themen...
Thema: Verfasser Antworten: Ansichten: Letzter Beitrag
  Arduino Uno R3, servos reagieren nicht auf die Befehle Crossedsticks 5 324 22.02.2017 22:42
Letzter Beitrag: Binatone
  4-fach Relaiskarte HL-54 zieht nicht richtig an. Kriskind 13 547 12.02.2017 23:51
Letzter Beitrag: Tommy56
  Arduino Micro - Probleme madin 65 2.582 07.01.2017 18:50
Letzter Beitrag: Harry Hirsch
  ws2812b + nodemcu Ich finde den Fehler nicht. Tha_Coralis 16 1.032 15.12.2016 18:37
Letzter Beitrag: Harry Hirsch
  USB-Gerät wird nicht erkannt kpc 4 559 13.12.2016 15:48
Letzter Beitrag: René Hitz
  Arduino Micro Bootlader Cabriolöwe 11 557 12.12.2016 18:58
Letzter Beitrag: Harry Hirsch
  Bluetooth-Steuerung mit elegoo uno funktioniert nicht Matthias_Arduino 0 460 01.11.2016 19:47
Letzter Beitrag: Matthias_Arduino
  Nema 17 Schrittmotor läuft an a4988 nicht fagus 9 967 04.08.2016 20:12
Letzter Beitrag: fagus
  LCD 1602 mit HD44780 TWI Controller funktioinert nicht mehr emduino 2 346 26.07.2016 20:42
Letzter Beitrag: hotsystems
  Uno gehen zwei digital Pins nicht edlosijagen 15 822 07.07.2016 19:22
Letzter Beitrag: Bitklopfer

Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste